summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-25 07:09:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-25 07:09:15 +0000
commit903f351acc914d0ee1877d67bef99e7ac31e87b4 (patch)
treee9d0cc7c6efe2e7f494c333cfcb2e181d918e238
parentlets help the user (diff)
downloadhistorical-903f351acc914d0ee1877d67bef99e7ac31e87b4.tar.gz
historical-903f351acc914d0ee1877d67bef99e7ac31e87b4.tar.bz2
historical-903f351acc914d0ee1877d67bef99e7ac31e87b4.zip
initial commit - ebuild based on the one provided by LepeL via bug #65143
-rw-r--r--games-puzzle/tint/ChangeLog10
-rw-r--r--games-puzzle/tint/Manifest5
-rw-r--r--games-puzzle/tint/files/0.03a-warnings.patch31
-rw-r--r--games-puzzle/tint/files/digest-tint-0.03a1
-rw-r--r--games-puzzle/tint/metadata.xml5
-rw-r--r--games-puzzle/tint/tint-0.03a.ebuild40
6 files changed, 92 insertions, 0 deletions
diff --git a/games-puzzle/tint/ChangeLog b/games-puzzle/tint/ChangeLog
new file mode 100644
index 000000000000..db9781ce7288
--- /dev/null
+++ b/games-puzzle/tint/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-puzzle/tint
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tint/ChangeLog,v 1.1 2004/09/25 07:09:15 mr_bones_ Exp $
+
+*tint-0.03a (25 Sep 2004)
+
+ 25 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.03a-warnings.patch, +tint-0.03a.ebuild:
+ initial commit - ebuild based on the one provided by LepeL via bug #65143
+
diff --git a/games-puzzle/tint/Manifest b/games-puzzle/tint/Manifest
new file mode 100644
index 000000000000..0ab7aba4fb67
--- /dev/null
+++ b/games-puzzle/tint/Manifest
@@ -0,0 +1,5 @@
+MD5 9ea3c61011ffa0436e87864887ecc656 tint-0.03a.ebuild 946
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 5049af1742aadbbb5d8aa2789a160de2 ChangeLog 420
+MD5 5289223409923d86537f6acd9f5d89e6 files/digest-tint-0.03a 61
+MD5 31cc566233024fe86488f53441aaf631 files/0.03a-warnings.patch 740
diff --git a/games-puzzle/tint/files/0.03a-warnings.patch b/games-puzzle/tint/files/0.03a-warnings.patch
new file mode 100644
index 000000000000..5dc1cfa7aa39
--- /dev/null
+++ b/games-puzzle/tint/files/0.03a-warnings.patch
@@ -0,0 +1,31 @@
+--- tint.c.orig 2004-09-24 19:28:16.000000000 -0700
++++ tint.c 2004-09-24 19:28:27.000000000 -0700
+@@ -651,7 +651,7 @@
+ shapecount[engine.curshape]++;
+ break;
+ /* shape moved down one line */
+- case 1:
++ case 1:;
+ }
+ }
+ }
+--- engine.c.orig 2004-09-24 19:26:04.000000000 -0700
++++ engine.c 2004-09-24 19:28:01.000000000 -0700
+@@ -27,6 +27,8 @@
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
++#include <stdlib.h>
++#include <string.h>
+ #include "typedefs.h"
+ #include "utils.h"
+ #include "io.h"
+@@ -94,7 +96,7 @@
+ case 5:
+ real_rotate (shape,FALSE);
+ break;
+- case 3: /* This one is not rotated at all */
++ case 3:; /* This one is not rotated at all */
+ }
+ }
+
diff --git a/games-puzzle/tint/files/digest-tint-0.03a b/games-puzzle/tint/files/digest-tint-0.03a
new file mode 100644
index 000000000000..f39af468dd74
--- /dev/null
+++ b/games-puzzle/tint/files/digest-tint-0.03a
@@ -0,0 +1 @@
+MD5 e89e47bafcd3be1184b3e334927a5a79 tint_0.03a.tar.gz 16781
diff --git a/games-puzzle/tint/metadata.xml b/games-puzzle/tint/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/tint/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/tint/tint-0.03a.ebuild b/games-puzzle/tint/tint-0.03a.ebuild
new file mode 100644
index 000000000000..7056e28dcea4
--- /dev/null
+++ b/games-puzzle/tint/tint-0.03a.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tint/tint-0.03a.ebuild,v 1.1 2004/09/25 07:09:15 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_P=${P/-/_}
+DESCRIPTION="Tint Is Not Tetris, a ncurses based clone of the original Tetris(tm) game"
+HOMEPAGE="http://oasis.frogfoot.net/code/tint/"
+SRC_URI="http://oasis.frogfoot.net/code/tint/download/$PV/$MY_P.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.4-r1"
+
+src_unpack() {
+ unpack $A
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-warnings.patch"
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ localstatedir="${GAMES_STATEDIR}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin tint || die "dogamesbin failed"
+ doman tint.6
+ dodoc CREDITS NOTES
+ insopts -m 0664
+ insinto "${GAMES_STATEDIR}"
+ doins tint.scores || die "doins failed"
+ prepgamesdirs
+}