summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-02-22 13:52:57 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-02-22 13:52:57 +0000
commit98055de25e0063726c67c529b90403ade48c29ee (patch)
tree5221d7ac654e0acef978b897cfb53aefe37ead88
parentFix compilation with gcc-4. Add patch to fix compilation when LINGUAS (diff)
downloadhistorical-98055de25e0063726c67c529b90403ade48c29ee.tar.gz
historical-98055de25e0063726c67c529b90403ade48c29ee.tar.bz2
historical-98055de25e0063726c67c529b90403ade48c29ee.zip
Clean up.
Package-Manager: portage-2.0.54
-rw-r--r--app-editors/cute/ChangeLog6
-rw-r--r--app-editors/cute/Manifest6
-rw-r--r--app-editors/cute/cute-0.2.9-r1.ebuild62
-rw-r--r--app-editors/cute/cute-0.2.9.ebuild53
-rw-r--r--app-editors/cute/files/digest-cute-0.2.91
-rw-r--r--app-editors/cute/files/digest-cute-0.2.9-r11
6 files changed, 6 insertions, 123 deletions
diff --git a/app-editors/cute/ChangeLog b/app-editors/cute/ChangeLog
index 5ae8c45eb57f..9ac02e6938ab 100644
--- a/app-editors/cute/ChangeLog
+++ b/app-editors/cute/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/cute
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cute/ChangeLog,v 1.23 2006/01/15 11:47:40 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cute/ChangeLog,v 1.24 2006/02/22 13:52:56 carlo Exp $
+
+ 22 Feb 2006; Carsten Lohrke <carlo@gentoo.org> -cute-0.2.9.ebuild,
+ -cute-0.2.9-r1.ebuild:
+ Clean up.
15 Jan 2006; Michael Hanselmann <hansmi@gentoo.org> cute-0.2.9-r2.ebuild:
Stable on ppc.
diff --git a/app-editors/cute/Manifest b/app-editors/cute/Manifest
index 93c275f5a708..8af6f15dceb3 100644
--- a/app-editors/cute/Manifest
+++ b/app-editors/cute/Manifest
@@ -1,8 +1,4 @@
-MD5 dab2144925d2e4a80a22fcde24a3c315 ChangeLog 2419
-MD5 967cd62e0f3b1904a90740d63dd01dea cute-0.2.9-r1.ebuild 2084
+MD5 b67d81f3726e0e7ae457c867bdbf9285 ChangeLog 2525
MD5 44308f61ec293a051a52e5f92508888e cute-0.2.9-r2.ebuild 2114
-MD5 46be2b5390080bf32c551b20b9fd16ce cute-0.2.9.ebuild 1552
-MD5 d8e651c892fe13f3ed796b87faac96bd files/digest-cute-0.2.9 63
-MD5 d8e651c892fe13f3ed796b87faac96bd files/digest-cute-0.2.9-r1 63
MD5 d8e651c892fe13f3ed796b87faac96bd files/digest-cute-0.2.9-r2 63
MD5 70f06600556327dcfbc31fa03f610042 metadata.xml 155
diff --git a/app-editors/cute/cute-0.2.9-r1.ebuild b/app-editors/cute/cute-0.2.9-r1.ebuild
deleted file mode 100644
index ee11dba2c0fa..000000000000
--- a/app-editors/cute/cute-0.2.9-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cute/cute-0.2.9-r1.ebuild,v 1.7 2006/01/03 12:21:51 caleb Exp $
-
-inherit distutils
-
-MY_P=${PN}-${PV/*.*.*.*/${PV%.*}-${PV##*.}}
-
-DESCRIPTION="CUTE is a Qt and Scintilla based text editor which can be easily extended using Python"
-HOMEPAGE="http://cute.sourceforge.net/"
-SRC_URI="mirror://sourceforge/cute/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ppc ~sparc x86"
-IUSE="doc"
-
-DEPEND="sys-apps/sed
- virtual/python
- <dev-python/qscintilla-1.6"
-
-src_unpack() {
- unpack ${A}
- distutils_python_version
- cd ${S} ; sed -i -e "s:qscintilla::" cute.pro
- rm -rf ${S}/qscintilla ; cd ${S}/cute
-
- sed -i -r -e "s:#define DOC_PATH.*:#define DOC_PATH \"/usr/share/doc/${P}/index.html\":" config.h
-
- # (multi-)lib fix
- sed -i -r -e "s:^QEXTSCINTILLADIR =.*:QEXTSCINTILLADIR = /usr/$(get_libdir):" \
- -e "s:^PYTHON_INCLUDE_DIR =.*:PYTHON_INCLUDE_DIR = /usr/include/python${PYVER}/:" \
- -e "s:^PYTHON_LIB_DIR =.*:PYTHON_LIB_DIR = /usr/$(get_libdir)/python${PYVER}/:" \
- -e "s:unix\:INCLUDEPATH=.*:unix\:INCLUDEPATH= ${QTDIR}/include /usr/include \\\\:" \
- -e "s:-lpython2.2:-lpython${PYVER}:" \
- -e "s:SCINTILLADIR/lib:SCINTILLADIR:" cute.pro
-
- echo -e "\nQMAKE_CFLAGS_RELEASE=${CFLAGS} -w\nQMAKE_CXXFLAGS_RELEASE=${CXXFLAGS} -w\nQMAKE_LFLAGS_RELEASE=${LDFLAGS}" >> cute.pro
-}
-
-src_compile() {
- cd ${S}/cute
- [ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
- addpredict "$QTDIR/etc/settings"
- ${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake -o Makefile cute.pro
- emake || die
-}
-
-src_install() {
- dobin ${S}/bin/cute
- use doc && ( dohtml -r ${S}/cute/doc/doc/*
- dosym index.html /usr/share/doc/${PF}/html/book1.html
- insinto /usr/share/doc/${PF}/api
- doins ${S}/cute/cute-api/html/* )
- insinto /usr/share/cute/langs
- doins ${S}/cute/langs/*
- insinto /usr/share/cute/lib/scripts/
- doins ${S}/cute/scripts/*
- insinto /usr/share/icons
- doins ${S}/cute/icons/cute.xpm
- dodoc changelog.txt LICENSE INSTALL README
-}
diff --git a/app-editors/cute/cute-0.2.9.ebuild b/app-editors/cute/cute-0.2.9.ebuild
deleted file mode 100644
index 648690262d38..000000000000
--- a/app-editors/cute/cute-0.2.9.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cute/cute-0.2.9.ebuild,v 1.11 2006/01/05 08:56:38 chriswhite Exp $
-
-inherit distutils qt3
-
-MY_P=${PN}-${PV/*.*.*.*/${PV%.*}-${PV##*.}}
-
-DESCRIPTION="CUTE is a Qt and Scintilla based text editor which can be easily extended using Python"
-HOMEPAGE="http://cute.sourceforge.net/"
-SRC_URI="mirror://sourceforge/cute/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="ppc"
-IUSE="doc"
-
-DEPEND="sys-apps/sed
- virtual/python
- $(qt_min_version 3.1)
- >=dev-python/qscintilla-1.60"
-
-src_unpack() {
- unpack ${A}
- distutils_python_version
- cd ${S}/cute
- sed -i -e "s:../qscintilla/:${QTDIR}:" -e "s:python2.2:python${PYVER}:g" cute.pro
-}
-
-src_compile() {
- cd ${S}/cute
- [ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
- addpredict "$QTDIR/etc/settings"
- ${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake -o Makefile cute.pro
- sed -i -e "s:CFLAGS = -pipe -O2:CFLAGS = ${CFLAGS}:" \
- -e "s:CXXFLAGS = -pipe -O2:CXXFLAGS = ${CXXFLAGS}:" Makefile
- emake || die
-}
-
-src_install() {
- dobin ${S}/bin/cute
- use doc && ( dohtml -r ${S}/cute/doc/doc/*
- dosym index.html /usr/share/doc/${PF}/html/book1.html
- insinto /usr/share/doc/${PF}/api
- doins ${S}/cute/cute-api/html/* )
- insinto /usr/share/cute/langs
- doins ${S}/cute/langs/*
- insinto /usr/share/cute/lib/scripts/
- doins ${S}/cute/scripts/*
- insinto /usr/share/icons
- doins ${S}/cute/icons/cute.xpm
- dodoc changelog.txt LICENSE INSTALL README
-}
diff --git a/app-editors/cute/files/digest-cute-0.2.9 b/app-editors/cute/files/digest-cute-0.2.9
deleted file mode 100644
index 506f8125c51c..000000000000
--- a/app-editors/cute/files/digest-cute-0.2.9
+++ /dev/null
@@ -1 +0,0 @@
-MD5 08da2882c51f2199ac0812a3500ddec6 cute-0.2.9.tar.gz 1252932
diff --git a/app-editors/cute/files/digest-cute-0.2.9-r1 b/app-editors/cute/files/digest-cute-0.2.9-r1
deleted file mode 100644
index 506f8125c51c..000000000000
--- a/app-editors/cute/files/digest-cute-0.2.9-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 08da2882c51f2199ac0812a3500ddec6 cute-0.2.9.tar.gz 1252932