summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-08-21 02:55:51 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-08-21 02:55:51 +0000
commita20093a6e5e747af9204433068ab54aa46c07432 (patch)
treeddb336e1881e6397b69af3678108cb1004864f80
parentfixum (diff)
downloadhistorical-a20093a6e5e747af9204433068ab54aa46c07432.tar.gz
historical-a20093a6e5e747af9204433068ab54aa46c07432.tar.bz2
historical-a20093a6e5e747af9204433068ab54aa46c07432.zip
unmasked glibc-2.2.4, and the new gcc now depends on ~sys-devel/autoconf-2.13.
-rw-r--r--profiles/package.mask3
-rwxr-xr-xscripts/bootstrap.sh2
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r2.ebuild7
3 files changed, 4 insertions, 8 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index c79ee2a2cc3a..07ea5d9d8af5 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -1,6 +1,3 @@
-#test version of glibc
-=sys-libs/glibc-2.2.4
-
#moved away
kde-apps/cervisia
kde-apps/kbear
diff --git a/scripts/bootstrap.sh b/scripts/bootstrap.sh
index 481718059a0a..6a5a8fb1681b 100755
--- a/scripts/bootstrap.sh
+++ b/scripts/bootstrap.sh
@@ -17,9 +17,9 @@ echo "Using GLIBC $myGLIBC"
export USE="build"
cd /usr/portage
emerge $myPORTAGE || exit
+emerge $myGETTEXT || exit
emerge $myBINUTILS || exit
emerge $myGCC || exit
-emerge $myGETTEXT || exit
unset USE
export USE="`spython -c 'import portage; print portage.settings["USE"];'` bootstrap"
emerge $myGLIBC || exit
diff --git a/sys-devel/gcc/gcc-2.95.3-r2.ebuild b/sys-devel/gcc/gcc-2.95.3-r2.ebuild
index be9270ded2b7..061d6b3873c2 100644
--- a/sys-devel/gcc/gcc-2.95.3-r2.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r2.ebuild,v 1.1 2001/08/20 14:30:19 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r2.ebuild,v 1.2 2001/08/21 02:55:51 drobbins Exp $
SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${P}.tar.gz
@@ -18,13 +18,12 @@ DESCRIPTION="Modern GCC C/C++ compiler"
HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
if [ -z "`use build`" ] ; then
if [ "`use bootstrap`" ] ; then
- DEPEND="nls? ( sys-devel/gettext )"
+ DEPEND="nls? ( sys-devel/gettext ) ~sys-devel/autoconf-2.13"
else
- DEPEND="nls? ( sys-devel/gettext ) sys-apps/texinfo"
+ DEPEND="nls? ( sys-devel/gettext ) sys-apps/texinfo ~sys-devel/autoconf-2.13"
fi
fi
-
src_unpack() {
unpack ${P}.tar.gz