summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-17 20:48:07 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-17 20:48:07 +0000
commitaba27760b33121bf470c2e5169ebb4452eaac112 (patch)
tree7993c33f1002d636b8d2ab2ad69aaf0a05c8ebd8
parentDelete older ebuild. (diff)
downloadhistorical-aba27760b33121bf470c2e5169ebb4452eaac112.tar.gz
historical-aba27760b33121bf470c2e5169ebb4452eaac112.tar.bz2
historical-aba27760b33121bf470c2e5169ebb4452eaac112.zip
Version bump.
Package-Manager: portage-2.2_rc97_p2/cvs/Linux x86_64
-rw-r--r--dev-python/dulwich/ChangeLog8
-rw-r--r--dev-python/dulwich/dulwich-0.6.2.ebuild32
-rw-r--r--dev-python/timelib/ChangeLog8
-rw-r--r--dev-python/timelib/timelib-0.2.2.ebuild22
4 files changed, 68 insertions, 2 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index 6300f4afbbd6..dc1b1bf7c501 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/dulwich
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.18 2010/09/19 23:31:07 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.19 2010/10/17 20:44:29 arfrever Exp $
+
+*dulwich-0.6.2 (17 Oct 2010)
+
+ 17 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +dulwich-0.6.2.ebuild:
+ Version bump.
19 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-dulwich-0.6.0.ebuild:
diff --git a/dev-python/dulwich/dulwich-0.6.2.ebuild b/dev-python/dulwich/dulwich-0.6.2.ebuild
new file mode 100644
index 000000000000..0690e62ff731
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.6.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.6.2.ebuild,v 1.1 2010/10/17 20:44:29 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="http://samba.org/~jelmer/dulwich/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/dulwich/tests"
+ }
+ python_execute_function -q delete_tests
+}
diff --git a/dev-python/timelib/ChangeLog b/dev-python/timelib/ChangeLog
index 21206072adb6..14391f1d2864 100644
--- a/dev-python/timelib/ChangeLog
+++ b/dev-python/timelib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/timelib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/timelib/ChangeLog,v 1.2 2010/01/12 13:41:37 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/timelib/ChangeLog,v 1.3 2010/10/17 20:48:07 arfrever Exp $
+
+*timelib-0.2.2 (17 Oct 2010)
+
+ 17 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -timelib-0.2.1.ebuild, +timelib-0.2.2.ebuild:
+ Version bump.
12 Jan 2010; Christian Faulhammer <fauli@gentoo.org> timelib-0.2.1.ebuild:
add ~x86, bug 297725
diff --git a/dev-python/timelib/timelib-0.2.2.ebuild b/dev-python/timelib/timelib-0.2.2.ebuild
new file mode 100644
index 000000000000..5a2e19990270
--- /dev/null
+++ b/dev-python/timelib/timelib-0.2.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/timelib/timelib-0.2.2.ebuild,v 1.1 2010/10/17 20:48:07 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="parse english textual date descriptions"
+HOMEPAGE="http://pypi.python.org/pypi/timelib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ZLIB PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+PYTHON_CFLAGS=("* + -fno-strict-aliasing")