summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-11-25 11:00:00 +0000
committerTorsten Veller <tove@gentoo.org>2008-11-25 11:00:00 +0000
commitb0d0c827386213f980a985709bdb6b7336994a0b (patch)
treea3bb78a6757389466075f812bb281d344a5e85aa
parentVersion bump. Also fixes bug #248648. (diff)
downloadhistorical-b0d0c827386213f980a985709bdb6b7336994a0b.tar.gz
historical-b0d0c827386213f980a985709bdb6b7336994a0b.tar.bz2
historical-b0d0c827386213f980a985709bdb6b7336994a0b.zip
Version bump
Package-Manager: portage-2.2_rc16/cvs/Linux 2.6.27-tuxonice i686
-rw-r--r--dev-perl/HTTP-Server-Simple/ChangeLog8
-rw-r--r--dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.36.ebuild22
-rw-r--r--dev-perl/HTTP-Server-Simple/files/0.36-debian.patch91
-rw-r--r--dev-perl/Mail-IMAPClient/ChangeLog8
-rw-r--r--dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.12.ebuild24
-rw-r--r--dev-perl/libwww-perl/ChangeLog7
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.821.ebuild30
-rw-r--r--dev-perl/locale-maketext-lexicon/ChangeLog8
-rw-r--r--dev-perl/locale-maketext-lexicon/locale-maketext-lexicon-0.75.ebuild22
9 files changed, 216 insertions, 4 deletions
diff --git a/dev-perl/HTTP-Server-Simple/ChangeLog b/dev-perl/HTTP-Server-Simple/ChangeLog
index fa5ddba0b879..6dd4687802be 100644
--- a/dev-perl/HTTP-Server-Simple/ChangeLog
+++ b/dev-perl/HTTP-Server-Simple/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/HTTP-Server-Simple
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTTP-Server-Simple/ChangeLog,v 1.31 2008/10/23 07:24:03 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTTP-Server-Simple/ChangeLog,v 1.32 2008/11/25 10:51:53 tove Exp $
+
+*HTTP-Server-Simple-0.36 (25 Nov 2008)
+
+ 25 Nov 2008; Torsten Veller <tove@gentoo.org> +files/0.36-debian.patch,
+ +HTTP-Server-Simple-0.36.ebuild:
+ Version bump
*HTTP-Server-Simple-0.35 (23 Oct 2008)
diff --git a/dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.36.ebuild b/dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.36.ebuild
new file mode 100644
index 000000000000..f67718ea3c54
--- /dev/null
+++ b/dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.36.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.36.ebuild,v 1.1 2008/11/25 10:51:53 tove Exp $
+
+MODULE_AUTHOR=ALEXMV
+inherit perl-module eutils
+
+DESCRIPTION="Lightweight HTTP Server"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="dev-lang/perl
+ dev-perl/URI"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST="do"
+PATCHES="${FILESDIR}/${PV}-debian.patch"
diff --git a/dev-perl/HTTP-Server-Simple/files/0.36-debian.patch b/dev-perl/HTTP-Server-Simple/files/0.36-debian.patch
new file mode 100644
index 000000000000..fbb7c443d97a
--- /dev/null
+++ b/dev-perl/HTTP-Server-Simple/files/0.36-debian.patch
@@ -0,0 +1,91 @@
+--- a/t/01live.t
++++ b/t/01live.t
+@@ -34,11 +34,7 @@ for my $class (@classes) {
+ }
+
+
+-TODO: {
+- local $TODO = "We don't currently wait for 'server is running' responses from the client";
+- run_server_tests('SlowServer');
+-
+-}
++run_server_tests('SlowServer');
+
+
+
+From: Niko Tyni <ntyni@iki.fi>
+Subject: [PATCH] Pipe version: parent waits for the child to say "OK" via a pipe.
+
+--- libhttp-server-simple-perl.orig/lib/HTTP/Server/Simple.pm
++++ libhttp-server-simple-perl/lib/HTTP/Server/Simple.pm
+@@ -6,6 +6,7 @@
+ use Socket;
+ use Carp;
+ use URI::Escape;
++use IO::Select;
+
+ use vars qw($VERSION $bad_request_doc);
+ $VERSION = '0.36';
+@@ -206,15 +207,36 @@
+
+ sub background {
+ my $self = shift;
++
++ # set up a pipe so the child can tell the parent when it's ready
++ # to accept requests
++ my ($readfh, $writefh) = FileHandle::pipe;
++
+ my $child = fork;
+ croak "Can't fork: $!" unless defined($child);
+- return $child if $child;
++ if ($child) { # parent
++ my $s = IO::Select->new;
++ $s->add($readfh);
++ my $now = time; my $left = 0;
++ my @ready;
++ while(not @ready and $left < 5) {
++ @ready = $s->can_read($left);
++ $left = time - $now;
++ }
++ die("child unresponsive for 5 seconds") if(not @ready);
++ my $response = <$readfh>;
++ chomp $response;
++ die("child is confused: answer '$response' != 'OK'")
++ if $response ne "OK";
++ return $child;
++ }
+
+ if ( $^O !~ /MSWin32/ ) {
+ require POSIX;
+ POSIX::setsid()
+ or croak "Can't start a new session: $!";
+ }
++ $self->{_parent_handle} = $writefh;
+ $self->run(@_);
+ }
+
+@@ -263,6 +285,7 @@
+ $self->after_setup_listener();
+ *{"$pkg\::run"} = $self->_default_run;
+ }
++ $self->_maybe_tell_parent();
+
+ local $SIG{HUP} = sub { $SERVER_SHOULD_RUN = 0; };
+
+@@ -400,6 +423,16 @@
+ }
+ }
+
++sub _maybe_tell_parent {
++ # inform the parent process that we're ready, if applicable
++ my $self = shift;
++ my $handle = $self->{_parent_handle};
++ return if !$handle;
++ print $handle "OK\n";
++ close $handle;
++ delete $self->{_parent_handle};
++}
++
+ =head2 stdio_handle [FILEHANDLE]
+
+ When called with an argument, sets the socket to the server to that arg.
diff --git a/dev-perl/Mail-IMAPClient/ChangeLog b/dev-perl/Mail-IMAPClient/ChangeLog
index 712a81444f8b..2471092bc535 100644
--- a/dev-perl/Mail-IMAPClient/ChangeLog
+++ b/dev-perl/Mail-IMAPClient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Mail-IMAPClient
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-IMAPClient/ChangeLog,v 1.25 2008/10/09 18:06:12 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-IMAPClient/ChangeLog,v 1.26 2008/11/25 10:48:33 tove Exp $
+
+*Mail-IMAPClient-3.12 (25 Nov 2008)
+
+ 25 Nov 2008; Torsten Veller <tove@gentoo.org>
+ +Mail-IMAPClient-3.12.ebuild:
+ Version bump
*Mail-IMAPClient-3.11 (09 Oct 2008)
diff --git a/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.12.ebuild b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.12.ebuild
new file mode 100644
index 000000000000..bbdd4ef9ffa7
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.12.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.12.ebuild,v 1.1 2008/11/25 10:48:33 tove Exp $
+
+MODULE_AUTHOR=MARKOV
+inherit perl-module eutils
+
+DESCRIPTION="IMAP client module for Perl"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/perl-libnet-1.0703
+ >=dev-perl/Parse-RecDescent-1.94
+ dev-perl/Digest-HMAC
+ dev-lang/perl"
+ #>=virtual/perl-File-Temp-0.18"
+ # only used in t/basic.t
+
+SRC_TEST="do"
+
+mydoc="FAQ"
diff --git a/dev-perl/libwww-perl/ChangeLog b/dev-perl/libwww-perl/ChangeLog
index 5469a470a029..ff0dced556c1 100644
--- a/dev-perl/libwww-perl/ChangeLog
+++ b/dev-perl/libwww-perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/libwww-perl
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.92 2008/11/21 09:48:03 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.93 2008/11/25 11:00:00 tove Exp $
+
+*libwww-perl-5.821 (25 Nov 2008)
+
+ 25 Nov 2008; Torsten Veller <tove@gentoo.org> +libwww-perl-5.821.ebuild:
+ Version bump
*libwww-perl-5.820 (21 Nov 2008)
diff --git a/dev-perl/libwww-perl/libwww-perl-5.821.ebuild b/dev-perl/libwww-perl/libwww-perl-5.821.ebuild
new file mode 100644
index 000000000000..0832cec7569d
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-5.821.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.821.ebuild,v 1.1 2008/11/25 11:00:00 tove Exp $
+
+MODULE_AUTHOR=GAAS
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ssl"
+
+DEPEND="virtual/perl-libnet
+ >=dev-perl/HTML-Parser-3.34
+ >=dev-perl/URI-1.10
+ >=virtual/perl-Digest-MD5-2.12
+ dev-perl/HTML-Tree
+ >=virtual/perl-MIME-Base64-2.12
+ >=virtual/perl-Compress-Zlib-1.10
+ ssl? ( dev-perl/Crypt-SSLeay )
+ dev-lang/perl"
+
+src_install() {
+ perl-module_src_install
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+}
diff --git a/dev-perl/locale-maketext-lexicon/ChangeLog b/dev-perl/locale-maketext-lexicon/ChangeLog
index 6f427d03edc8..0e3fced010d1 100644
--- a/dev-perl/locale-maketext-lexicon/ChangeLog
+++ b/dev-perl/locale-maketext-lexicon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/locale-maketext-lexicon
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/locale-maketext-lexicon/ChangeLog,v 1.46 2008/10/31 08:45:52 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/locale-maketext-lexicon/ChangeLog,v 1.47 2008/11/25 10:56:37 tove Exp $
+
+*locale-maketext-lexicon-0.75 (25 Nov 2008)
+
+ 25 Nov 2008; Torsten Veller <tove@gentoo.org>
+ +locale-maketext-lexicon-0.75.ebuild:
+ Version bump
*locale-maketext-lexicon-0.73 (31 Oct 2008)
diff --git a/dev-perl/locale-maketext-lexicon/locale-maketext-lexicon-0.75.ebuild b/dev-perl/locale-maketext-lexicon/locale-maketext-lexicon-0.75.ebuild
new file mode 100644
index 000000000000..f10285954ba2
--- /dev/null
+++ b/dev-perl/locale-maketext-lexicon/locale-maketext-lexicon-0.75.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/locale-maketext-lexicon/locale-maketext-lexicon-0.75.ebuild,v 1.1 2008/11/25 10:56:37 tove Exp $
+
+MODULE_AUTHOR=DRTECH
+MY_PN=Locale-Maketext-Lexicon
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+inherit perl-module
+
+DESCRIPTION="Use other catalog formats in Maketext"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/perl-locale-maketext
+ dev-lang/perl"
+
+SRC_TEST="do"