summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-11-29 23:54:21 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-11-29 23:54:21 +0000
commitc85dc7e49ef07f0e40f9a1dfee7f4ccb42e8bb99 (patch)
tree5aa6d459b0d4351bbbf348144bf7137560d6b592
parentInitial import from project overlay (diff)
downloadhistorical-c85dc7e49ef07f0e40f9a1dfee7f4ccb42e8bb99.tar.gz
historical-c85dc7e49ef07f0e40f9a1dfee7f4ccb42e8bb99.tar.bz2
historical-c85dc7e49ef07f0e40f9a1dfee7f4ccb42e8bb99.zip
Version bump from project overlay
Package-Manager: portage-2.1.4_rc4
-rw-r--r--dev-php5/agavi/ChangeLog10
-rw-r--r--dev-php5/agavi/agavi-0.11.0.ebuild41
-rw-r--r--dev-php5/agavi/files/digest-agavi-0.11.03
-rw-r--r--dev-php5/libchart/ChangeLog13
-rw-r--r--dev-php5/libchart/Manifest16
-rw-r--r--dev-php5/libchart/files/digest-libchart-1.23
-rw-r--r--dev-php5/libchart/libchart-1.2.ebuild35
-rw-r--r--dev-php5/libchart/metadata.xml5
-rw-r--r--dev-php5/pecl-geoip/ChangeLog13
-rw-r--r--dev-php5/pecl-geoip/files/digest-pecl-geoip-1.0.23
-rw-r--r--dev-php5/pecl-geoip/pecl-geoip-1.0.2.ebuild22
-rw-r--r--dev-php5/pecl-http/ChangeLog11
-rw-r--r--dev-php5/pecl-http/files/digest-pecl-http-1.5.43
-rw-r--r--dev-php5/pecl-http/files/digest-pecl-http-1.6.03
-rw-r--r--dev-php5/pecl-http/pecl-http-1.5.4.ebuild39
-rw-r--r--dev-php5/pecl-http/pecl-http-1.6.0.ebuild69
-rw-r--r--dev-php5/pecl-memcache/ChangeLog12
-rw-r--r--dev-php5/pecl-memcache/files/digest-pecl-memcache-3.0.03
-rw-r--r--dev-php5/pecl-memcache/pecl-memcache-3.0.0.ebuild41
-rw-r--r--dev-php5/pecl-pam/ChangeLog10
-rw-r--r--dev-php5/pecl-pam/files/digest-pecl-pam-1.0.23
-rw-r--r--dev-php5/pecl-pam/pecl-pam-1.0.2.ebuild32
-rw-r--r--dev-php5/pecl-syck/ChangeLog10
-rw-r--r--dev-php5/pecl-syck/files/digest-pecl-syck-0.9.23
-rw-r--r--dev-php5/pecl-syck/pecl-syck-0.9.2.ebuild22
-rw-r--r--dev-php5/znf/ChangeLog12
-rw-r--r--dev-php5/znf/files/digest-znf-0.7.103
-rw-r--r--dev-php5/znf/znf-0.7.10.ebuild36
28 files changed, 426 insertions, 50 deletions
diff --git a/dev-php5/agavi/ChangeLog b/dev-php5/agavi/ChangeLog
index 6085d3a11dbb..59dbf66dad2b 100644
--- a/dev-php5/agavi/ChangeLog
+++ b/dev-php5/agavi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/agavi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/agavi/ChangeLog,v 1.6 2007/03/17 22:44:49 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/agavi/ChangeLog,v 1.7 2007/11/29 23:43:43 jokey Exp $
+
+*agavi-0.11.0 (29 Nov 2007)
+
+ 29 Nov 2007; Markus Ullmann <jokey@gentoo.org> +agavi-0.11.0.ebuild:
+ Version bump from project overlay
+
+ 22 Nov 2007; Jakub Moc <jakub@gentoo.org> +agavi-0.11.0.ebuild:
+ Version bump, fix LICENSE.
17 Mar 2007; Luca Longinotti <chtekk@gentoo.org> metadata.xml,
-agavi-0.10.0.ebuild, agavi-0.10.1b.ebuild:
diff --git a/dev-php5/agavi/agavi-0.11.0.ebuild b/dev-php5/agavi/agavi-0.11.0.ebuild
new file mode 100644
index 000000000000..85a2d0c35d13
--- /dev/null
+++ b/dev-php5/agavi/agavi-0.11.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/agavi/agavi-0.11.0.ebuild,v 1.1 2007/11/29 23:43:43 jokey Exp $
+
+inherit php-pear-lib-r1 depend.php
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP5 MVC Application Framework."
+HOMEPAGE="http://www.agavi.org/"
+SRC_URI="http://agavi.org/downloads/releases/${PV}.tgz"
+LICENSE="LGPL-2.1 as-is public-domain CCPL-Attribution-ShareAlike-2.5"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND=">=dev-php/PEAR-PEAR-1.6.2-r1
+ >=dev-php5/phing-2.2.0
+ dev-php/PEAR-PhpDocumentor"
+RDEPEND=">=dev-php5/phing-2.2.0
+ !minimal? ( dev-php5/creole
+ dev-php5/propel )"
+
+need_php_by_category
+
+pkg_setup() {
+ local flags="pcre reflection spl xml"
+ use minimal || flags="${flags} iconv nls pdo session tokenizer xmlrpc xsl"
+ require_php_with_use ${flags}
+}
+
+src_compile() {
+ phing -f "${WORKDIR}"/${PV}/build.xml package-pear || die "failed to build pear package"
+}
+
+src_install() {
+ cd "${WORKDIR}"/${PV}
+ cp -pPR build/ "${WORKDIR}"/${P} || die "failed to copy pear package"
+ cp build/package.xml "${WORKDIR}" || die "failed to copy package.xml"
+ cd "${S}"
+ php-pear-lib-r1_src_install
+}
diff --git a/dev-php5/agavi/files/digest-agavi-0.11.0 b/dev-php5/agavi/files/digest-agavi-0.11.0
new file mode 100644
index 000000000000..63c36285ef30
--- /dev/null
+++ b/dev-php5/agavi/files/digest-agavi-0.11.0
@@ -0,0 +1,3 @@
+MD5 09759d7fecfe47b7f069451f68f5e283 0.11.0.tgz 1710864
+RMD160 0558339ddaf4e7e2de14c866a88986eed7c46eb6 0.11.0.tgz 1710864
+SHA256 207f63a2f0c98ae70be18a02f77252b7248b9c1c5f704f51528bcd93135dda16 0.11.0.tgz 1710864
diff --git a/dev-php5/libchart/ChangeLog b/dev-php5/libchart/ChangeLog
new file mode 100644
index 000000000000..4f99a9f527c4
--- /dev/null
+++ b/dev-php5/libchart/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for www-apps/libchart
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/libchart/ChangeLog,v 1.1 2007/11/29 23:45:15 jokey Exp $
+
+*libchart-1.2 (29 Nov 2007)
+
+ 29 Nov 2007; Markus Ullmann <jokey@gentoo.org> +metadata.xml,
+ +libchart-1.2.ebuild:
+ Version bump from project overlay
+
+ 07 Sep 2007; Jakub Moc <jakub@gentoo.org> +metadata.xml,
+ +libchart-1.2.ebuild:
+ New ebuild, bug #110116.
diff --git a/dev-php5/libchart/Manifest b/dev-php5/libchart/Manifest
new file mode 100644
index 000000000000..afbb2966797f
--- /dev/null
+++ b/dev-php5/libchart/Manifest
@@ -0,0 +1,16 @@
+DIST libchart-1.2.tar.gz 103765 RMD160 8f71b5473a7a43dd9db08aa9aed695551a64cc1e SHA1 d96503fcd8075694ab34c35af766b8e9cb91fd4b SHA256 b0855dbd020a5b9dda58d67079e833aa7a297333f43bbb314745cc81b4d67f34
+EBUILD libchart-1.2.ebuild 893 RMD160 4056a36b867b81b6206946a2ce98fd0871a3f176 SHA1 82f7909b7a48b99dad8f222ec96185b1158d1b1c SHA256 75712aeaeb767dc1070d875efc5b5371a875daa04809a1bcb1c267e20be05c9c
+MD5 ee4c69966eb06e7bdb9785c18eabad52 libchart-1.2.ebuild 893
+RMD160 4056a36b867b81b6206946a2ce98fd0871a3f176 libchart-1.2.ebuild 893
+SHA256 75712aeaeb767dc1070d875efc5b5371a875daa04809a1bcb1c267e20be05c9c libchart-1.2.ebuild 893
+MISC ChangeLog 382 RMD160 981717db111b40c38e926d13a847c937a764c2df SHA1 f0d6b819d2ce7ee387563fe3e5fe2fb48966b862 SHA256 75776a53098512aba4ab49bf774d653ec31c5e6cca6d9bca4138a53d4be15307
+MD5 01dd93305658bb80792858e3d3eb7fd6 ChangeLog 382
+RMD160 981717db111b40c38e926d13a847c937a764c2df ChangeLog 382
+SHA256 75776a53098512aba4ab49bf774d653ec31c5e6cca6d9bca4138a53d4be15307 ChangeLog 382
+MISC metadata.xml 157 RMD160 a98db3a086fae3c09a903dadbc05f60443ec4b1a SHA1 ddaa23cc35eb917bf8962b652442bebb1ce0f440 SHA256 54f8878ca0228e380abbaa4b529806b5533a6b9b51b3b16c0909e906586a91a1
+MD5 c58d07ca1c1235bbad9bccaec96fc062 metadata.xml 157
+RMD160 a98db3a086fae3c09a903dadbc05f60443ec4b1a metadata.xml 157
+SHA256 54f8878ca0228e380abbaa4b529806b5533a6b9b51b3b16c0909e906586a91a1 metadata.xml 157
+MD5 1c9c8ee66af0577b4f81dbb490666d83 files/digest-libchart-1.2 238
+RMD160 10db0dd721368e4e9b1b4e74c595bf5df2e701c3 files/digest-libchart-1.2 238
+SHA256 dcffe0294f501752772da079a197c11a74cfb9cdb4ec0dc20515720f210d5b81 files/digest-libchart-1.2 238
diff --git a/dev-php5/libchart/files/digest-libchart-1.2 b/dev-php5/libchart/files/digest-libchart-1.2
new file mode 100644
index 000000000000..1e0114ace155
--- /dev/null
+++ b/dev-php5/libchart/files/digest-libchart-1.2
@@ -0,0 +1,3 @@
+MD5 d7571d77ae224759c2298f5ae0e4fc22 libchart-1.2.tar.gz 103765
+RMD160 8f71b5473a7a43dd9db08aa9aed695551a64cc1e libchart-1.2.tar.gz 103765
+SHA256 b0855dbd020a5b9dda58d67079e833aa7a297333f43bbb314745cc81b4d67f34 libchart-1.2.tar.gz 103765
diff --git a/dev-php5/libchart/libchart-1.2.ebuild b/dev-php5/libchart/libchart-1.2.ebuild
new file mode 100644
index 000000000000..a11c5163ff98
--- /dev/null
+++ b/dev-php5/libchart/libchart-1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/libchart/libchart-1.2.ebuild,v 1.1 2007/11/29 23:45:15 jokey Exp $
+
+inherit php-lib-r1 depend.php
+
+DESCRIPTION="Libchart is a chart creation PHP library that is easy to use."
+HOMEPAGE="http://naku.dohcrew.com/libchart"
+SRC_URI="http://naku.dohcrew.com/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-3 BitstreamVera"
+KEYWORDS="~x86"
+SLOT=0
+IUSE="examples"
+
+need_php5
+
+pkg_setup() {
+ if ! PHPCHECKNODIE="yes" require_php_with_use truetype || \
+ ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ die "Re-install ${PHP_PKG} with truetype and either gd or gd-external in USE."
+ fi
+}
+
+src_install() {
+ php-lib-r1_src_install ${PN} `cd ${PN}; find . -type f -print`
+ for i in ${PN}/{ChangeLog,README} ; do
+ dodoc-php ${i}
+ rm -f ${i}
+ done
+ if use examples ; then
+ insinto /usr/share/doc/${CATEGORY}/${PF}
+ doins -r demo/
+ fi
+}
diff --git a/dev-php5/libchart/metadata.xml b/dev-php5/libchart/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php5/libchart/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php5/pecl-geoip/ChangeLog b/dev-php5/pecl-geoip/ChangeLog
index d48b7ffcaace..9839102d1713 100644
--- a/dev-php5/pecl-geoip/ChangeLog
+++ b/dev-php5/pecl-geoip/ChangeLog
@@ -1,10 +1,19 @@
# ChangeLog for dev-php5/pecl-geoip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-geoip/ChangeLog,v 1.1 2007/08/30 13:02:22 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-geoip/ChangeLog,v 1.2 2007/11/29 23:46:13 jokey Exp $
+
+*pecl-geoip-1.0.2 (29 Nov 2007)
+
+ 29 Nov 2007; Markus Ullmann <jokey@gentoo.org> +pecl-geoip-1.0.2.ebuild:
+ Version bump from project overlay
+
+ 22 Nov 2007; Jakub Moc <jakub@gentoo.org>
+ +pecl-geoip-1.0.2.ebuild:
+ Version bump
*pecl-geoip-1.0.1 (30 Aug 2007)
- 30 Aug 2007; Markus Ullmann <jokey@gentoo.org> +metadata.xml,
+ 30 Aug 2007; Markus Ullmann <jokey@gentoo.org>
+pecl-geoip-1.0.1.ebuild:
Port from project overlay
diff --git a/dev-php5/pecl-geoip/files/digest-pecl-geoip-1.0.2 b/dev-php5/pecl-geoip/files/digest-pecl-geoip-1.0.2
new file mode 100644
index 000000000000..ce734a1743cc
--- /dev/null
+++ b/dev-php5/pecl-geoip/files/digest-pecl-geoip-1.0.2
@@ -0,0 +1,3 @@
+MD5 6112a8cf08af5507aa4861bb5b9b4c40 geoip-1.0.2.tgz 7643
+RMD160 fef60c87198276d699db26a3c442f752b3978fd8 geoip-1.0.2.tgz 7643
+SHA256 0ad3cde1210ba6435b8d379b80e0ca4f9084bc09fe6a8f2ca9e0fa8a320b261b geoip-1.0.2.tgz 7643
diff --git a/dev-php5/pecl-geoip/pecl-geoip-1.0.2.ebuild b/dev-php5/pecl-geoip/pecl-geoip-1.0.2.ebuild
new file mode 100644
index 000000000000..bb05c15c1c81
--- /dev/null
+++ b/dev-php5/pecl-geoip/pecl-geoip-1.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-geoip/pecl-geoip-1.0.2.ebuild,v 1.1 2007/11/29 23:46:13 jokey Exp $
+
+PHP_EXT_NAME="geoip"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README ChangeLog"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension to map IP address to geographic places"
+LICENSE="PHP"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/geoip-1.4.0"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
diff --git a/dev-php5/pecl-http/ChangeLog b/dev-php5/pecl-http/ChangeLog
index 50c39d919ad8..3e11b2533ee0 100644
--- a/dev-php5/pecl-http/ChangeLog
+++ b/dev-php5/pecl-http/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-php5/pecl-http
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/ChangeLog,v 1.8 2007/10/10 20:56:45 anant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/ChangeLog,v 1.9 2007/11/29 23:49:52 jokey Exp $
+
+*pecl-http-1.6.0 (29 Nov 2007)
+
+ 29 Nov 2007; Markus Ullmann <jokey@gentoo.org> -pecl-http-1.5.4.ebuild,
+ +pecl-http-1.6.0.ebuild:
+ Version bump from project overlay
+
+ 26 Nov 2007; Jakub Moc <jakub@gentoo.org> +pecl-http-1.6.0.ebuild:
+ Version bump. Add defaults to ini file.
*pecl-http-1.5.6 (11 Oct 2007)
diff --git a/dev-php5/pecl-http/files/digest-pecl-http-1.5.4 b/dev-php5/pecl-http/files/digest-pecl-http-1.5.4
deleted file mode 100644
index b6dad8bd551e..000000000000
--- a/dev-php5/pecl-http/files/digest-pecl-http-1.5.4
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 b2e5440d2d2ae8c260594d2230f0a6d2 pecl_http-1.5.4.tgz 168091
-RMD160 e3698afac63d4a292ffc5a091cd09de9b08f40b5 pecl_http-1.5.4.tgz 168091
-SHA256 7dcab683935616d25dba8e77edbd526a19f200ea3d3d84e09d9869abdb41f526 pecl_http-1.5.4.tgz 168091
diff --git a/dev-php5/pecl-http/files/digest-pecl-http-1.6.0 b/dev-php5/pecl-http/files/digest-pecl-http-1.6.0
new file mode 100644
index 000000000000..030689432ecc
--- /dev/null
+++ b/dev-php5/pecl-http/files/digest-pecl-http-1.6.0
@@ -0,0 +1,3 @@
+MD5 21ef481ae45db61591dd98a935a4dfce pecl_http-1.6.0.tgz 172432
+RMD160 71f8a458fc35c8291e4b570e3b48ecced0a0aaf3 pecl_http-1.6.0.tgz 172432
+SHA256 9a43f3f9f3ebd3ff706e5dcae2efba9b6f07167ab56c232c2839cb5b8c14c7e9 pecl_http-1.6.0.tgz 172432
diff --git a/dev-php5/pecl-http/pecl-http-1.5.4.ebuild b/dev-php5/pecl-http/pecl-http-1.5.4.ebuild
deleted file mode 100644
index 8721b3e2068d..000000000000
--- a/dev-php5/pecl-http/pecl-http-1.5.4.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/pecl-http-1.5.4.ebuild,v 1.3 2007/08/30 13:04:58 jokey Exp $
-
-PHP_EXT_NAME="http"
-PHP_EXT_PECL_PKG="pecl_http"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-inherit php-ext-pecl-r1
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Extended HTTP Support for PHP."
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-DEPEND="net-misc/curl
- sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-need_php_by_category
-
-src_compile() {
- my_conf="--enable-http \
- --with-http-curl-requests \
- --with-http-zlib-compression"
-
- php-ext-pecl-r1_src_compile
-}
-
-pkg_postinst() {
- has_php
- if ! built_with_use --missing true =${PHP_PKG} iconv hash session spl ; then
- elog "${PN} can optionally use iconv, hash, session and spl features."
- elog "If you want those, recompile ${PHP_PKG} with those flags in USE."
- fi
-}
diff --git a/dev-php5/pecl-http/pecl-http-1.6.0.ebuild b/dev-php5/pecl-http/pecl-http-1.6.0.ebuild
new file mode 100644
index 000000000000..c5703f87ddb4
--- /dev/null
+++ b/dev-php5/pecl-http/pecl-http-1.6.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/pecl-http-1.6.0.ebuild,v 1.1 2007/11/29 23:49:52 jokey Exp $
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="docs/examples/tutorial.txt ThanksTo.txt KnownIssues.txt"
+
+inherit php-ext-pecl-r1 php-ext-base-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=net-misc/curl-7.16.4
+ sys-libs/zlib
+ dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_compile() {
+ my_conf="--enable-http \
+ --with-http-curl-requests \
+ --with-http-zlib-compression \
+ --with-http-curl-libevent \
+ --with-http-magic-mime"
+
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+
+ php-ext-base-r1_addtoinifiles "http.etag.mode" "MD5"
+ php-ext-base-r1_addtoinifiles "http.force_exit" "1"
+ php-ext-base-r1_addtoinifiles "http.log.allowed_methods" ""
+ php-ext-base-r1_addtoinifiles "http.log.cache" ""
+ php-ext-base-r1_addtoinifiles "http.log.composite" ""
+ php-ext-base-r1_addtoinifiles "http.log.not_found" ""
+ php-ext-base-r1_addtoinifiles "http.log.redirect" ""
+ php-ext-base-r1_addtoinifiles "http.only_exceptions" "0"
+ php-ext-base-r1_addtoinifiles "http.persistent.handles.ident" "GLOBAL"
+ php-ext-base-r1_addtoinifiles "http.persistent.handles.limit" "-1"
+ php-ext-base-r1_addtoinifiles "http.request.datashare.connect" "0"
+ php-ext-base-r1_addtoinifiles "http.request.datashare.cookie" "0"
+ php-ext-base-r1_addtoinifiles "http.request.datashare.dns" "1"
+ php-ext-base-r1_addtoinifiles "http.request.datashare.ssl" "0"
+ php-ext-base-r1_addtoinifiles "http.request.methods.allowed" ""
+ php-ext-base-r1_addtoinifiles "http.request.methods.custom" ""
+ php-ext-base-r1_addtoinifiles "http.send.inflate.start_auto" "0"
+ php-ext-base-r1_addtoinifiles "http.send.inflate.start_flags" "0"
+ php-ext-base-r1_addtoinifiles "http.send.deflate.start_auto" "0"
+ php-ext-base-r1_addtoinifiles "http.send.deflate.start_flags" "0"
+ php-ext-base-r1_addtoinifiles "http.send.not_found_404" "1"
+}
+
+pkg_postinst() {
+ has_php
+ if ! built_with_use --missing true =${PHP_PKG} hash iconv session spl ; then
+ elog "${PN} can optionally use hash, iconv, session and spl features."
+ elog "If you want those, recompile ${PHP_PKG} with those flags in USE."
+ fi
+}
diff --git a/dev-php5/pecl-memcache/ChangeLog b/dev-php5/pecl-memcache/ChangeLog
index 5934706b0a7b..0a3f72804fee 100644
--- a/dev-php5/pecl-memcache/ChangeLog
+++ b/dev-php5/pecl-memcache/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-php5/pecl-memcache
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.18 2007/11/15 19:15:39 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.19 2007/11/29 23:51:03 jokey Exp $
+
+*pecl-memcache-3.0.0 (29 Nov 2007)
+
+ 29 Nov 2007; Markus Ullmann <jokey@gentoo.org>
+ +pecl-memcache-3.0.0.ebuild:
+ Version bump from project overlay
+
+ 26 Nov 2007; Jakub Moc <jakub@gentoo.org> +metadata.xml,
+ +pecl-memcache-3.0.0.ebuild:
+ Version bump, new API. See README for details on new API and INI directives.
*pecl-memcache-2.2.1 (15 Nov 2007)
diff --git a/dev-php5/pecl-memcache/files/digest-pecl-memcache-3.0.0 b/dev-php5/pecl-memcache/files/digest-pecl-memcache-3.0.0
new file mode 100644
index 000000000000..446e70e2b8d9
--- /dev/null
+++ b/dev-php5/pecl-memcache/files/digest-pecl-memcache-3.0.0
@@ -0,0 +1,3 @@
+MD5 0cc7d64f4af5b63403604c3cec308315 memcache-3.0.0.tgz 41593
+RMD160 74d836789eff72c443081f55ed38808abcf78f92 memcache-3.0.0.tgz 41593
+SHA256 71eba99de348bd4e995c0f1c5d3370874325306aa7fc014ab075cdb671a7dbd4 memcache-3.0.0.tgz 41593
diff --git a/dev-php5/pecl-memcache/pecl-memcache-3.0.0.ebuild b/dev-php5/pecl-memcache/pecl-memcache-3.0.0.ebuild
new file mode 100644
index 000000000000..d3aa6dfdf2e3
--- /dev/null
+++ b/dev-php5/pecl-memcache/pecl-memcache-3.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/pecl-memcache-3.0.0.ebuild,v 1.1 2007/11/29 23:51:03 jokey Exp $
+
+PHP_EXT_NAME="memcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+inherit php-ext-pecl-r1 php-ext-base-r1
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="PHP extension for using memcached."
+LICENSE="PHP"
+SLOT="0"
+IUSE=""
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_compile() {
+ my_conf="--enable-memcache --with-zlib-dir=/usr"
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+
+ php-ext-base-r1_addtoinifiles "memcache.allow_failover" "true"
+ php-ext-base-r1_addtoinifiles "memcache.max_failover_attempts" "20"
+ php-ext-base-r1_addtoinifiles "memcache.chunk_size" "32768"
+ php-ext-base-r1_addtoinifiles "memcache.default_port" "11211"
+ php-ext-base-r1_addtoinifiles "memcache.hash_strategy" "consistent"
+ php-ext-base-r1_addtoinifiles "memcache.hash_function" "crc32"
+ php-ext-base-r1_addtoinifiles "memcache.redundancy" "1"
+ php-ext-base-r1_addtoinifiles "memcache.session_redundancy" "2"
+ php-ext-base-r1_addtoinifiles "memcache.protocol" "ascii"
+}
diff --git a/dev-php5/pecl-pam/ChangeLog b/dev-php5/pecl-pam/ChangeLog
index a960aac4e250..d46ca824e98a 100644
--- a/dev-php5/pecl-pam/ChangeLog
+++ b/dev-php5/pecl-pam/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/pecl-pam
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pam/ChangeLog,v 1.1 2007/11/15 19:17:03 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pam/ChangeLog,v 1.2 2007/11/29 23:52:21 jokey Exp $
+
+*pecl-pam-1.0.2 (29 Nov 2007)
+
+ 29 Nov 2007; Markus Ullmann <jokey@gentoo.org> +pecl-pam-1.0.2.ebuild:
+ Version bump from project overlay
+
+ 28 Nov 2007; Jakub Moc <jakub@gentoo.org> +pecl-pam-1.0.2.ebuild:
+ Version bump
*pecl-pam-1.0.1 (15 Nov 2007)
diff --git a/dev-php5/pecl-pam/files/digest-pecl-pam-1.0.2 b/dev-php5/pecl-pam/files/digest-pecl-pam-1.0.2
new file mode 100644
index 000000000000..d50ae15bc6b5
--- /dev/null
+++ b/dev-php5/pecl-pam/files/digest-pecl-pam-1.0.2
@@ -0,0 +1,3 @@
+MD5 5ea92fe39ef2ba45366ee194fcd86734 pam-1.0.2.tgz 6050
+RMD160 3fe19ae6d7753ae2918e3ae1d740d1c44b6d82f8 pam-1.0.2.tgz 6050
+SHA256 d3a19ca7347258e8893b45c51978487d273252500242a323d6462c49e6db6682 pam-1.0.2.tgz 6050
diff --git a/dev-php5/pecl-pam/pecl-pam-1.0.2.ebuild b/dev-php5/pecl-pam/pecl-pam-1.0.2.ebuild
new file mode 100644
index 000000000000..b62d52aea1f3
--- /dev/null
+++ b/dev-php5/pecl-pam/pecl-pam-1.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pam/pecl-pam-1.0.2.ebuild,v 1.1 2007/11/29 23:52:21 jokey Exp $
+
+PHP_EXT_NAME="pam"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+inherit php-ext-pecl-r1 pam
+
+KEYWORDS="~x86"
+
+DESCRIPTION="This extension provides PAM (Pluggable Authentication Modules) integration."
+LICENSE="PHP"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_compile() {
+ my_conf="--with-pam=/usr $(use_enable debug)"
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ pamd_mimic_system php auth account password
+ php-ext-pecl-r1_src_install
+}
diff --git a/dev-php5/pecl-syck/ChangeLog b/dev-php5/pecl-syck/ChangeLog
index 69d2faad2a47..5de88d3342f3 100644
--- a/dev-php5/pecl-syck/ChangeLog
+++ b/dev-php5/pecl-syck/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/pecl-syck
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-syck/ChangeLog,v 1.7 2007/11/18 17:44:36 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-syck/ChangeLog,v 1.8 2007/11/29 23:53:29 jokey Exp $
+
+*pecl-syck-0.9.2 (29 Nov 2007)
+
+ 29 Nov 2007; Markus Ullmann <jokey@gentoo.org> +pecl-syck-0.9.2.ebuild:
+ Version bump from project overlay
+
+ 24 Nov 2007; Jakub Moc <jakub@gentoo.org> +pecl-syck-0.9.2.ebuild:
+ Version bump
18 Nov 2007; Markus Rothe <corsair@gentoo.org> pecl-syck-0.9.1.ebuild:
Stable on ppc64; bug #198568
diff --git a/dev-php5/pecl-syck/files/digest-pecl-syck-0.9.2 b/dev-php5/pecl-syck/files/digest-pecl-syck-0.9.2
new file mode 100644
index 000000000000..9103e5431a48
--- /dev/null
+++ b/dev-php5/pecl-syck/files/digest-pecl-syck-0.9.2
@@ -0,0 +1,3 @@
+MD5 39db9d4c56407b59b7e9bbf7b7d53308 syck-0.9.2.tgz 11339
+RMD160 a292c7a76cc08cdb907cb46b56578f5e6fb3d940 syck-0.9.2.tgz 11339
+SHA256 4f0d459d929b187962b2fbf0b3e5108da1ed1a5cbe26a02cdfcde38441875a62 syck-0.9.2.tgz 11339
diff --git a/dev-php5/pecl-syck/pecl-syck-0.9.2.ebuild b/dev-php5/pecl-syck/pecl-syck-0.9.2.ebuild
new file mode 100644
index 000000000000..c400a7f3e1aa
--- /dev/null
+++ b/dev-php5/pecl-syck/pecl-syck-0.9.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-syck/pecl-syck-0.9.2.ebuild,v 1.1 2007/11/29 23:53:29 jokey Exp $
+
+PHP_EXT_NAME="syck"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CHANGELOG TODO"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="PHP bindings for Syck - an extension for reading and writing YAML swiftly in popular scripting languages."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/syck"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
diff --git a/dev-php5/znf/ChangeLog b/dev-php5/znf/ChangeLog
index 1e72e695adc9..f0ea086bbf25 100644
--- a/dev-php5/znf/ChangeLog
+++ b/dev-php5/znf/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-php5/znf
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/znf/ChangeLog,v 1.8 2007/10/22 22:52:25 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/znf/ChangeLog,v 1.9 2007/11/29 23:54:21 jokey Exp $
+
+*znf-0.7.10 (29 Nov 2007)
+
+ 29 Nov 2007; Markus Ullmann <jokey@gentoo.org> +znf-0.7.10.ebuild:
+ Version bump from project overlay
+
+ 22 Nov 2007; Jakub Moc <jakub@gentoo.org> +znf-0.7.10.ebuild:
+ Version bump, last release as this project has been abandoned. See
+ http://znf.zeronotice.com/index.php?znfAction=newsView&news_id=13 for
+ details.
*znf-0.7.9-r1 (22 Oct 2007)
diff --git a/dev-php5/znf/files/digest-znf-0.7.10 b/dev-php5/znf/files/digest-znf-0.7.10
new file mode 100644
index 000000000000..97d741d7f7e9
--- /dev/null
+++ b/dev-php5/znf/files/digest-znf-0.7.10
@@ -0,0 +1,3 @@
+MD5 499f1d81f9e43e60a2b2d33f9376feed ZNF-0.7.10.tgz 814254
+RMD160 e4e363bad2c1dff4e77c65f97171ea62e5a1c36c ZNF-0.7.10.tgz 814254
+SHA256 6c99d3fee7c622542d713e352c2c4073185975018d995d657027812bac3cd771 ZNF-0.7.10.tgz 814254
diff --git a/dev-php5/znf/znf-0.7.10.ebuild b/dev-php5/znf/znf-0.7.10.ebuild
new file mode 100644
index 000000000000..a72dfef29296
--- /dev/null
+++ b/dev-php5/znf/znf-0.7.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/znf/znf-0.7.10.ebuild,v 1.1 2007/11/29 23:54:21 jokey Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~sparc ~x86"
+
+MY_P="ZNF-${PV}"
+
+DESCRIPTION="PHP5 MVC framework for enterprise web applications."
+HOMEPAGE="http://znf.zeronotice.com/"
+SRC_URI="http://pear.zeronotice.org/get/${MY_P}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND=">=dev-php/PEAR-PEAR-1.6.2"
+RDEPEND="!minimal? ( >=dev-php/PEAR-DB-1.7.6-r1
+ >=dev-php/smarty-2.6.10-r1 )"
+
+S="${WORKDIR}/${MY_P}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_with_use xml xsl
+}
+
+pkg_postinst() {
+ has_php
+ if ! built_with_use =${PHP_PKG} pdo ; then
+ elog "${PN} can optionally use PDO features. If you want those,"
+ elog "re-emerge ${PHP_PKG} with USE=\"pdo\"."
+ fi
+}