summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-09-11 14:29:55 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-09-11 14:29:55 +0000
commitd071526f3b242ba6c4b6818090f57480307a551c (patch)
treeac91deb6fd627e07b11ffd1a4f15e15d61963eb9
parentemake -> make (diff)
downloadhistorical-d071526f3b242ba6c4b6818090f57480307a551c.tar.gz
historical-d071526f3b242ba6c4b6818090f57480307a551c.tar.bz2
historical-d071526f3b242ba6c4b6818090f57480307a551c.zip
small patch fix0r
-rw-r--r--x11-wm/ion/ChangeLog10
-rw-r--r--x11-wm/ion/files/digest-ion-200111091
-rw-r--r--x11-wm/ion/files/digest-ion-20011109-r11
-rw-r--r--x11-wm/ion/files/digest-ion-20020207-r11
-rw-r--r--x11-wm/ion/files/ion-20020207-gentoo.diff12
-rw-r--r--x11-wm/ion/ion-20011109.ebuild47
-rw-r--r--x11-wm/ion/ion-20020207-r1.ebuild (renamed from x11-wm/ion/ion-20011109-r1.ebuild)16
7 files changed, 33 insertions, 55 deletions
diff --git a/x11-wm/ion/ChangeLog b/x11-wm/ion/ChangeLog
index ffe25c57434f..b96d166edbfd 100644
--- a/x11-wm/ion/ChangeLog
+++ b/x11-wm/ion/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-wm/ion
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion/ChangeLog,v 1.2 2002/02/09 05:45:47 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion/ChangeLog,v 1.3 2002/09/11 14:29:55 seemant Exp $
+
+*ion-20020207-r1 (11 Sep 2002)
+
+ 11 Sep 2002; Seemant Kulleen <seemant@gentoo.org> ion-20020207-r1.ebuild
+ files/ion-20020207-gentoo.diff files/digest-ion-20020207-r1 :
+
+ Patch by: sascha-gentoo-bugzilla@silbe.org (Sascha Silbe) in bug #7783 to
+ fix the quote_next() function.
*ion-20020207 (8 Feb 2002)
diff --git a/x11-wm/ion/files/digest-ion-20011109 b/x11-wm/ion/files/digest-ion-20011109
deleted file mode 100644
index e802581c253c..000000000000
--- a/x11-wm/ion/files/digest-ion-20011109
+++ /dev/null
@@ -1 +0,0 @@
-MD5 db5400a7bb05ae74babacca60e2a2609 ion-20011109.tar.gz 177287
diff --git a/x11-wm/ion/files/digest-ion-20011109-r1 b/x11-wm/ion/files/digest-ion-20011109-r1
deleted file mode 100644
index e802581c253c..000000000000
--- a/x11-wm/ion/files/digest-ion-20011109-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 db5400a7bb05ae74babacca60e2a2609 ion-20011109.tar.gz 177287
diff --git a/x11-wm/ion/files/digest-ion-20020207-r1 b/x11-wm/ion/files/digest-ion-20020207-r1
new file mode 100644
index 000000000000..2c51c5253f43
--- /dev/null
+++ b/x11-wm/ion/files/digest-ion-20020207-r1
@@ -0,0 +1 @@
+MD5 2e909abb45efefb08b1ceb886bf34cfe ion-20020207.tar.gz 157649
diff --git a/x11-wm/ion/files/ion-20020207-gentoo.diff b/x11-wm/ion/files/ion-20020207-gentoo.diff
new file mode 100644
index 000000000000..a52afdbeaa6c
--- /dev/null
+++ b/x11-wm/ion/files/ion-20020207-gentoo.diff
@@ -0,0 +1,12 @@
+diff -ur ion-20020207/src/key.c ion-20020207.quotefix/src/key.c
+--- ion-20020207/src/key.c 2002-02-06 00:29:01.000000000 +0100
++++ ion-20020207.quotefix/src/key.c 2002-09-11 07:22:22.000000000 +0200
+@@ -93,7 +93,7 @@
+ {
+ XKeyEvent *ev=&xev->xkey;
+ if(ev->type==KeyRelease)
+- return TRUE;
++ return FALSE;
+ if(ismod(ev->keycode))
+ return FALSE;
+ assert(WTHING_IS(thing, WClientWin));
diff --git a/x11-wm/ion/ion-20011109.ebuild b/x11-wm/ion/ion-20011109.ebuild
deleted file mode 100644
index 00a458a0f976..000000000000
--- a/x11-wm/ion/ion-20011109.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion/ion-20011109.ebuild,v 1.5 2002/08/14 15:45:39 murphy Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="A keyboard-based window manager"
-SRC_URI="http://www.students.tut.fi/~tuomov/dl/${P}.tar.gz"
-HOMEPAGE="http://www.students.tut.fi/~tuomov/ion/"
-DEPEND="virtual/glibc"
-RDEPEND="virtual/x11"
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="x86 sparc sparc64"
-
-src_compile() {
- cd ${S}
-
- # Edit system.mk
- sed -e 's:PREFIX=/usr/local:PREFIX=/usr:' \
- -e 's:ETCDIR=$(PREFIX):ETCDIR=:' \
- -e 's:$(PREFIX)/man:$(PREFIX)/share/man:' \
- -e 's:$(PREFIX)/doc:$(PREFIX)/share/doc:' \
- -e 's:#HAS_SYSTEM_ASPRINTF=1:HAS_SYSTEM_ASPRINTF=1:' \
- -e 's:#INSTALL=install -c:INSTALL=install -c:' \
- -e 's:INSTALL=install *$:#INSTALL=install:' \
- system.mk > system.mk.new
- mv system.mk.new system.mk
-
- # Edit Makefile
- # I don't know how to use ${P} instead of typing the whole version
- # here. At some point, it should be cleaned up.
- sed -e 's:$(DOCDIR)/ion:$(DOCDIR)/ion-20010523:g' Makefile > Makefile.new
- mv Makefile.new Makefile
-
- make depend || die
- emake || die
-}
-
-src_install () {
- make PREFIX=${D}/usr ETCDIR=${D}/etc install || die
-}
-
-pkg_postinst () {
- einfo "Configuration documentation can be found in these places:"
- einfo "/usr/share/doc/${P}/config.txt"
- einfo "http://www.students.tut.fi/~tuomov/ion/resources.html"
-}
diff --git a/x11-wm/ion/ion-20011109-r1.ebuild b/x11-wm/ion/ion-20020207-r1.ebuild
index 70ae53bdf3a7..6fcaad55ac44 100644
--- a/x11-wm/ion/ion-20011109-r1.ebuild
+++ b/x11-wm/ion/ion-20020207-r1.ebuild
@@ -1,20 +1,26 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion/ion-20011109-r1.ebuild,v 1.5 2002/08/14 15:45:39 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion/ion-20020207-r1.ebuild,v 1.1 2002/09/11 14:29:55 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A keyboard-based window manager"
SRC_URI="http://www.students.tut.fi/~tuomov/dl/${P}.tar.gz"
HOMEPAGE="http://www.students.tut.fi/~tuomov/ion/"
-DEPEND="virtual/glibc"
-RDEPEND="virtual/x11"
-LICENSE="Artistic"
+
SLOT="0"
+LICENSE="Artistic"
KEYWORDS="x86 sparc sparc64"
-src_compile() {
+DEPEND="virtual/x11"
+
+src_unpack() {
+ unpack ${A}
cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-gentoo.diff || die
+}
+
+src_compile() {
# Edit system.mk
cp system.mk system.mk.new
sed -e 's:PREFIX=/usr/local:PREFIX=/usr:' \