summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2005-03-26 04:02:16 +0000
committerJason Wever <weeve@gentoo.org>2005-03-26 04:02:16 +0000
commitd3deb9c1c1165e183d5d11c1d22f01fc9ae54305 (patch)
tree0bbb480c24f7f397448fd490218c85e909e3420b
parentKeyworded ~sparc wrt #84992 (diff)
downloadhistorical-d3deb9c1c1165e183d5d11c1d22f01fc9ae54305.tar.gz
historical-d3deb9c1c1165e183d5d11c1d22f01fc9ae54305.tar.bz2
historical-d3deb9c1c1165e183d5d11c1d22f01fc9ae54305.zip
Bump that sexy version.
Package-Manager: portage-2.0.51.19
-rw-r--r--x11-wm/ratpoison/ChangeLog9
-rw-r--r--x11-wm/ratpoison/Manifest4
-rw-r--r--x11-wm/ratpoison/files/digest-ratpoison-1.4.0_beta21
-rw-r--r--x11-wm/ratpoison/ratpoison-1.4.0_beta2.ebuild67
4 files changed, 78 insertions, 3 deletions
diff --git a/x11-wm/ratpoison/ChangeLog b/x11-wm/ratpoison/ChangeLog
index b8739a556a14..07d2114ea03e 100644
--- a/x11-wm/ratpoison/ChangeLog
+++ b/x11-wm/ratpoison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/ratpoison
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.27 2004/12/12 04:52:36 weeve Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.28 2005/03/26 04:02:15 weeve Exp $
+
+*ratpoison-1.4.0_beta2 (26 Mar 2005)
+
+ 26 Mar 2005; Jason Wever <weeve@gentoo.org> +ratpoison-1.4.0_beta2.ebuild:
+ Bump that sexy version.
11 Dec 2004; Jason Wever <weeve@gentoo.org> ratpoison-1.3.0.ebuild:
Updated HOMEPAGE and SRC_URI to reflect recent move to savannah.nongnu.org.
diff --git a/x11-wm/ratpoison/Manifest b/x11-wm/ratpoison/Manifest
index 48769dd71e18..15f24d142f8c 100644
--- a/x11-wm/ratpoison/Manifest
+++ b/x11-wm/ratpoison/Manifest
@@ -1,8 +1,10 @@
-MD5 7d645ba01972b6e06f1d76c1b4dd2559 ChangeLog 3592
+MD5 6346def6f54fb6762bdaacad6114f55b ChangeLog 3734
MD5 0dc401dca3401344d482d660aedf9b3b metadata.xml 829
MD5 754907a47eb6de73be0c437706501932 ratpoison-1.3.0.ebuild 1444
+MD5 8e71189578c6957a1a66541c432f8b86 ratpoison-1.4.0_beta2.ebuild 1499
MD5 ab1a7f36971489b5cffb75d84a2b2d0a files/50ratpoison-gentoo.el 82
MD5 a03e9a6eb4cf2a842fb1b5c33c3758a5 files/ratpoison.xsession 36
MD5 e4205db91428787672e5463c32d4b701 files/digest-ratpoison-1.3.0 67
MD5 129f353e076455306b034fd577a6cdd2 files/ratpoison.el-gentoo.patch 273
MD5 a7dd337c32ae9d2fe627cf230b77965c files/ratpoisonrc 609
+MD5 e97b940b1d366b59e727dd7c8f727874 files/digest-ratpoison-1.4.0_beta2 73
diff --git a/x11-wm/ratpoison/files/digest-ratpoison-1.4.0_beta2 b/x11-wm/ratpoison/files/digest-ratpoison-1.4.0_beta2
new file mode 100644
index 000000000000..38d3d78e4566
--- /dev/null
+++ b/x11-wm/ratpoison/files/digest-ratpoison-1.4.0_beta2
@@ -0,0 +1 @@
+MD5 c5f5a2c7a9d5de02ccabfb1327346124 ratpoison-1.4.0-beta2.tar.gz 342068
diff --git a/x11-wm/ratpoison/ratpoison-1.4.0_beta2.ebuild b/x11-wm/ratpoison/ratpoison-1.4.0_beta2.ebuild
new file mode 100644
index 000000000000..81a8d962200a
--- /dev/null
+++ b/x11-wm/ratpoison/ratpoison-1.4.0_beta2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-1.4.0_beta2.ebuild,v 1.1 2005/03/26 04:02:16 weeve Exp $
+
+inherit elisp-common eutils
+
+MY_P=${P/_beta/-beta}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Ratpoison is an extremely light-weight and barebones wm modelled after screen"
+HOMEPAGE="http://www.nongnu.org/ratpoison/"
+LICENSE="GPL-2"
+
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+IUSE="emacs"
+
+DEPEND="virtual/x11
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50ratpoison-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/contrib
+ epatch ${FILESDIR}/ratpoison.el-gentoo.patch
+}
+
+src_compile() {
+ if [ "${ARCH}" = "amd64" ]
+ then
+ libtoolize -c -f
+ fi
+ econf || die "econf failed"
+ emake CFLAGS="${CFLAGS} -I/usr/X11R6/include" || die
+ if use emacs; then
+ cd contrib && elisp-comp ratpoison.el
+ fi
+}
+
+src_install() {
+ einstall
+
+ exeinto /etc/X11/Sessions
+ newexe ${FILESDIR}/ratpoison.xsession ratpoison
+
+ dodoc INSTALL TODO README NEWS AUTHORS ChangeLog
+ docinto example
+ dodoc contrib/{genrpbindings,split.sh} \
+ doc/{ipaq.ratpoisonrc,sample.ratpoisonrc}
+
+ rm -rf $D/usr/share/{doc/ratpoison,ratpoison}
+
+ if use emacs; then
+ elisp-install ${PN} contrib/ratpoison.*
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}