summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-04-08 00:00:25 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-04-08 00:00:25 +0000
commite375efd9475bc319c2062ae16833ef6d4e31b383 (patch)
treec9df4db704cf51965ec96856fccebb794c093ccb
parentsmall fix (diff)
downloadhistorical-e375efd9475bc319c2062ae16833ef6d4e31b383.tar.gz
historical-e375efd9475bc319c2062ae16833ef6d4e31b383.tar.bz2
historical-e375efd9475bc319c2062ae16833ef6d4e31b383.zip
libtoolize
-rw-r--r--sys-apps/shadow/ChangeLog7
-rw-r--r--sys-apps/shadow/shadow-4.0.2-r3.ebuild9
-rw-r--r--sys-apps/shadow/shadow-4.0.3.ebuild9
3 files changed, 18 insertions, 7 deletions
diff --git a/sys-apps/shadow/ChangeLog b/sys-apps/shadow/ChangeLog
index ded1c37ab5ee..0071f46f9162 100644
--- a/sys-apps/shadow/ChangeLog
+++ b/sys-apps/shadow/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/shadow
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/ChangeLog,v 1.9 2002/04/04 06:03:36 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/ChangeLog,v 1.10 2002/04/08 00:00:25 azarah Exp $
+
+ 8 Apr 2002; M.Schlemmer <azarah@gentoo.org>
+
+ Libtoolized to fix .la files. Build is pretty broken if libtoolized, so had
+ to put a unortodox LIBS= and LDFLAGS= there.
*shadow-4.0.3 (3 Apr 2002)
diff --git a/sys-apps/shadow/shadow-4.0.2-r3.ebuild b/sys-apps/shadow/shadow-4.0.2-r3.ebuild
index b41cfacf9e62..c4bfdbac0a1e 100644
--- a/sys-apps/shadow/shadow-4.0.2-r3.ebuild
+++ b/sys-apps/shadow/shadow-4.0.2-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.2-r3.ebuild,v 1.1 2002/04/04 05:32:40 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.2-r3.ebuild,v 1.2 2002/04/08 00:00:25 azarah Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Utilities to deal with user accounts"
@@ -19,9 +19,11 @@ pkg_preinst() {
}
src_compile() {
+ libtoolize --copy --force
+
local myconf=""
use nls || myconf="${myconf} --disable-nls"
-
+
./configure --disable-desrpc \
--with-libcrypt \
--with-libcrack \
@@ -32,7 +34,8 @@ src_compile() {
${myconf} || die "bad configure"
# Parallel make fails sometimes
- make LDFLAGS="" || die "compile problem"
+ make LDFLAGS="-lcrack -lcrypt" \
+ LIBS="../libmisc/nscd.o" || die "compile problem"
}
src_install() {
diff --git a/sys-apps/shadow/shadow-4.0.3.ebuild b/sys-apps/shadow/shadow-4.0.3.ebuild
index 85bf964181ae..7cc02db8caad 100644
--- a/sys-apps/shadow/shadow-4.0.3.ebuild
+++ b/sys-apps/shadow/shadow-4.0.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.3.ebuild,v 1.1 2002/04/04 06:03:36 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.3.ebuild,v 1.2 2002/04/08 00:00:25 azarah Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Utilities to deal with user accounts"
@@ -19,9 +19,11 @@ pkg_preinst() {
}
src_compile() {
+ libtoolize --copy --force
+
local myconf=""
use nls || myconf="${myconf} --disable-nls"
-
+
./configure --disable-desrpc \
--with-libcrypt \
--with-libcrack \
@@ -32,7 +34,8 @@ src_compile() {
${myconf} || die "bad configure"
# Parallel make fails sometimes
- make LDFLAGS="" || die "compile problem"
+ make LDFLAGS="-lcrack -lcrypt" \
+ LIBS="../libmisc/nscd.o" || die "compile problem"
}
src_install() {