summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 01:46:33 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 01:46:33 +0000
commitef74cc98633913f893ad679be6f409f36547cf4d (patch)
tree2dd37851d1e13ae8527fe895fdf81a0d5913aaa9
parentChanged einstall||die to einstall (diff)
downloadhistorical-ef74cc98633913f893ad679be6f409f36547cf4d.tar.gz
historical-ef74cc98633913f893ad679be6f409f36547cf4d.tar.bz2
historical-ef74cc98633913f893ad679be6f409f36547cf4d.zip
Changed econf||die to econf
-rw-r--r--app-admin/ctcs/ctcs-1.3.0_pre4.ebuild19
-rw-r--r--app-admin/gpsui/gpsui-2.2.ebuild17
-rw-r--r--app-admin/gtkdiskfree/gtkdiskfree-1.8.4.ebuild19
-rw-r--r--app-admin/gwcc/gwcc-0.9.6-r2.ebuild14
-rw-r--r--app-admin/jinit/jinit-0.1.9-r1.ebuild10
-rw-r--r--app-admin/metalog/metalog-0.6-r10.ebuild9
-rw-r--r--app-admin/msyslog/msyslog-1.09a.ebuild19
-rw-r--r--app-admin/mtools/mtools-3.9.8-r1.ebuild16
-rw-r--r--app-admin/powertweak/powertweak-0.1.17-r2.ebuild17
-rw-r--r--app-admin/powertweak/powertweak-0.99.4.ebuild20
-rw-r--r--app-admin/powertweak/powertweak-0.99.5_pre20021029.ebuild22
-rw-r--r--app-admin/puregui/puregui-0.3.5.ebuild14
-rw-r--r--app-admin/pwgen/pwgen-2.01.ebuild7
-rw-r--r--app-admin/runset/runset-1.4.ebuild7
14 files changed, 80 insertions, 130 deletions
diff --git a/app-admin/ctcs/ctcs-1.3.0_pre4.ebuild b/app-admin/ctcs/ctcs-1.3.0_pre4.ebuild
index 015cd8001e7d..b2d2aeee0d5e 100644
--- a/app-admin/ctcs/ctcs-1.3.0_pre4.ebuild
+++ b/app-admin/ctcs/ctcs-1.3.0_pre4.ebuild
@@ -1,23 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ctcs/ctcs-1.3.0_pre4.ebuild,v 1.7 2002/11/17 05:37:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ctcs/ctcs-1.3.0_pre4.ebuild,v 1.8 2002/11/30 01:25:23 vapier Exp $
-# ${A} - the tarball itself eg: ${PORTDIR}/distfiles/t.tgz
-# ${P} - program name-program version eg: foo-1.0
-# ${PN} - program name eg: foo
-# ${PV} - program version eg: 1.0
-# ${D} - /var/tmp/portage/foo-1.0/image -- install files go here
-# ${S} - /var/tmp/portage/foo-1.0/work/${P}
-# ${WORKDIR} - /var/tmp/portage/foo-1.0/work
-# ${FILESDIR} - Location of patches
-
-MY_P="ctcs-1.3.0pre4"
+MY_P="${P/_/}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="CTCS (Cerberus Test Control System) used to make sure that new systems are ready to go out and face the perils of the cold, hard world. It's made up of a suite of programs that literally pound the system. The tests are meant for hardware with nothing on it yet... you will lose data. Not might. Will. Please read at least README.FIRST before attempting to use the Cerberus Test Control System as certain configurations of CTCS may damage your system."
-
-# Developer reference
-HOMEPAGE="http://sourceforge.net/projects/va-ctcs"
+HOMEPAGE="http://sourceforge.net/projects/va-ctcs/"
+SRC_URI="mirror://sourceforge/va-ctcs/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -46,7 +36,6 @@ RDEPEND="virtual/glibc
# Optional: sys-apps/lm_sensors
src_compile() {
-# econf || die
emake || die
}
diff --git a/app-admin/gpsui/gpsui-2.2.ebuild b/app-admin/gpsui/gpsui-2.2.ebuild
index 9393ee4080d6..fe7665113db1 100644
--- a/app-admin/gpsui/gpsui-2.2.ebuild
+++ b/app-admin/gpsui/gpsui-2.2.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gpsui/gpsui-2.2.ebuild,v 1.1 2002/11/11 06:31:26 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gpsui/gpsui-2.2.ebuild,v 1.2 2002/11/30 01:30:01 vapier Exp $
DESCRIPTION="GUI program for managing running processes"
HOMEPAGE="http://gpsui.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE="nls"
-MY_P="gpsui"
-S="${WORKDIR}/${MY_P}"
+S="${WORKDIR}/${PN}"
DEPEND="=x11-libs/gtk+-1.2*
=gnome-base/gnome-libs-1.4*
@@ -19,16 +19,15 @@ DEPEND="=x11-libs/gtk+-1.2*
src_compile() {
local myconf=""
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+ econf ${myconf}
- use nls || myconf="--disable-nls"
-
- econf $myconf || die "./configure failed"
-
emake || die "Compilation failed"
}
src_install() {
- einstall || die "Installation failed"
-
+ einstall
dodoc ABOUT-NLS AUTHORS ChangeLog COPYING README
}
diff --git a/app-admin/gtkdiskfree/gtkdiskfree-1.8.4.ebuild b/app-admin/gtkdiskfree/gtkdiskfree-1.8.4.ebuild
index e412cf391bee..c270f7a9d2c3 100644
--- a/app-admin/gtkdiskfree/gtkdiskfree-1.8.4.ebuild
+++ b/app-admin/gtkdiskfree/gtkdiskfree-1.8.4.ebuild
@@ -1,33 +1,30 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gtkdiskfree/gtkdiskfree-1.8.4.ebuild,v 1.1 2002/11/06 06:31:21 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gtkdiskfree/gtkdiskfree-1.8.4.ebuild,v 1.2 2002/11/30 01:30:44 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="GtkDiskFree is a program which shows free space on your mounted filesystems"
HOMEPAGE="http://gtkdiskfree.tuxfamily.org/"
SRC_URI="http://gtkdiskfree.tuxfamily.org/src_tgz/${P}.tar.gz"
-IUSE=""
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86"
DEPEND="=x11-libs/gtk+-1.2*
- =dev-libs/glib-1.2*
- nls? ( sys-devel/gettext ) "
+ =dev-libs/glib-1.2*
+ nls? ( sys-devel/gettext ) "
src_compile() {
local myconf
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+ econf ${myconf}
- use nls || myconf="--disable-nls"
-
- econf ${myconf} || die "./configure failed"
emake all || die "emake failed"
}
src_install() {
- einstall DESTDIR=${D} || die "einstall failed"
-
+ einstall DESTDIR=${D}
dodoc AUTHORS ChangeLog NEWS README THANKS TODO
}
-
diff --git a/app-admin/gwcc/gwcc-0.9.6-r2.ebuild b/app-admin/gwcc/gwcc-0.9.6-r2.ebuild
index 03fb5b454a10..884558cb907b 100644
--- a/app-admin/gwcc/gwcc-0.9.6-r2.ebuild
+++ b/app-admin/gwcc/gwcc-0.9.6-r2.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gwcc/gwcc-0.9.6-r2.ebuild,v 1.1 2002/10/15 13:54:51 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gwcc/gwcc-0.9.6-r2.ebuild,v 1.2 2002/11/30 01:25:58 vapier Exp $
-IUSE="nls"
-
-S=${WORKDIR}/${P}
DESCRIPTION="GNOME Workstation Command Center"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://gwcc.sourceforge.net"
+HOMEPAGE="http://gwcc.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
+IUSE="nls"
DEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1"
@@ -20,16 +18,16 @@ RDEPEND="nls? ( sys-devel/gettext )
src_compile() {
local myconf
-
+
#sandbox fix, always disable nls
myconf="--disable-nls"
#use nls || myconf="--disable-nls"
- econf ${myconf} || die
+ econf ${myconf}
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc COPYING ChangeLog NEWS README
diff --git a/app-admin/jinit/jinit-0.1.9-r1.ebuild b/app-admin/jinit/jinit-0.1.9-r1.ebuild
index 5acd4ad341ba..41d38d5bd5e0 100644
--- a/app-admin/jinit/jinit-0.1.9-r1.ebuild
+++ b/app-admin/jinit/jinit-0.1.9-r1.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/jinit/jinit-0.1.9-r1.ebuild,v 1.10 2002/10/18 13:31:45 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/jinit/jinit-0.1.9-r1.ebuild,v 1.11 2002/11/30 01:28:59 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="An alternative to sysvinit which supports the need(8) concept"
SRC_URI="http://homepage.ntlworld.com/john.fremlin/programs/linux/jinit/download/${P}.tar.gz"
HOMEPAGE="http://homepage.ntlworld.com/john.fremlin/programs/linux/jinit/
@@ -11,19 +10,16 @@ HOMEPAGE="http://homepage.ntlworld.com/john.fremlin/programs/linux/jinit/
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
-IUSE=""
DEPEND="virtual/glibc"
RDEPEND=""
src_compile() {
-
- econf || die
+ econf
make || die
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die
mv ${D}/usr/sbin ${D}
mv ${D}/sbin/init ${D}/sbin/jinit
diff --git a/app-admin/metalog/metalog-0.6-r10.ebuild b/app-admin/metalog/metalog-0.6-r10.ebuild
index 17ceea496e4f..90996f4f808d 100644
--- a/app-admin/metalog/metalog-0.6-r10.ebuild
+++ b/app-admin/metalog/metalog-0.6-r10.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/metalog/metalog-0.6-r10.ebuild,v 1.8 2002/10/20 18:14:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/metalog/metalog-0.6-r10.ebuild,v 1.9 2002/11/30 01:31:07 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="A highly configurable replacement for syslogd/klogd"
SRC_URI="mirror://sourceforge/metalog/${P}.tar.gz"
HOMEPAGE="http://metalog.sourceforge.net/"
-IUSE=""
SLOT="0"
LICENSE="GPL-2"
@@ -14,7 +12,6 @@ KEYWORDS="x86 ppc sparc sparc64"
DEPEND=">=dev-libs/libpcre-3.4"
-
src_unpack() {
unpack ${A} ; cd ${S}
# adds a pidfile option. NiCE aeoo! :)
@@ -30,11 +27,11 @@ src_unpack() {
}
src_compile() {
- econf || die
+ econf
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog README
diff --git a/app-admin/msyslog/msyslog-1.09a.ebuild b/app-admin/msyslog/msyslog-1.09a.ebuild
index 85eadaffaa68..c09be4b4fc79 100644
--- a/app-admin/msyslog/msyslog-1.09a.ebuild
+++ b/app-admin/msyslog/msyslog-1.09a.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/msyslog/msyslog-1.09a.ebuild,v 1.3 2002/10/05 05:39:05 drobbins Exp $
-
-IUSE="postgres mysql"
+# $Header: /var/cvsroot/gentoo-x86/app-admin/msyslog/msyslog-1.09a.ebuild,v 1.4 2002/11/30 01:32:38 vapier Exp $
#lame upstream conventions...
#archive: msyslog-1.09a-src.tar.gz
@@ -13,18 +11,19 @@ DESCRIPTION="Flexible and easy to integrate syslog with modularized input/output
HOMEPAGE="http://sourceforge.net/projects/msyslog/"
SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86 sparc sparc64"
+IUSE="postgres mysql"
+
DEPEND="virtual/glibc"
RDEPEND="${DEPEND}
mysql? ( >=dev-db/mysql-3.23 )
postgres? ( >=dev-db/postgresql-7 )"
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="x86 sparc sparc64"
-
src_unpack() {
- unpack ${A} || die
- cd ${S} || die
+ unpack ${A}
+ cd ${S}
# fix paths for pidfile, config file, libdir, logdir...
patch -p1 <${FILESDIR}/${P}-gentoo.diff || die
}
@@ -33,7 +32,7 @@ src_compile() {
local myconf
use mysql || myconf="${myconf} --without-mysql"
use postgres || myconf="${myconf} --without-pgsql"
- econf --with-daemon-name=msyslogd ${myconf} || die
+ econf --with-daemon-name=msyslogd ${myconf}
emake || die
}
diff --git a/app-admin/mtools/mtools-3.9.8-r1.ebuild b/app-admin/mtools/mtools-3.9.8-r1.ebuild
index cd80e59f3be7..fe200120e251 100644
--- a/app-admin/mtools/mtools-3.9.8-r1.ebuild
+++ b/app-admin/mtools/mtools-3.9.8-r1.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mtools/mtools-3.9.8-r1.ebuild,v 1.15 2002/10/20 18:14:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mtools/mtools-3.9.8-r1.ebuild,v 1.16 2002/11/30 01:37:27 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="Mtools is a collection of utilities to access MS-DOS disks
-from Unix without mounting them. It supports Win95 style long file names,..."
+DESCRIPTION="utilities to access MS-DOS disks from Unix without mounting them"
SRC_URI="http://mtools.linux.lu/mtools-3.9.8.tar.gz"
-HOMEPAGE="http://mtools.linux.lu"
-IUSE=""
+HOMEPAGE="http://mtools.linux.lu/"
SLOT="0"
LICENSE="GPL-2"
@@ -16,13 +13,12 @@ KEYWORDS="x86 ppc sparc sparc64"
DEPEND="sys-apps/texinfo"
src_compile() {
- econf --sysconfdir=/etc/mtools || die
+ econf --sysconfdir=/etc/mtools
make || die
}
-src_install () {
- einstall \
- sysconfdir=${D}/etc/mtools || die
+src_install() {
+ einstall sysconfdir=${D}/etc/mtools
insinto /etc/mtools
newins mtools.conf mtools.conf.example
dodoc COPYING ChangeLog NEWPARAMS README* Release.notes
diff --git a/app-admin/powertweak/powertweak-0.1.17-r2.ebuild b/app-admin/powertweak/powertweak-0.1.17-r2.ebuild
index 50f2bc6bd868..81bac51d7831 100644
--- a/app-admin/powertweak/powertweak-0.1.17-r2.ebuild
+++ b/app-admin/powertweak/powertweak-0.1.17-r2.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/powertweak/powertweak-0.1.17-r2.ebuild,v 1.6 2002/10/18 13:31:45 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/powertweak/powertweak-0.1.17-r2.ebuild,v 1.7 2002/11/30 01:38:27 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Powertweak"
SRC_URI="http://powertweak.sourceforge.net/files/${P}.tar.bz2"
HOMEPAGE="http://powertweak.sourceforge.net"
-IUSE=""
SLOT="0"
LICENSE="GPL-2"
@@ -16,31 +14,28 @@ DEPEND="=x11-libs/gtk+-1.2*
>=dev-libs/libxml-1.8.10"
src_unpack() {
-
CFLAGS="${CPPFLAGS} -Wno-error"
CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
unpack ${A}
cd ${S}
for FILE in `find . -iname "Makefile*"`;do
+ cp ${FILE} ${FILE}.hacked
sed -e "s:\(^CFLAGS =.*\):\1 ${CFLAGS}:" \
-e "s:\(^CPPFLAGS =.*\):\1 ${CPPFLAGS}:" \
- ${FILE} > ${FILE}.hacked || die "Hack failed"
- mv ${FILE}.hacked ${FILE}
+ ${FILE}.hacked > ${FILE} || die "Hack failed"
done
-}
+}
src_compile() {
-
CFLAGS="${CPPFLAGS} -Wno-error"
CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
cp /usr/share/libtool/ltmain.sh .
- econf || die "Configure failed"
+ econf
emake || die "Make failed"
}
src_install() {
-
- make install prefix=${D}/usr || die "Install failed"
+ einstall
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
docinto Documentation
dodoc Documentation/*
diff --git a/app-admin/powertweak/powertweak-0.99.4.ebuild b/app-admin/powertweak/powertweak-0.99.4.ebuild
index 4ae6c9d21d61..9007c40f665e 100644
--- a/app-admin/powertweak/powertweak-0.99.4.ebuild
+++ b/app-admin/powertweak/powertweak-0.99.4.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/powertweak/powertweak-0.99.4.ebuild,v 1.4 2002/10/05 05:39:05 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/powertweak/powertweak-0.99.4.ebuild,v 1.5 2002/11/30 01:40:58 vapier Exp $
-IUSE="gtk"
-
-S=${WORKDIR}/${PN}
-DESCRIPTION="Powertweak"
+DESCRIPTION="tune your kernel and hardware settings for optimal performance"
SRC_URI="mirror://sourceforge/powertweak/${P}.tar.bz2"
-HOMEPAGE="http://powertweak.sourceforge.net"
+HOMEPAGE="http://powertweak.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 -ppc"
+IUSE="gtk"
DEPEND="gtk? ( =x11-libs/gtk+-1.2* )
>=dev-libs/libxml-1.8.10
@@ -21,6 +19,8 @@ DEPEND="gtk? ( =x11-libs/gtk+-1.2* )
RDEPEND=">=sys-apps/pciutils-2.1.0
gtk? ( =x11-libs/gtk+-1.2* )"
+S=${WORKDIR}/${PN}
+
inherit libtool
src_unpack() {
@@ -29,10 +29,10 @@ src_unpack() {
cd ${S} ; patch -l -p1 < ${FILESDIR}/${P}-gentoo.diff
for FILE in `find . -iname "Makefile*"`;do
+ cp ${FILE} ${FILE}.hacked
sed -e "s:\(^CFLAGS =.*\):\1 ${CFLAGS}:" \
-e "s:\(^CPPFLAGS =.*\):\1 ${CPPFLAGS}:" \
- ${FILE} > ${FILE}.hacked || die "Hack failed"
- mv ${FILE}.hacked ${FILE}
+ ${FILE}.hacked > ${FILE} || die "Hack failed"
done
}
@@ -44,7 +44,7 @@ src_compile() {
CFLAGS="${CPPFLAGS} -Wno-error"
CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}
@@ -55,7 +55,7 @@ src_install() {
dodoc Documentation/* Documentation/Hackers/*
use gtk || rm ${D}/usr/bin/gpowertweak
-
+
exeinto /etc/init.d ; newexe ${FILESDIR}/powertweakd.rc6 powertweakd
}
diff --git a/app-admin/powertweak/powertweak-0.99.5_pre20021029.ebuild b/app-admin/powertweak/powertweak-0.99.5_pre20021029.ebuild
index 5c400b1129e2..f4260fa2743e 100644
--- a/app-admin/powertweak/powertweak-0.99.5_pre20021029.ebuild
+++ b/app-admin/powertweak/powertweak-0.99.5_pre20021029.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/powertweak/powertweak-0.99.5_pre20021029.ebuild,v 1.2 2002/11/01 21:55:45 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/powertweak/powertweak-0.99.5_pre20021029.ebuild,v 1.3 2002/11/30 01:43:23 vapier Exp $
-IUSE="gtk"
-
-S=${WORKDIR}/${PN}
-DESCRIPTION="Powertweak"
+DESCRIPTION="tune your kernel and hardware settings for optimal performance"
SRC_URI="mirror://sourceforge/powertweak/${PN}-0.99.4.tar.bz2"
-HOMEPAGE="http://powertweak.sourceforge.net"
+HOMEPAGE="http://powertweak.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 -ppc -sparc -sparc64 -alpha"
+IUSE="gtk"
DEPEND="gtk? ( =x11-libs/gtk+-1.2* )
>=dev-libs/libxml2-2.3.0
@@ -21,8 +19,9 @@ DEPEND="gtk? ( =x11-libs/gtk+-1.2* )
RDEPEND=">=sys-apps/pciutils-2.1.0
gtk? ( =x11-libs/gtk+-1.2* )"
-src_unpack() {
+S=${WORKDIR}/${PN}
+src_unpack() {
unpack ${A}
cd ${S}
bzcat ${FILESDIR}/${P}.diff.bz2 | patch -p1 || die "patch failed"
@@ -30,23 +29,17 @@ src_unpack() {
cp configure.in configure.in.orig
sed -e "s:CFLAGS=\"\":CFLAGS=\"${CFLAGS}\":" \
< configure.in.orig > configure.in
-
}
src_compile() {
-
./autogen.sh
use gtk || myconf="--disable-gtktest"
-
- econf ${myconf} || die
-
+ econf ${myconf}
emake || die
-
}
src_install() {
-
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
@@ -57,5 +50,4 @@ src_install() {
use gtk || rm ${D}/usr/bin/gpowertweak
exeinto /etc/init.d ; newexe ${FILESDIR}/powertweakd.rc6 powertweakd
-
}
diff --git a/app-admin/puregui/puregui-0.3.5.ebuild b/app-admin/puregui/puregui-0.3.5.ebuild
index 641fd2fc1d7f..86c4b4b271f5 100644
--- a/app-admin/puregui/puregui-0.3.5.ebuild
+++ b/app-admin/puregui/puregui-0.3.5.ebuild
@@ -1,32 +1,28 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puregui/puregui-0.3.5.ebuild,v 1.10 2002/10/05 05:39:05 drobbins Exp $
-
-IUSE="nls"
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puregui/puregui-0.3.5.ebuild,v 1.11 2002/11/30 01:45:26 vapier Exp $
S=${WORKDIR}/${PN}
DESCRIPTION="A GUI to Configure Pure-FTPD"
SRC_URI="mirror://sourceforge/pureftpd/${P}.tar.bz2"
-HOMEPAGE="http://pureftpd.sourceforge.net"
+HOMEPAGE="http://pureftpd.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
+IUSE="nls"
DEPEND="=x11-libs/gtk+-1.2*"
RDEPEND="nls? ( sys-devel/gettext )"
src_compile() {
-
local myconf
-
use nls || myconf="${myconf} --disable-nls"
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog NEWS README
}
diff --git a/app-admin/pwgen/pwgen-2.01.ebuild b/app-admin/pwgen/pwgen-2.01.ebuild
index cb6ba708d45a..75d47d0a21e8 100644
--- a/app-admin/pwgen/pwgen-2.01.ebuild
+++ b/app-admin/pwgen/pwgen-2.01.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/pwgen/pwgen-2.01.ebuild,v 1.10 2002/10/20 18:14:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pwgen/pwgen-2.01.ebuild,v 1.11 2002/11/30 01:45:46 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Password Generator"
SRC_URI="mirror://sourceforge/pwgen/${P}.tar.gz"
HOMEPAGE="http://sourceforge.net/projects/pwgen/"
@@ -19,10 +18,10 @@ src_compile() {
sed -e 's:$(prefix)/man/man1:$(mandir)/man1:g' \
Makefile.in.new > Makefile.in
- econf --sysconfdir=/etc/pwgen || die "./configure failed"
+ econf --sysconfdir=/etc/pwgen
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
}
diff --git a/app-admin/runset/runset-1.4.ebuild b/app-admin/runset/runset-1.4.ebuild
index abe89d063ec1..cd68ba663ade 100644
--- a/app-admin/runset/runset-1.4.ebuild
+++ b/app-admin/runset/runset-1.4.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/runset/runset-1.4.ebuild,v 1.9 2002/10/04 03:45:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/runset/runset-1.4.ebuild,v 1.10 2002/11/30 01:46:33 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Runset Init suite, a replacement for sysv style initd"
SRC_URI="ftp://ftp.ocis.net/pub/users/ldeutsch/release/${P}.tar.gz"
HOMEPAGE="http://www.icewalkers.com/softlib/app/app_00233.html"
@@ -14,13 +13,11 @@ KEYWORDS="x86 sparc sparc64"
DEPEND="virtual/glibc"
src_compile() {
-
- econf || die
+ econf
make || die
}
src_install() {
-
# fix info file
echo "INFO-DIR-SECTION Admin" >>doc/runset.info
echo "START-INFO-DIR-ENTRY" >>doc/runset.info