summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-04 22:05:36 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-04 22:05:36 +0000
commitfe01e4bde9275f5f81a47a0464d7a940db872f71 (patch)
tree8fc40113c27316088b19264e5a90bcf7d6135797
parentnew revision that installs english.hash (the user doesn't need to generate it... (diff)
downloadhistorical-fe01e4bde9275f5f81a47a0464d7a940db872f71.tar.gz
historical-fe01e4bde9275f5f81a47a0464d7a940db872f71.tar.bz2
historical-fe01e4bde9275f5f81a47a0464d7a940db872f71.zip
fix problem with tetex, general revamp
-rw-r--r--sys-libs/gpm/files/digest-gpm-1.19.6-r21
-rw-r--r--sys-libs/gpm/gpm-1.19.6-r2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-libs/gpm/files/digest-gpm-1.19.6-r2 b/sys-libs/gpm/files/digest-gpm-1.19.6-r2
new file mode 100644
index 000000000000..06072978fd42
--- /dev/null
+++ b/sys-libs/gpm/files/digest-gpm-1.19.6-r2
@@ -0,0 +1 @@
+MD5 5cedbdc902ebfbb272502062cdbb389c gpm-1.19.6.tar.gz 376832
diff --git a/sys-libs/gpm/gpm-1.19.6-r2.ebuild b/sys-libs/gpm/gpm-1.19.6-r2.ebuild
new file mode 100644
index 000000000000..6ae578bdca1a
--- /dev/null
+++ b/sys-libs/gpm/gpm-1.19.6-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.19.6-r2.ebuild,v 1.1 2002/01/04 22:05:36 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Console-based mouse driver"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/mouse/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ sys-devel/autoconf"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ #this little hack turns off EMACS byte compilation. Really don't want
+ #this thing auto-detecting emacs
+ env ac_cv_path_emacs=no \
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc/gpm || die
+
+ # Do not create gpmdoc.ps, as it cause build to fail with our version
+ # of tetex (it is already there, so this will only create missing
+ # manpages)
+ cp doc/Makefile doc/Makefile.orig
+ sed -e 's:all\: $(srcdir)/gpmdoc.ps:all\::' \
+ doc/Makefile.orig > doc/Makefile
+
+ emake || die
+}
+
+src_install() {
+ #create missing script
+ echo 'mkdir -p "$@"' > ${S}/mkinstalldirs
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc/gpm \
+ install || die
+ chmod 755 ${D}/usr/lib/libgpm.so.1.18.0
+ dodoc BUGS COPYING ChangeLog Changes MANIFEST README TODO
+ dodoc doc/Announce doc/FAQ doc/README*
+# doman doc/gpm.8 doc/mev.1 doc/gpm-root.1 doc/gpm-types.7 doc/mouse-test.1
+ doinfo doc/gpm.info
+ docinto txt
+ dodoc doc/gpmdoc.txt
+ docinto ps
+ dodoc doc/gpmdoc.ps
+
+ insinto /etc/gpm
+ doins conf/gpm-*.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/gpm.rc6 gpm
+ insinto /etc/conf.d
+ newins ${FILESDIR}/gpm.conf.d gpm
+}