summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 14:25:57 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 14:25:57 +0000
commit26c0b78b6283dd6e3318f2379758010b49aee23d (patch)
treec4c649821238f48d44828eedfe420bc7a5a3c3da /app-admin/cpu
parentadded tetex dep (diff)
downloadhistorical-26c0b78b6283dd6e3318f2379758010b49aee23d.tar.gz
historical-26c0b78b6283dd6e3318f2379758010b49aee23d.tar.bz2
historical-26c0b78b6283dd6e3318f2379758010b49aee23d.zip
need eutils for epatch
Diffstat (limited to 'app-admin/cpu')
-rw-r--r--app-admin/cpu/cpu-1.3.100-r1.ebuild25
-rw-r--r--app-admin/cpu/cpu-1.3.100.ebuild25
2 files changed, 25 insertions, 25 deletions
diff --git a/app-admin/cpu/cpu-1.3.100-r1.ebuild b/app-admin/cpu/cpu-1.3.100-r1.ebuild
index 4699881eeefa..83a526ab1cc7 100644
--- a/app-admin/cpu/cpu-1.3.100-r1.ebuild
+++ b/app-admin/cpu/cpu-1.3.100-r1.ebuild
@@ -1,31 +1,30 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/cpu-1.3.100-r1.ebuild,v 1.2 2003/07/06 07:03:42 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/cpu-1.3.100-r1.ebuild,v 1.3 2003/08/05 14:24:03 vapier Exp $
-DESCRIPTION="CPU is an LDAP user management tool written in C and loosely based on FreeBSD's pw(8)."
+DESCRIPTION="LDAP user management tool written in C and loosely based on FreeBSD's pw(8)"
HOMEPAGE="http://cpu.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
-RDEPEND="net-nds/openldap
- sys-libs/cracklib"
+RDEPEND="net-nds/openldap
+ sys-libs/cracklib"
DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.54"
-
-S=${WORKDIR}/${P}
+ >=sys-devel/autoconf-2.54"
WANT_AUTOCONF_2_5=1
-src_compile() {
-
+pkg_setup() {
if use static; then
- MSG="Sorry, the package does NOT support static building."
- eerror "${MSG}"
+ eerror "Sorry, the package does NOT support static building."
fi
+ return 0
+}
+src_compile() {
local myconf
# provide PASSWD support as well
@@ -42,7 +41,7 @@ src_compile() {
# This app really belongs in sbin!
myconf="${myconf} --bindir=/usr/sbin"
-
+
econf ${myconf} || die "Configure failure"
emake || die "Make failure"
diff --git a/app-admin/cpu/cpu-1.3.100.ebuild b/app-admin/cpu/cpu-1.3.100.ebuild
index dc4703f1f3ba..34e4b8efadb2 100644
--- a/app-admin/cpu/cpu-1.3.100.ebuild
+++ b/app-admin/cpu/cpu-1.3.100.ebuild
@@ -1,31 +1,32 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/cpu-1.3.100.ebuild,v 1.2 2003/07/05 08:57:48 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/cpu-1.3.100.ebuild,v 1.3 2003/08/05 14:24:03 vapier Exp $
-DESCRIPTION="CPU is an LDAP user management tool written in C and loosely based on FreeBSD's pw(8)."
+inherit eutils
+
+DESCRIPTION="LDAP user management tool written in C and loosely based on FreeBSD's pw(8)"
HOMEPAGE="http://cpu.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
-RDEPEND="net-nds/openldap
- sys-libs/cracklib"
+RDEPEND="net-nds/openldap
+ sys-libs/cracklib"
DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.54"
-
-S=${WORKDIR}/${P}
+ >=sys-devel/autoconf-2.54"
WANT_AUTOCONF_2_5=1
-src_compile() {
-
+pkg_setup() {
if use static; then
- MSG="Sorry, the package does NOT support static building."
- eerror "${MSG}"
+ eerror "Sorry, the package does NOT support static building."
fi
+ return 0
+}
+src_compile() {
# The package has a history of bad configure files...
epatch ${FILESDIR}/${P}-fixup.patch
autoconf