summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-11-22 17:39:04 +0000
committerUlrich Müller <ulm@gentoo.org>2009-11-22 17:39:04 +0000
commitd1134fcbe4b47bcb19abe69c0b4b366a852ec1eb (patch)
tree1214ca78e62d419fa00ae40f6a32fc108b31c0d5 /app-admin/eselect-unison
parentfix regression in the portage provider (diff)
downloadhistorical-d1134fcbe4b47bcb19abe69c0b4b366a852ec1eb.tar.gz
historical-d1134fcbe4b47bcb19abe69c0b4b366a852ec1eb.tar.bz2
historical-d1134fcbe4b47bcb19abe69c0b4b366a852ec1eb.zip
Version bump: support brief output mode, bug 292115.
Package-Manager: portage-2.2_rc51/cvs/Linux i686
Diffstat (limited to 'app-admin/eselect-unison')
-rw-r--r--app-admin/eselect-unison/ChangeLog10
-rw-r--r--app-admin/eselect-unison/eselect-unison-0.2.ebuild26
-rw-r--r--app-admin/eselect-unison/files/unison.eselect-0.2147
3 files changed, 181 insertions, 2 deletions
diff --git a/app-admin/eselect-unison/ChangeLog b/app-admin/eselect-unison/ChangeLog
index 81f536cb9c28..31edb4dd821c 100644
--- a/app-admin/eselect-unison/ChangeLog
+++ b/app-admin/eselect-unison/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/eselect-unison
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-unison/ChangeLog,v 1.8 2008/06/30 20:37:46 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-unison/ChangeLog,v 1.9 2009/11/22 17:39:04 ulm Exp $
+
+*eselect-unison-0.2 (22 Nov 2009)
+
+ 22 Nov 2009; Ulrich Mueller <ulm@gentoo.org> +files/unison.eselect-0.2,
+ +eselect-unison-0.2.ebuild:
+ Version bump: support brief output mode, bug 292115.
30 Jun 2008; Raúl Porcel <armin76@gentoo.org> eselect-unison-0.1.ebuild:
sparc stable wrt #229187
diff --git a/app-admin/eselect-unison/eselect-unison-0.2.ebuild b/app-admin/eselect-unison/eselect-unison-0.2.ebuild
new file mode 100644
index 000000000000..5e63073cafc0
--- /dev/null
+++ b/app-admin/eselect-unison/eselect-unison-0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-unison/eselect-unison-0.2.ebuild,v 1.1 2009/11/22 17:39:04 ulm Exp $
+
+inherit eutils
+
+DESCRIPTION="unison module for eselect"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-admin/eselect-1.2.3"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="unison"
+ dodir ${MODULEDIR}
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}/${MODULE}.eselect-${PVR}" ${MODULE}.eselect \
+ || die "failed to install"
+}
diff --git a/app-admin/eselect-unison/files/unison.eselect-0.2 b/app-admin/eselect-unison/files/unison.eselect-0.2
new file mode 100644
index 000000000000..ef40b989784d
--- /dev/null
+++ b/app-admin/eselect-unison/files/unison.eselect-0.2
@@ -0,0 +1,147 @@
+# -*-eselect-*- vim: ft=eselect
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: unison.eselect-0.2,v 1.1 2009/11/22 17:39:04 ulm Exp $
+
+DESCRIPTION="Manage /usr/bin/unison versions"
+MAINTAINER="ml@gentoo.org"
+SVN_DATE='$Date: 2009/11/22 17:39:04 $'
+VERSION=$(svn_date_to_version "${SVN_DATE}" )
+
+# find a list of unison symlink targets, best first
+find_targets() {
+ local f
+ for f in "${ROOT}"/usr/bin/unison-[0-9]*; do
+ if [[ -f ${f} ]] ; then
+ echo "${f##*/unison-}"
+ fi
+ done | tac
+}
+
+# find version number of currently symlinked version
+identify_target() {
+ local f
+ f="$(canonicalise "${ROOT}"/usr/bin/unison)"
+ echo "${f##*/unison-}"
+}
+
+# try to remove the unison symlink
+remove_symlinks() {
+ rm -f "${ROOT}"/usr/bin/unison &>/dev/null
+}
+
+# set the unison symlink
+set_symlinks() {
+ local target="${1}" targets
+ if is_number "${target}" && [[ ${target} -ge 1 ]] ; then
+ targets=( $(find_targets ) )
+ target=${targets[$(( ${target} - 1 ))]}
+ fi
+ if [[ -f "${ROOT}/usr/bin/unison-${target}" ]] ; then
+ remove_symlinks
+ ln -s "unison-${target}" "${ROOT}/usr/bin/unison" || \
+ die "Could not set ${target} /usr/bin/unison symlink"
+ else
+ die -q "Target \"${target}\" doesn't appear to be valid!"
+ fi
+}
+
+### show action ###
+
+describe_show() {
+ echo "Show the current unison version"
+}
+
+do_show() {
+ [[ -z "${@}" ]] || die -q "Too many parameters"
+
+ write_list_start "Current unison verson:"
+ if [[ -L "${ROOT}/usr/bin/unison" ]] ; then
+ write_kv_list_entry "$(identify_target)" ""
+ elif [[ -e "${ROOT}/usr/bin/unison" ]] ; then
+ write_kv_list_entry "(not a symlink)" ""
+ else
+ write_kv_list_entry "(unset)" ""
+ fi
+}
+
+### list action ###
+
+describe_list() {
+ echo "List available unison versions"
+}
+
+do_list() {
+ [[ $# -eq 0 ]] || die -q "Too many parameters"
+
+ local i targets current
+ targets=( $(find_targets ) )
+ current=$(identify_target)
+ for (( i = 0; i < ${#targets[@]}; i++ )); do
+ [[ ${targets[i]} = ${current} ]] \
+ && targets[i]=$(highlight_marker "${targets[i]}")
+ done
+ write_list_start "Available unison versions:"
+ write_numbered_list -m "(none found)" "${targets[@]}"
+}
+
+### set action ###
+
+describe_set() {
+ echo "Set a new unison version"
+}
+
+describe_set_options() {
+ echo "target : Target version number or index from 'list' action"
+}
+
+describe_set_parameters() {
+ echo "<target>"
+}
+
+do_set() {
+ if [[ -z "${1}" ]] ; then
+ die -q "You didn't give me a version number"
+
+ elif [[ -n "${2}" ]] ; then
+ die -q "Too many parameters"
+
+ elif [[ -L "${ROOT}/usr/bin/unison" ]] ; then
+ if ! remove_symlinks ; then
+ die -q "Can't remove existing version symlink"
+ elif ! set_symlinks "${1}" ; then
+ die -q "Can't set new version"
+ fi
+
+ elif [[ -e "${ROOT}/usr/bin/unison" ]] ; then
+ die -q "${ROOT}/usr/bin/unison seems to be from an old ebuild, please remove manually"
+
+ else
+ set_symlinks "${1}" || die -q "Can't set new version"
+ fi
+}
+
+### update action ###
+
+describe_update() {
+ echo "Automatically update the unison version number"
+}
+
+describe_update_options() {
+ echo "--if-unset : Do not override currently selected version"
+}
+
+do_update() {
+ [[ -z "${1}" ]] || ( [[ -z "${2}" ]] && [[ "${1}" == "--if-unset" ]] ) || \
+ die -q "Usage error"
+
+ if [[ -L "${ROOT}/usr/bin/unison" ]] ; then
+ [[ ${1} == "--if-unset" ]] && return
+ remove_symlinks || die -q "Can't remove existing symlink"
+ fi
+ if [[ -e "${ROOT}/usr/bin/unison" ]] ; then
+ die -q "${ROOT}/usr/bin/unison seems to be from an old ebuild, please remove manually"
+ elif ! [[ -z $(find_targets ) ]] ; then
+ set_symlinks 1 || die -q "Can't set a new version"
+ fi
+}