summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-08-08 11:43:44 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-08-08 11:43:44 +0000
commit010091da1651a7976655f1ef57c04ebfc8156a88 (patch)
treefc96e6cedae696492652a2658e0c3b154c044382 /app-admin/tmpwatch
parentversion bump and closing #23511 (diff)
downloadhistorical-010091da1651a7976655f1ef57c04ebfc8156a88.tar.gz
historical-010091da1651a7976655f1ef57c04ebfc8156a88.tar.bz2
historical-010091da1651a7976655f1ef57c04ebfc8156a88.zip
version bump and closing #23511
Diffstat (limited to 'app-admin/tmpwatch')
-rw-r--r--app-admin/tmpwatch/Manifest4
-rw-r--r--app-admin/tmpwatch/files/digest-tmpwatch-2.9.01
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.9.0.ebuild39
3 files changed, 42 insertions, 2 deletions
diff --git a/app-admin/tmpwatch/Manifest b/app-admin/tmpwatch/Manifest
index 16c879ac9bc2..225372694aed 100644
--- a/app-admin/tmpwatch/Manifest
+++ b/app-admin/tmpwatch/Manifest
@@ -1,5 +1,5 @@
-MD5 a3ea8e220578e6227174e14e6bdaa156 ChangeLog 676
+MD5 cf22cacbc46eb3360f9c5d56c8f73311 ChangeLog 885
MD5 b10e3a536a1780c29245767f876a916e tmpwatch-2.8.4.ebuild 998
-MD5 3a5000e54e17ae6e51a182e50d50d9b2 tmpwatch-2.9.0.ebuild 1033
+MD5 dd13dfdc2b24d2ba9601c10cbba72b69 tmpwatch-2.9.0.ebuild 1033
MD5 dda6f902f6f95e2696dadeecd0bfeb64 files/digest-tmpwatch-2.8.4 68
MD5 185828eaf60e27de261fa50a676a47b6 files/digest-tmpwatch-2.9.0 68
diff --git a/app-admin/tmpwatch/files/digest-tmpwatch-2.9.0 b/app-admin/tmpwatch/files/digest-tmpwatch-2.9.0
new file mode 100644
index 000000000000..8192dfd6b802
--- /dev/null
+++ b/app-admin/tmpwatch/files/digest-tmpwatch-2.9.0
@@ -0,0 +1 @@
+MD5 c1d980ad4f082b0f69c7d373628a4a33 tmpwatch-2.9.0-2.src.rpm 20943
diff --git a/app-admin/tmpwatch/tmpwatch-2.9.0.ebuild b/app-admin/tmpwatch/tmpwatch-2.9.0.ebuild
new file mode 100644
index 000000000000..a2ae863aa15c
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/tmpwatch-2.9.0.ebuild,v 1.1 2003/08/08 11:42:53 aliz Exp $
+
+RPM_V="2"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Utility recursively searches through specified directories and removes files which have not been accessed in a specified period of time."
+SRC_URI="ftp://ftp.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS/${P}-${RPM_V}.src.rpm"
+HOMEPAGE="ftp://ftp.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+
+DEPEND="virtual/glibc
+ app-arch/rpm2targz"
+
+src_unpack() {
+ cd ${WORKDIR}
+ rpm2targz ${DISTDIR}/${P}-${RPM_V}.src.rpm
+ tar zxf ${P}-${RPM_V}.src.tar.gz
+ tar zxf ${P}.tar.gz
+
+ cd ${S}
+ sed -i "s:..RPM_OPT_FLAGS.:${CFLAGS}:" Makefile
+ sed -i 's|/sbin/fuser|/bin/fuser|' tmpwatch.c
+ sed -i 's|/sbin|/bin|' tmpwatch.8
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ preplib /usr
+
+ dosbin tmpwatch
+ doman tmpwatch.8
+}