summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-12-31 22:38:46 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-12-31 22:38:46 +0000
commit7da7b84952990dd8acf41dcc1dae8446fcc846f1 (patch)
tree0b81804cd7bb557da24622f3d7cea5e6a83940bf /app-admin/torsmo
parentConfig files are now installed with src_install(). (diff)
downloadhistorical-7da7b84952990dd8acf41dcc1dae8446fcc846f1.tar.gz
historical-7da7b84952990dd8acf41dcc1dae8446fcc846f1.tar.bz2
historical-7da7b84952990dd8acf41dcc1dae8446fcc846f1.zip
revision bump to fix endless loop for AMD64 users. Bug #74036
Diffstat (limited to 'app-admin/torsmo')
-rw-r--r--app-admin/torsmo/ChangeLog13
-rw-r--r--app-admin/torsmo/files/digest-torsmo-0.18-r11
-rw-r--r--app-admin/torsmo/files/torsmo-0.18.xwin.patch18
-rw-r--r--app-admin/torsmo/torsmo-0.17-r1.ebuild4
-rw-r--r--app-admin/torsmo/torsmo-0.17.ebuild4
-rw-r--r--app-admin/torsmo/torsmo-0.18-r1.ebuild54
-rw-r--r--app-admin/torsmo/torsmo-0.18.ebuild6
7 files changed, 91 insertions, 9 deletions
diff --git a/app-admin/torsmo/ChangeLog b/app-admin/torsmo/ChangeLog
index 122de0f7bed4..8defca758592 100644
--- a/app-admin/torsmo/ChangeLog
+++ b/app-admin/torsmo/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-admin/torsmo
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/ChangeLog,v 1.19 2004/12/27 23:56:32 dragonheart Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/ChangeLog,v 1.20 2004/12/31 22:38:46 dragonheart Exp $
+
+*torsmo-0.18-r1 (01 Jan 2005)
+
+ 01 Jan 2005; Daniel Black <dragonheart@gentoo.org>
+ +files/torsmo-0.18.xwin.patch, +torsmo-0.18-r1.ebuild, torsmo-0.18.ebuild:
+ revision bump to fix endless loop for AMD64 users. Bug #74036 and
+ http://sourceforge.net/tracker/index.php?func=detail&aid=1087205&group_id=1085
+ 94&atid=650929 refer. Thanks to Florian Huber <florian.huber@mnet-online.de>
+ for pointing out the solution and floam@sh.nu for testing it.
28 Dec 2004; Daniel Black <dragonheart@gentoo.org> torsmo-0.18.ebuild:
X libraries fix as per bug #75828. Fix by Emil Beinroth <emilbeinroth@gmx.net>.
diff --git a/app-admin/torsmo/files/digest-torsmo-0.18-r1 b/app-admin/torsmo/files/digest-torsmo-0.18-r1
new file mode 100644
index 000000000000..f2c1092e434d
--- /dev/null
+++ b/app-admin/torsmo/files/digest-torsmo-0.18-r1
@@ -0,0 +1 @@
+MD5 88bd8f627637d785a1d681f4f15f00b6 torsmo-0.18.tar.gz 84020
diff --git a/app-admin/torsmo/files/torsmo-0.18.xwin.patch b/app-admin/torsmo/files/torsmo-0.18.xwin.patch
new file mode 100644
index 000000000000..57275b8d59da
--- /dev/null
+++ b/app-admin/torsmo/files/torsmo-0.18.xwin.patch
@@ -0,0 +1,18 @@
+--- x11.c.orig 2005-01-01 07:56:33.135756896 +0930
++++ x11.c 2005-01-01 07:57:16.810117384 +0930
+@@ -64,15 +64,6 @@
+
+ XFree(buf); buf = 0;
+
+- /* get workarea */
+- if (XGetWindowProperty(display, root, ATOM(_NET_WORKAREA), desktop*4, 4,
+- False, XA_CARDINAL, &type, &format, &nitems, &bytes, &buf) ==
+- Success && type == XA_CARDINAL) {
+- workarea[0] = ((long *) buf)[0];
+- workarea[1] = ((long *) buf)[1];
+- workarea[2] = ((long *) buf)[2];
+- workarea[3] = ((long *) buf)[3];
+- }
+ }
+
+ if (buf) { XFree(buf); buf = 0; }
diff --git a/app-admin/torsmo/torsmo-0.17-r1.ebuild b/app-admin/torsmo/torsmo-0.17-r1.ebuild
index 2a2e578c675d..a6ed5fba7671 100644
--- a/app-admin/torsmo/torsmo-0.17-r1.ebuild
+++ b/app-admin/torsmo/torsmo-0.17-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/torsmo-0.17-r1.ebuild,v 1.4 2004/12/07 21:06:19 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/torsmo-0.17-r1.ebuild,v 1.5 2004/12/31 22:38:46 dragonheart Exp $
inherit eutils linux-info
diff --git a/app-admin/torsmo/torsmo-0.17.ebuild b/app-admin/torsmo/torsmo-0.17.ebuild
index 23307ba8c541..a04e5bd66387 100644
--- a/app-admin/torsmo/torsmo-0.17.ebuild
+++ b/app-admin/torsmo/torsmo-0.17.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/torsmo-0.17.ebuild,v 1.10 2004/10/19 22:00:17 bazik Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/torsmo-0.17.ebuild,v 1.11 2004/12/31 22:38:46 dragonheart Exp $
inherit eutils
diff --git a/app-admin/torsmo/torsmo-0.18-r1.ebuild b/app-admin/torsmo/torsmo-0.18-r1.ebuild
new file mode 100644
index 000000000000..bb9d389b3373
--- /dev/null
+++ b/app-admin/torsmo/torsmo-0.18-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/torsmo-0.18-r1.ebuild,v 1.1 2004/12/31 22:38:46 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="minimalist system monitor for X"
+HOMEPAGE="http://torsmo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/torsmo/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+IUSE=""
+
+RDEPEND="virtual/libc
+ virtual/x11"
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.4
+ sys-devel/autoconf
+ sys-apps/grep
+ sys-apps/sed
+ sys-devel/gcc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}.xwin.patch || die "patch failed"
+}
+
+src_compile() {
+ econf --x-libraries=/usr/X11R6/lib/ || die "econf failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "make install failed"
+ dodoc ChangeLog AUTHORS README torsmorc.sample
+}
+
+pkg_postinst() {
+ einfo 'default configuration file is "~/.torsmorc"'
+ einfo "you can find a sample configuration file in"
+ einfo "/usr/share/doc/${PF}/torsmorc.sample.gz"
+ einfo
+ einfo "Comment out temperature info lines if you have no kernel"
+ einfo "support for it."
+ einfo
+ ewarn "Torsmo doesn't work with window managers that"
+ ewarn "take control over root window such as Gnome's nautilus."
+ einfo
+ ewarn "Please note that >=0.18 contains mozilla support without"
+ ewarn "patching, thus the mozilla USE flag has been dropped"
+}
diff --git a/app-admin/torsmo/torsmo-0.18.ebuild b/app-admin/torsmo/torsmo-0.18.ebuild
index b1d0222fa050..1ba89cb7f5c5 100644
--- a/app-admin/torsmo/torsmo-0.18.ebuild
+++ b/app-admin/torsmo/torsmo-0.18.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/torsmo-0.18.ebuild,v 1.2 2004/12/27 23:56:32 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/torsmo-0.18.ebuild,v 1.3 2004/12/31 22:38:46 dragonheart Exp $
DESCRIPTION="minimalist system monitor for X"
HOMEPAGE="http://torsmo.sourceforge.net/"
@@ -27,7 +27,7 @@ src_compile() {
src_install() {
emake DESTDIR=${D} install || die "make install failed"
- dodoc ChangeLog AUTHORS README NEWS torsmorc.sample
+ dodoc ChangeLog AUTHORS README torsmorc.sample
}
pkg_postinst() {