summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2006-07-19 20:58:50 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2006-07-19 20:58:50 +0000
commitca33b4576c51d987bc61231087eb75f66197323a (patch)
tree0ad4aef727385f452933175cb53cade940b438d8 /app-admin/webapp-config/webapp-config-1.50.15.ebuild
parentVersion bump for #140444. (diff)
downloadhistorical-ca33b4576c51d987bc61231087eb75f66197323a.tar.gz
historical-ca33b4576c51d987bc61231087eb75f66197323a.tar.bz2
historical-ca33b4576c51d987bc61231087eb75f66197323a.zip
Release of webapp-config-1.50.15. rl03 added the webapp-cleaner.
Package-Manager: portage-2.1-r1
Diffstat (limited to 'app-admin/webapp-config/webapp-config-1.50.15.ebuild')
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.15.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.50.15.ebuild b/app-admin/webapp-config/webapp-config-1.50.15.ebuild
new file mode 100644
index 000000000000..6b3ae5def3db
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.50.15.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.15.ebuild,v 1.1 2006/07/19 20:58:50 wrobel Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~wrobel/webapp-config/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+S=${WORKDIR}/${PF}
+
+DEPEND=""
+
+src_install() {
+
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils_src_install --install-scripts="/usr/sbin"
+
+ dodir /etc/vhosts
+ cp config/webapp-config ${D}/etc/vhosts/
+ keepdir /usr/share/webapps
+ keepdir /var/db/webapps
+ dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt TODO.txt CHANGES.txt examples/postinstall-en.txt
+ doman doc/webapp-config.5 doc/webapp-config.8 doc/webapp.eclass.5
+ dohtml doc/webapp-config.5.html doc/webapp-config.8.html doc/webapp.eclass.5.html
+}
+
+src_test() {
+ cd ${S}
+ distutils_python_version
+ if [[ $PYVER_MAJOR > 1 ]] && [[ $PYVER_MINOR > 3 ]] ; then
+ einfo "Running webapp-config doctests..."
+ if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
+ eerror "DocTests failed - please submit a bug report"
+ die "DocTesting failed!"
+ fi
+ else
+ einfo "Python version below 2.4! Disabling tests."
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "Now that you have upgraded webapp-config, you **must** update your"
+ einfo "config files in /etc/vhosts/webapp-config before you emerge any"
+ einfo "packages that use webapp-config."
+ echo
+ epause 5
+}