summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-09 12:24:38 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-09 12:24:38 +0000
commit8442765a454c1db8666be17445ec0ade72b7d930 (patch)
treece62edc21bea3b4bcdb3bfb617b46c09cbeb87ea /app-admin/webmin
parentVersion bumped (diff)
downloadhistorical-8442765a454c1db8666be17445ec0ade72b7d930.tar.gz
historical-8442765a454c1db8666be17445ec0ade72b7d930.tar.bz2
historical-8442765a454c1db8666be17445ec0ade72b7d930.zip
Version bumped
Diffstat (limited to 'app-admin/webmin')
-rw-r--r--app-admin/webmin/Manifest4
-rw-r--r--app-admin/webmin/files/digest-webmin-1.1211
-rw-r--r--app-admin/webmin/webmin-1.121.ebuild75
3 files changed, 78 insertions, 2 deletions
diff --git a/app-admin/webmin/Manifest b/app-admin/webmin/Manifest
index 04d6af685ada..6c3b4accd87a 100644
--- a/app-admin/webmin/Manifest
+++ b/app-admin/webmin/Manifest
@@ -1,9 +1,9 @@
-MD5 953a671dcb52845b87f48d832e8276c8 ChangeLog 4603
+MD5 dcecd2047781e72989206768f0fef2e0 ChangeLog 4721
MD5 85e44244d64f3c9d6c9633fcc8d97d76 webmin-1.080.ebuild 1763
MD5 22fd790cb463b3fb55e6a3343e07cd20 webmin-1.110.ebuild 1865
MD5 4b168c5132365cfb0035fecb1b374728 webmin-1.120.ebuild 1854
MD5 7fdd3ae59bfbac3959bdc75e2b40e3dc webmin-1.100-r1.ebuild 1933
-MD5 4b168c5132365cfb0035fecb1b374728 webmin-1.121.ebuild 1854
+MD5 8d1a135288202f1da4efa63d12ee36e9 webmin-1.121.ebuild 1854
MD5 c2e70e10958f50cd84c377b5963a8ced files/digest-webmin-1.080 65
MD5 7519cb946bf13c469d0e6ae31afd9e1a files/digest-webmin-1.120 65
MD5 bc8eb1c9de103599fc00b140b0ed1f9f files/uninstall.sh 260
diff --git a/app-admin/webmin/files/digest-webmin-1.121 b/app-admin/webmin/files/digest-webmin-1.121
new file mode 100644
index 000000000000..bf534bb9d424
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-1.121
@@ -0,0 +1 @@
+MD5 dbcbd15008cfcc588eb76ad445fb6d99 webmin-1.121.tar.gz 6784004
diff --git a/app-admin/webmin/webmin-1.121.ebuild b/app-admin/webmin/webmin-1.121.ebuild
new file mode 100644
index 000000000000..4d1f409fe726
--- /dev/null
+++ b/app-admin/webmin/webmin-1.121.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.121.ebuild,v 1.1 2003/11/09 12:24:32 mholzer Exp $
+
+IUSE="ssl"
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.webmin.com/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+
+DEPEND="dev-lang/perl
+ ssl? ( dev-perl/Net-SSLeay )"
+
+src_install() {
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /etc/init.d
+ dodir /var
+ dodir /etc/pam.d
+ cp -rp * ${D}/usr/libexec/webmin
+ mv ${D}/usr/libexec/webmin/openslp/config \
+ ${D}/usr/libexec/webmin/openslp/config-gentoo-linux
+
+ exeinto /etc/init.d
+ newexe webmin-gentoo-init webmin
+
+ insinto /etc/pam.d/
+ newins webmin-pam webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ exeinto /etc/webmin
+ doexe ${FILESDIR}/uninstall.sh
+ use ssl sed -i 's:ssl=$ssl:ssl=1:' setup.sh
+}
+
+pkg_postinst() {
+ /etc/init.d/webmin stop >/dev/null 2>&1
+ stopstatus=$?
+ cd /usr/libexec/webmin
+ config_dir=/etc/webmin
+ var_dir=/var/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/webmin/maketemp.pl
+ ./setup.sh >/tmp/.webmin/webmin-setup.out 2>&1
+
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/webmin start
+ fi
+}
+
+pkg_prerm() {
+ webmin stop
+}