summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Bormolini <lordjoe@gentoo.org>2001-08-03 09:10:31 +0000
committerJoe Bormolini <lordjoe@gentoo.org>2001-08-03 09:10:31 +0000
commit542fe40055443cd1fd2a1325a05947c8403a16fe (patch)
treeee3d5dfe3948879cc18d710f93c0eca918d020e9 /app-admin
parent4 new ebuilds by Craig Joly, read the wiki note before working on them (diff)
downloadhistorical-542fe40055443cd1fd2a1325a05947c8403a16fe.tar.gz
historical-542fe40055443cd1fd2a1325a05947c8403a16fe.tar.bz2
historical-542fe40055443cd1fd2a1325a05947c8403a16fe.zip
A bunch of bbtools ebuilds from Craig Joly <joly@ee.ualberta.ca> and myself Joe Bormolini <lordjoe@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/bbapm/bbapm-0.0.1.ebuild29
-rw-r--r--app-admin/bbapm/files/digest-bbapm-0.0.11
-rw-r--r--app-admin/bbsload/bbsload-0.2.5.ebuild28
-rw-r--r--app-admin/bbsload/files/digest-bbsload-0.2.51
4 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/bbapm/bbapm-0.0.1.ebuild b/app-admin/bbapm/bbapm-0.0.1.ebuild
new file mode 100644
index 000000000000..05702d5643c7
--- /dev/null
+++ b/app-admin/bbapm/bbapm-0.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Craig Joly <joly@ee.ualberta.ca>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox advanced power management tool"
+SRC_URI="http://bbtools.thelinuxcommunity.org/sources/${A}"
+HOMEPAGE="http://bbtools.thelinuxcommunity.org/contrib.phtml"
+
+DEPEND=">=x11-wm/blackbox-0.61
+ >=sys-apps/apmd-3.0.1"
+
+src_compile() {
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ try emake
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README TODO
+ cd /usr/X11R6/bin/wm
+ cp blackbox blackbox.bak
+ sed -e s:.*blackbox:"exec /usr/X11R6/bin/bbapm \&\n&": blackbox.bak > blackbox
+}
+
diff --git a/app-admin/bbapm/files/digest-bbapm-0.0.1 b/app-admin/bbapm/files/digest-bbapm-0.0.1
new file mode 100644
index 000000000000..33ef2d23d594
--- /dev/null
+++ b/app-admin/bbapm/files/digest-bbapm-0.0.1
@@ -0,0 +1 @@
+MD5 4d2629959bd907696c7765b7c34bc54f bbapm-0.0.1.tar.gz
diff --git a/app-admin/bbsload/bbsload-0.2.5.ebuild b/app-admin/bbsload/bbsload-0.2.5.ebuild
new file mode 100644
index 000000000000..af2cd33709e1
--- /dev/null
+++ b/app-admin/bbsload/bbsload-0.2.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joe Bormolini <lordjoe@gentoo.org>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox load monitor"
+SRC_URI="http://bbtools.thelinuxcommunity.org/sources/${A}"
+HOMEPAGE="http://bbtools.windsofstorm.net/available.phtml#bbsload"
+
+DEPEND=">=x11-wm/blackbox-0.61"
+
+src_compile() {
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ try emake
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc README COPYING AUTHORS BUGS INSTALL ChangeLog NEWS TODO data/README.bbsload
+ cd /usr/X11R6/bin/wm
+ cp blackbox blackbox.bak
+ sed -e s:.*blackbox:"exec /usr/X11R6/bin/bbsload \&\n&": blackbox.bak > blackbox
+}
+
diff --git a/app-admin/bbsload/files/digest-bbsload-0.2.5 b/app-admin/bbsload/files/digest-bbsload-0.2.5
new file mode 100644
index 000000000000..43177b055ffe
--- /dev/null
+++ b/app-admin/bbsload/files/digest-bbsload-0.2.5
@@ -0,0 +1 @@
+MD5 b7096bddeffbc37d87fa1000370b67e6 bbsload-0.2.5.tar.gz