summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2007-01-10 19:43:52 +0000
committerJonathan Smith <smithj@gentoo.org>2007-01-10 19:43:52 +0000
commit55a94ceab19010208d78b8ab8c3f6556f87f9ff6 (patch)
treea23b1148dbc5de0c6bf8b9bedc8e9c86f80ef771 /app-admin
parentDependency update: dev-util/guile -> dev-scheme/guile. (diff)
downloadhistorical-55a94ceab19010208d78b8ab8c3f6556f87f9ff6.tar.gz
historical-55a94ceab19010208d78b8ab8c3f6556f87f9ff6.tar.bz2
historical-55a94ceab19010208d78b8ab8c3f6556f87f9ff6.zip
version bump
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/rmake/ChangeLog9
-rw-r--r--app-admin/rmake/files/digest-rmake-1.0.33
-rw-r--r--app-admin/rmake/rmake-1.0.3.ebuild43
3 files changed, 53 insertions, 2 deletions
diff --git a/app-admin/rmake/ChangeLog b/app-admin/rmake/ChangeLog
index 59d80a5ef06c..f95a517f6b0d 100644
--- a/app-admin/rmake/ChangeLog
+++ b/app-admin/rmake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/rmake
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/rmake/ChangeLog,v 1.5 2006/11/21 17:34:13 smithj Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/rmake/ChangeLog,v 1.6 2007/01/10 19:43:52 smithj Exp $
+
+*rmake-1.0.3 (10 Jan 2007)
+
+ 10 Jan 2007; <smithj@gentoo.org> -rmake-1.0.ebuild, +rmake-1.0.3.ebuild:
+ version bump
*rmake-1.0.2 (21 Nov 2006)
diff --git a/app-admin/rmake/files/digest-rmake-1.0.3 b/app-admin/rmake/files/digest-rmake-1.0.3
new file mode 100644
index 000000000000..e994d1353598
--- /dev/null
+++ b/app-admin/rmake/files/digest-rmake-1.0.3
@@ -0,0 +1,3 @@
+MD5 56ba74b5e88ce772db2104b127d04855 rmake-1.0.3.tar.bz2 92299
+RMD160 012306994cc5f0b88ad4b8e5f3722c1da0e5af26 rmake-1.0.3.tar.bz2 92299
+SHA256 651b7e0909c916ddf7cd7df1b57d83b85bf7fd871ec905d0ac6c43cf75eb679e rmake-1.0.3.tar.bz2 92299
diff --git a/app-admin/rmake/rmake-1.0.3.ebuild b/app-admin/rmake/rmake-1.0.3.ebuild
new file mode 100644
index 000000000000..9462fe092c95
--- /dev/null
+++ b/app-admin/rmake/rmake-1.0.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2006-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/rmake/rmake-1.0.3.ebuild,v 1.1 2007/01/10 19:43:52 smithj Exp $
+
+inherit eutils
+
+DESCRIPTION="repository-based build system"
+HOMEPAGE="http://wiki.rpath.com/wiki/Conary:About_rMake"
+SRC_URI="ftp://download.rpath.com/${PN}/${P}.tar.bz2"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=dev-lang/python-2.4*
+ sys-libs/libcap
+ app-admin/conary"
+
+src_compile() {
+ emake || die "Make failure"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ chmod 04755 ${D}/usr/libexec/rmake/chroothelper
+ for x in ${D}/var/{rmake,{log,lib,run}/rmake} ${D}/{etc,srv}/rmake;do
+ mkdir -p $x
+ chown rmake:rmake $x
+ touch ${x}/.keep
+ done
+ chmod 700 ${D}/var/rmake
+ # replace with updstream-provided in next release... see
+ # https://issues.rpath.com/browse/RMK-242
+ doinitd ${FILESDIR}/rmake
+}
+
+pkg_setup() {
+ enewgroup rmake
+ enewgroup rmake-chroot
+ enewuser rmake -1 -1 /srv/rmake "rmake"
+ enewuser rmake-chroot -1 -1 / "rmake-chroot"
+}