summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-07-29 09:47:21 +0000
committerTravis Tilley <lv@gentoo.org>2004-07-29 09:47:21 +0000
commit9344986fd0d8958f5659bc70a1db853ca0e8e474 (patch)
tree0e6370b5af735adf26a3f2cfc974c3d3d261617e /app-admin
parentBump to -r2. Fixed overflow issue in Bug #57962. (diff)
downloadhistorical-9344986fd0d8958f5659bc70a1db853ca0e8e474.tar.gz
historical-9344986fd0d8958f5659bc70a1db853ca0e8e474.tar.bz2
historical-9344986fd0d8958f5659bc70a1db853ca0e8e474.zip
added very preliminary support for non-x86 archs and added ~amd64 keyword
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/paxtest/ChangeLog5
-rw-r--r--app-admin/paxtest/Manifest14
-rw-r--r--app-admin/paxtest/paxtest-0.9.5-r1.ebuild15
3 files changed, 19 insertions, 15 deletions
diff --git a/app-admin/paxtest/ChangeLog b/app-admin/paxtest/ChangeLog
index 84791f94b3b3..826d6d714e6a 100644
--- a/app-admin/paxtest/ChangeLog
+++ b/app-admin/paxtest/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-admin/paxtest
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/ChangeLog,v 1.11 2004/06/24 21:33:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/ChangeLog,v 1.12 2004/07/29 09:47:21 lv Exp $
+
+ 29 Jul 2004; Travis Tilley <lv@gentoo.org> paxtest-0.9.5-r1.ebuild:
+ added very preliminary support for non-x86 archs and added ~amd64 keyword
07 May 2004; Brandon Hale <tseng@gentoo.org> paxtest-0.9.5-r1.ebuild:
Added IUSE=
diff --git a/app-admin/paxtest/Manifest b/app-admin/paxtest/Manifest
index bc8d160b4b0d..59ba258bd208 100644
--- a/app-admin/paxtest/Manifest
+++ b/app-admin/paxtest/Manifest
@@ -1,15 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 e8f3609eea352905424f9fc3c14a3af0 ChangeLog 1753
+MD5 1be6b9869e1c6f39692f6b35284cd949 ChangeLog 1894
MD5 9c3ac1379620120fbd744ce753b30ab5 metadata.xml 1075
-MD5 d08382ada696b3f08fb29e724d84422e paxtest-0.9.5-r1.ebuild 934
+MD5 50b704fafee0bee0c95f8d1568f32ec1 paxtest-0.9.5-r1.ebuild 1355
MD5 d2c0f3f930cc073ecca57b22266fc4af files/digest-paxtest-0.9.5-r1 64
MD5 424438ef95656aae91eb2f6c53c663d9 files/paxtest-0.9.5.1.diff 2369
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.8 (GNU/Linux)
-
-iD8DBQFA3HzkHTu7gpaalycRAob0AKC/uMoWl7Zxih8RUMOen7ByxRS7KgCfc+jd
-jdqeljWFt5Pe64K/VDo6AqE=
-=vV1/
------END PGP SIGNATURE-----
diff --git a/app-admin/paxtest/paxtest-0.9.5-r1.ebuild b/app-admin/paxtest/paxtest-0.9.5-r1.ebuild
index 6cee39815eb2..b2d5a23fd226 100644
--- a/app-admin/paxtest/paxtest-0.9.5-r1.ebuild
+++ b/app-admin/paxtest/paxtest-0.9.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.5-r1.ebuild,v 1.7 2004/06/25 19:28:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.5-r1.ebuild,v 1.8 2004/07/29 09:47:21 lv Exp $
inherit eutils
@@ -14,7 +14,7 @@ SRC_URI="http://pageexec.virtualave.net/paxtest-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ~amd64"
IUSE=""
DEPEND="virtual/libc
@@ -26,6 +26,10 @@ src_unpack() {
epatch ${FILESDIR}/paxtest-0.9.5.1.diff
cp Makefile{,.orig}
cp Makefile{.Gentoo-hardened,}
+
+ # paxtest includes crt1S.S, which is great if you're on x86, but not so
+ # much if you're not... lets use the system Scrt1.o
+ use !x86 && cp ${ROOT}/usr/lib/Scrt1.o ${S}/crt1S.o
}
src_compile() {
@@ -38,3 +42,10 @@ src_install() {
[ -f "${doc}" ] && dodoc ${doc}
done
}
+
+pkg_postinst() {
+ use !x86 && (
+ ewarn "WARNING: support for non-x86 archs is currently a hack."
+ ewarn "since you're not on x86, you may get \"Accessing a corrupted shared library\""
+ ewarn "during the getmain2 and getheap2 tests." )
+}