summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 02:42:21 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 02:42:21 +0000
commita2d172870650a6294e58e8f87806a3a4cd09796f (patch)
tree6d8a472b06132a831e6c21ea8647b36034106833 /app-admin
parent2.11y release... Mostly cleanups. (diff)
downloadhistorical-a2d172870650a6294e58e8f87806a3a4cd09796f.tar.gz
historical-a2d172870650a6294e58e8f87806a3a4cd09796f.tar.bz2
historical-a2d172870650a6294e58e8f87806a3a4cd09796f.zip
Changed src_install () to src_install()
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/gkrellm/gkrellm-2.1.0.ebuild12
-rw-r--r--app-admin/grubconfig/grubconfig-1.16.ebuild13
-rw-r--r--app-admin/hddtemp/hddtemp-0.2.ebuild16
-rw-r--r--app-admin/ide-smart/ide-smart-1.4.ebuild8
-rw-r--r--app-admin/makepasswd/makepasswd-1.10.ebuild8
-rw-r--r--app-admin/mon/mon-0.38.20-r7.ebuild12
-rw-r--r--app-admin/newsyslog/newsyslog-1.0.103.ebuild16
-rw-r--r--app-admin/petrovich/petrovich-1.0.0.ebuild6
-rw-r--r--app-admin/puregui/puregui-1-r1.ebuild13
-rw-r--r--app-admin/qtsvc/qtsvc-0.1-r1.ebuild10
-rw-r--r--app-admin/quickswitch/quickswitch-0.10.ebuild5
-rw-r--r--app-admin/quickswitch/quickswitch-1.0_pre1.ebuild12
-rw-r--r--app-admin/superadduser/superadduser-1.0-r2.ebuild6
-rw-r--r--app-admin/sysstat/sysstat-3.3.6-r1.ebuild9
-rw-r--r--app-admin/va-systemimager-client/va-systemimager-client-1.4.0.ebuild7
-rw-r--r--app-admin/va-systemimager-server/va-systemimager-server-1.4.0.ebuild6
-rw-r--r--app-admin/watchdog/watchdog-5.2.ebuild16
17 files changed, 58 insertions, 117 deletions
diff --git a/app-admin/gkrellm/gkrellm-2.1.0.ebuild b/app-admin/gkrellm/gkrellm-2.1.0.ebuild
index 7e154bdb4133..b08f315c3c7c 100644
--- a/app-admin/gkrellm/gkrellm-2.1.0.ebuild
+++ b/app-admin/gkrellm/gkrellm-2.1.0.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gkrellm/gkrellm-2.1.0.ebuild,v 1.3 2002/11/14 23:08:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gkrellm/gkrellm-2.1.0.ebuild,v 1.4 2002/11/30 02:23:51 vapier Exp $
-IUSE="gtk nls"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Single process stack of various system monitors"
SRC_URI="http://web.wt.net/~billw/${PN}/${P}.tar.bz2"
HOMEPAGE="http://www.gkrellm.net/"
@@ -12,9 +9,9 @@ HOMEPAGE="http://www.gkrellm.net/"
SLOT="2"
LICENSE="GPL-2"
KEYWORDS="x86 ppc ~alpha ~sparc ~sparc64"
+IUSE="gtk nls"
DEPEND="gtk? >=x11-libs/gtk+-2.0.5 : =dev-libs/glib-1.2*"
-
RDEPEND="nls? ( sys-devel/gettext )"
src_compile() {
@@ -23,8 +20,7 @@ src_compile() {
sed -e "s:enable_nls=1:enable_nls=0:" Makefile.orig > Makefile
fi
- if use gtk
- then
+ if [ `use gtk` ] ; then
emake || die
else
cd ${S}/server
@@ -32,7 +28,7 @@ src_compile() {
fi
}
-src_install () {
+src_install() {
touch .keep
dodir /usr/{bin,include,share/man}
diff --git a/app-admin/grubconfig/grubconfig-1.16.ebuild b/app-admin/grubconfig/grubconfig-1.16.ebuild
index 0f853ea0814a..024fe229a761 100644
--- a/app-admin/grubconfig/grubconfig-1.16.ebuild
+++ b/app-admin/grubconfig/grubconfig-1.16.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/grubconfig/grubconfig-1.16.ebuild,v 1.1 2002/10/25 10:43:26 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/grubconfig/grubconfig-1.16.ebuild,v 1.2 2002/11/30 02:27:56 vapier Exp $
-DESCRIPTION="Simple Tool to configure Grub-Bootloader."
+DESCRIPTION="Simple Tool to configure Grub-Bootloader"
HOMEPAGE="http://www.tux.org/pub/people/kent-robotti/looplinux/index.html"
SRC_URI="http://www.tux.org/pub/people/kent-robotti/looplinux/${P}.tar.gz"
-DEPEND=">=dev-util/dialog-0.7"
+
KEYWORDS="~x86 -ppc -sparc -sparc64 -alpha"
LICENSE="GPL-2"
SLOT="0"
-src_install () {
- exeinto /usr/sbin
- doexe grubconfig
+DEPEND=">=dev-util/dialog-0.7"
+
+src_install() {
+ dosbin grubconfig
dodoc README
}
diff --git a/app-admin/hddtemp/hddtemp-0.2.ebuild b/app-admin/hddtemp/hddtemp-0.2.ebuild
index b4ed2b706fa5..8799d6203f3a 100644
--- a/app-admin/hddtemp/hddtemp-0.2.ebuild
+++ b/app-admin/hddtemp/hddtemp-0.2.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.2.ebuild,v 1.8 2002/10/20 18:14:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.2.ebuild,v 1.9 2002/11/30 02:25:51 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="A simple utility, to read the temperature of SMART IDE hard drives."
SRC_URI="http://coredump.free.fr/linux/${P}.tar.gz"
HOMEPAGE="http://coredump.free.fr/linux/harddrive.html"
-IUSE=""
SLOT="0"
LICENSE="GPL-2"
@@ -31,20 +29,12 @@ src_unpack() {
}
src_compile() {
-
make || die
-
}
-src_install () {
-
- exeinto /usr/bin
- doexe hddtemp
- dodir /usr/share/hddtemp
+src_install() {
+ dobin hddtemp
insinto /usr/share/hddtemp
doins hddtemp.db
-
- #docs
dodoc README COPYING
-
}
diff --git a/app-admin/ide-smart/ide-smart-1.4.ebuild b/app-admin/ide-smart/ide-smart-1.4.ebuild
index fb979322856d..9896c237f0cd 100644
--- a/app-admin/ide-smart/ide-smart-1.4.ebuild
+++ b/app-admin/ide-smart/ide-smart-1.4.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ide-smart/ide-smart-1.4.ebuild,v 1.11 2002/10/20 18:14:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ide-smart/ide-smart-1.4.ebuild,v 1.12 2002/11/30 02:26:43 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="A tool to read SMART (or S.M.A.R.T) information from harddiscs."
SRC_URI="http://lightside.eresmas.com/${P}.tar.gz"
HOMEPAGE="http://lightside.eresmas.com/"
-IUSE=""
SLOT="0"
LICENSE="GPL-2"
@@ -24,12 +22,10 @@ src_unpack() {
}
src_compile() {
-
emake || die
}
-src_install () {
-
+src_install() {
dobin ide-smart
doman ide-smart.8
dodoc README COPYING
diff --git a/app-admin/makepasswd/makepasswd-1.10.ebuild b/app-admin/makepasswd/makepasswd-1.10.ebuild
index 08768c2c6cce..ce5b15a243d0 100644
--- a/app-admin/makepasswd/makepasswd-1.10.ebuild
+++ b/app-admin/makepasswd/makepasswd-1.10.ebuild
@@ -1,22 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/makepasswd/makepasswd-1.10.ebuild,v 1.6 2002/10/18 13:31:45 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/makepasswd/makepasswd-1.10.ebuild,v 1.7 2002/11/30 02:28:35 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Random password generator"
SRC_URI="http://ftp.debian.org/debian/dists/stable/main/source/admin/${PN}_${PV}.orig.tar.gz"
HOMEPAGE="http://packages.debian.org/stable/admin/makepasswd.html"
-IUSE=""
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
-DEPEND="${RDEPEND}"
RDEPEND="sys-devel/perl"
-src_install () {
- into /usr
+src_install() {
dobin makepasswd
doman makepasswd.1
dodoc README CHANGES COPYING-2.0
diff --git a/app-admin/mon/mon-0.38.20-r7.ebuild b/app-admin/mon/mon-0.38.20-r7.ebuild
index 9b9447b5fc68..59fffdbb9cef 100644
--- a/app-admin/mon/mon-0.38.20-r7.ebuild
+++ b/app-admin/mon/mon-0.38.20-r7.ebuild
@@ -1,31 +1,27 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mon/mon-0.38.20-r7.ebuild,v 1.6 2002/10/18 13:31:45 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mon/mon-0.38.20-r7.ebuild,v 1.7 2002/11/30 02:29:25 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="mon is a highly configurable service monitoring daemon"
SRC_URI="ftp://ftp.kernel.org/pub/software/admin/mon/${P}.tar.bz2"
HOMEPAGE="http://www.kernel.org/software/mon/"
-IUSE=""
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
+IUSE=""
DEPEND=">=dev-perl/Mon-0.9
>=dev-perl/Time-HiRes-01.20
>=dev-perl/Period-1.20-r2"
src_compile() {
-
cd ${S}/mon.d
make CC="gcc $CFLAGS" || die
}
-src_install () {
-
- exeinto /usr/sbin
- doexe mon clients/mon*
+src_install() {
+ dosbin mon clients/mon*
insinto /usr/lib/mon/utils
doins utils/*
diff --git a/app-admin/newsyslog/newsyslog-1.0.103.ebuild b/app-admin/newsyslog/newsyslog-1.0.103.ebuild
index 05b1eeea221b..de548ef90369 100644
--- a/app-admin/newsyslog/newsyslog-1.0.103.ebuild
+++ b/app-admin/newsyslog/newsyslog-1.0.103.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/newsyslog/newsyslog-1.0.103.ebuild,v 1.1 2002/10/25 04:40:06 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/newsyslog/newsyslog-1.0.103.ebuild,v 1.2 2002/11/30 02:42:21 vapier Exp $
DESCRIPTION="An enhanced version of newsyslog originally written by Theodore Ts'o"
-
HOMEPAGE="http://www.weird.com/~woods/projects/newsyslog.html"
SRC_URI="ftp://ftp.weird.com/pub/local/newsyslog.tar.gz"
@@ -15,12 +14,8 @@ DEPEND="sys-apps/groff"
RDEPEND="virtual/cron
sys-apps/gzip"
-S="${WORKDIR}/${P}"
-
src_unpack() {
- unpack ${A}
- cd ${S}
-
+ unpack ${A} ; cd ${S}
patch -p1 < ${FILESDIR}/newsyslog-html.patch || die
}
@@ -33,17 +28,16 @@ src_compile() {
econf \
--with-gzip \
--with-newsyslog_conf=/etc/newsyslog.conf \
- ${myconf} || die
+ ${myconf}
emake || die
}
-src_install () {
+src_install() {
einstall catmandir=${D}/usr/share/man
-
+
rm -rf ${D}/usr/share/man/cat?
dodoc newsyslog.conf AUTHORS COPYING ChangeLog INSTALL NEWS README.* ToDo
prepalldocs
-
}
diff --git a/app-admin/petrovich/petrovich-1.0.0.ebuild b/app-admin/petrovich/petrovich-1.0.0.ebuild
index 4f56524db10c..d944ece3edae 100644
--- a/app-admin/petrovich/petrovich-1.0.0.ebuild
+++ b/app-admin/petrovich/petrovich-1.0.0.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/petrovich/petrovich-1.0.0.ebuild,v 1.11 2002/10/20 18:14:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/petrovich/petrovich-1.0.0.ebuild,v 1.12 2002/11/30 02:30:49 vapier Exp $
S=${WORKDIR}/${PN}
DESCRIPTION="Filesystem Integrity Checker"
SRC_URI="http://prdownloads.sf.net/petrovich/${P}.tar.gz"
HOMEPAGE="http://sourceforge.net/projects/petrovich"
-IUSE=""
SLOT="0"
LICENSE="GPL-2"
@@ -20,8 +19,7 @@ src_unpack () {
patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
}
-src_install () {
- into /usr
+src_install() {
dosbin petrovich.pl
insinto /etc
diff --git a/app-admin/puregui/puregui-1-r1.ebuild b/app-admin/puregui/puregui-1-r1.ebuild
index 3e356a873100..3b032d3e4635 100644
--- a/app-admin/puregui/puregui-1-r1.ebuild
+++ b/app-admin/puregui/puregui-1-r1.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puregui/puregui-1-r1.ebuild,v 1.10 2002/10/18 13:31:45 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puregui/puregui-1-r1.ebuild,v 1.11 2002/11/30 02:33:10 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="A GUI to Configure Pure-FTPD"
SRC_URI="mirror://sourceforge/pureftpd/${PN}.tar.gz"
HOMEPAGE="http://pureftpd.sourceforge.net"
-IUSE=""
SLOT="0"
LICENSE="GPL-2"
@@ -15,16 +13,11 @@ KEYWORDS="x86 sparc sparc64"
DEPEND="=x11-libs/gtk+-1.2*"
src_compile() {
-
- econf \
- --cache-file=${FILESDIR}/config.cache || die
+ econf --cache-file=${FILESDIR}/config.cache
make || die
-
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die
dodoc COPYING ChangeLog README
-
}
diff --git a/app-admin/qtsvc/qtsvc-0.1-r1.ebuild b/app-admin/qtsvc/qtsvc-0.1-r1.ebuild
index ae33c2397afb..b1f9fcdfac80 100644
--- a/app-admin/qtsvc/qtsvc-0.1-r1.ebuild
+++ b/app-admin/qtsvc/qtsvc-0.1-r1.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/qtsvc/qtsvc-0.1-r1.ebuild,v 1.12 2002/10/04 03:45:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/qtsvc/qtsvc-0.1-r1.ebuild,v 1.13 2002/11/30 02:33:37 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="A QT frontend for svc"
SRC_URI="http://www.together.net/~plomp/${P}.tar.gz"
HOMEPAGE="http://www.together.net/~plomp/qtsvc.html"
@@ -16,8 +15,7 @@ RDEPEND="${DEPEND}
>=sys-apps/daemontools-0.70"
src_unpack() {
- unpack ${A}
- cd ${S}
+ unpack ${A} ; cd ${S}
patch -p0 < ${FILESDIR}/qtsvc-0.1.diff || die
}
@@ -27,9 +25,7 @@ src_compile() {
make || die
}
-src_install () {
- into /usr
+src_install() {
dobin qtsvc/qtsvc
dodoc README qtsvc/MANUAL qtsvc/LICENSE qtsvc/PROGRAMMING
-
}
diff --git a/app-admin/quickswitch/quickswitch-0.10.ebuild b/app-admin/quickswitch/quickswitch-0.10.ebuild
index 6abffd98706a..5c4ebc04aef6 100644
--- a/app-admin/quickswitch/quickswitch-0.10.ebuild
+++ b/app-admin/quickswitch/quickswitch-0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/quickswitch/quickswitch-0.10.ebuild,v 1.9 2002/10/04 03:45:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/quickswitch/quickswitch-0.10.ebuild,v 1.10 2002/11/30 02:33:59 vapier Exp $
S=${WORKDIR}/${PN}
DESCRIPTION="Utility to switch network profiles on the fly"
@@ -13,8 +13,7 @@ KEYWORDS="x86 sparc sparc64"
DEPEND="sys-devel/perl"
-
-src_install () {
+src_install() {
dobin switchto
dosed "s:/etc/switch.conf:/etc/quickswitch/switch.conf:" /usr/bin/switchto
dosed "s:/etc/switchto.last:/etc/quickswitch/switchto.last:" /usr/bin/switchto
diff --git a/app-admin/quickswitch/quickswitch-1.0_pre1.ebuild b/app-admin/quickswitch/quickswitch-1.0_pre1.ebuild
index c7622308fea1..b7e9b07f32b7 100644
--- a/app-admin/quickswitch/quickswitch-1.0_pre1.ebuild
+++ b/app-admin/quickswitch/quickswitch-1.0_pre1.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/quickswitch/quickswitch-1.0_pre1.ebuild,v 1.8 2002/10/20 18:14:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/quickswitch/quickswitch-1.0_pre1.ebuild,v 1.9 2002/11/30 02:35:13 vapier Exp $
-S=${WORKDIR}/quickwitch
+MY_PN="quickwitch"
+MY_P="${MY_PN}-${PV/_/}"
+S=${WORKDIR}/${MY_PN}
DESCRIPTION="Utility to switch network profiles on the fly"
-SRC_URI="mirror://sourceforge/quickswitch/quickwitch-1.0pre1.tar.gz"
+SRC_URI="mirror://sourceforge/quickswitch/${MY_P}.tar.gz"
HOMEPAGE="http://edgesolutions.ca/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
-
DEPEND=">=sys-devel/perl-5.6.0"
-src_install () {
- cd ${S}
+src_install() {
dobin switchto
dobin switcher
dosed "s:/etc/switchto.conf:/etc/quickswitch/switchto.conf:" /usr/bin/switchto
diff --git a/app-admin/superadduser/superadduser-1.0-r2.ebuild b/app-admin/superadduser/superadduser-1.0-r2.ebuild
index 5d075fb4d4db..5c2debffa67b 100644
--- a/app-admin/superadduser/superadduser-1.0-r2.ebuild
+++ b/app-admin/superadduser/superadduser-1.0-r2.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/superadduser/superadduser-1.0-r2.ebuild,v 1.3 2002/10/04 03:45:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/superadduser/superadduser-1.0-r2.ebuild,v 1.4 2002/11/30 02:35:39 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Interactive adduser script"
SRC_URI=""
HOMEPAGE="http://www.gentoo.org/"
@@ -13,8 +12,7 @@ KEYWORDS="x86 ppc sparc sparc64"
RDEPEND="sys-apps/shadow"
-
-src_install () {
+src_install() {
dosbin ${FILESDIR}/${PV}/superadduser
doman ${FILESDIR}/${PV}/superadduser.8
}
diff --git a/app-admin/sysstat/sysstat-3.3.6-r1.ebuild b/app-admin/sysstat/sysstat-3.3.6-r1.ebuild
index c9d89fdee6cd..677e9771dc41 100644
--- a/app-admin/sysstat/sysstat-3.3.6-r1.ebuild
+++ b/app-admin/sysstat/sysstat-3.3.6-r1.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/sysstat-3.3.6-r1.ebuild,v 1.9 2002/10/05 05:39:05 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/sysstat-3.3.6-r1.ebuild,v 1.10 2002/11/30 02:36:12 vapier Exp $
-IUSE="nls"
-
-S=${WORKDIR}/${P}
DESCRIPTION="System performance tools for Linux"
SRC_URI="http://www.ibiblio.org/pub/Linux/system/status/${P}.tar.gz"
HOMEPAGE="http://perso.wanadoo.fr/sebastien.godard/"
@@ -12,6 +9,7 @@ HOMEPAGE="http://perso.wanadoo.fr/sebastien.godard/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
+IUSE="nls"
DEPEND="virtual/glibc"
RDEPEND="nls? ( sys-devel/gettext )"
@@ -28,10 +26,9 @@ src_compile() {
cp build/CONFIG build/CONFIG.orig
use nls || sed 's/\(ENABLE_NLS\ =\ \)y/\1n/g' build/CONFIG.orig > build/CONFIG
make PREFIX=/usr || die
-
}
-src_install () {
+src_install() {
dodir /usr/bin
dodir /usr/share/man/man{1,8}
dodir /var/log/sa
diff --git a/app-admin/va-systemimager-client/va-systemimager-client-1.4.0.ebuild b/app-admin/va-systemimager-client/va-systemimager-client-1.4.0.ebuild
index 266710a9c128..1760b8485615 100644
--- a/app-admin/va-systemimager-client/va-systemimager-client-1.4.0.ebuild
+++ b/app-admin/va-systemimager-client/va-systemimager-client-1.4.0.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/va-systemimager-client/va-systemimager-client-1.4.0.ebuild,v 1.9 2002/10/18 20:46:41 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/va-systemimager-client/va-systemimager-client-1.4.0.ebuild,v 1.10 2002/11/30 02:36:58 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="VA SystemImager software automates the installation of Linux to masses of similar machines."
SRC_URI="mirror://sourceforge/systemimager/${P}.tar.bz2"
-HOMEPAGE="http://systemimager.org"
+HOMEPAGE="http://systemimager.org/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
-src_install () {
+src_install() {
DESTDIR=${D} ./installclient --quiet || die
}
diff --git a/app-admin/va-systemimager-server/va-systemimager-server-1.4.0.ebuild b/app-admin/va-systemimager-server/va-systemimager-server-1.4.0.ebuild
index f63abd423821..4959e2d5d900 100644
--- a/app-admin/va-systemimager-server/va-systemimager-server-1.4.0.ebuild
+++ b/app-admin/va-systemimager-server/va-systemimager-server-1.4.0.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/va-systemimager-server/va-systemimager-server-1.4.0.ebuild,v 1.9 2002/10/18 20:46:41 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/va-systemimager-server/va-systemimager-server-1.4.0.ebuild,v 1.10 2002/11/30 02:38:50 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="VA SystemImager software automates the installation of Linux to masses of similar machines."
SRC_URI="mirror://sourceforge/systemimager/${P}.tar.bz2"
HOMEPAGE="http://systemimager.org"
@@ -11,8 +10,7 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
-src_install () {
-
+src_install() {
DESTDIR=${D} ./install --no-afterburner --quiet || die
insinto /etc/rsync
newins ${FILESDIR}/${P}-rsyncd.conf rsyncd.conf
diff --git a/app-admin/watchdog/watchdog-5.2.ebuild b/app-admin/watchdog/watchdog-5.2.ebuild
index 6db3cbaec830..ed940e059d2c 100644
--- a/app-admin/watchdog/watchdog-5.2.ebuild
+++ b/app-admin/watchdog/watchdog-5.2.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.ebuild,v 1.10 2002/10/29 16:48:49 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.ebuild,v 1.11 2002/11/30 02:40:39 vapier Exp $
-S="${WORKDIR}/${P}"
DESCRIPTION="A software watchdog."
HOMEPAGE="http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/"
SRC_URI="http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/${P}.tar.gz"
@@ -13,24 +12,19 @@ KEYWORDS="x86 -ppc"
DEPEND="virtual/glibc"
src_unpack() {
-
- unpack ${A}
- cd ${S}
+ unpack ${A} ; cd ${S}
patch -p1 < ${FILESDIR}/sundries.diff || die "patch failed"
-
}
src_compile() {
# Two configure switches have been added to use /etc/watchdog
econf \
--sysconfdir=/etc/watchdog \
- --with-configfile=/etc/watchdog/watchdog.conf \
- || die "./configure failed"
-
+ --with-configfile=/etc/watchdog/watchdog.conf
emake || die
}
-src_install () {
+src_install() {
dodir /etc/watchdog
make DESTDIR="${D}" install || die
@@ -38,7 +32,7 @@ src_install () {
doexe "${FILESDIR}/${PVR}/watchdog"
}
-pkg_postinst () {
+pkg_postinst() {
einfo
einfo "To enable the start-up script run \"rc-update add watchdog boot\"."
einfo