summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-05 21:25:15 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-05 21:25:15 +0000
commitb2194565227ec0c5bb01fdccc7ae6b2efd1b2c14 (patch)
treed64064b74b14e0ee16c798dd1165126051726a1c /app-admin
parentA multi-sourced configuration back-end (diff)
downloadhistorical-b2194565227ec0c5bb01fdccc7ae6b2efd1b2c14.tar.gz
historical-b2194565227ec0c5bb01fdccc7ae6b2efd1b2c14.tar.bz2
historical-b2194565227ec0c5bb01fdccc7ae6b2efd1b2c14.zip
Apache configuration tool
Package-Manager: portage-2.1.1_rc1-r1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/system-config-httpd/ChangeLog11
-rw-r--r--app-admin/system-config-httpd/files/1.3.3-gentooify.patch79
-rw-r--r--app-admin/system-config-httpd/files/digest-system-config-httpd-1.3.33
-rw-r--r--app-admin/system-config-httpd/metadata.xml9
-rw-r--r--app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild49
-rw-r--r--app-admin/system-config-lvm/Manifest20
-rw-r--r--app-admin/system-config-nfs/Manifest20
7 files changed, 191 insertions, 0 deletions
diff --git a/app-admin/system-config-httpd/ChangeLog b/app-admin/system-config-httpd/ChangeLog
new file mode 100644
index 000000000000..8d710ed7c2b1
--- /dev/null
+++ b/app-admin/system-config-httpd/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-admin/system-config-httpd
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-httpd/ChangeLog,v 1.1 2006/09/05 21:25:15 dberkholz Exp $
+
+*system-config-httpd-1.3.3 (05 Sep 2006)
+
+ 05 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/1.3.3-gentooify.patch, +metadata.xml,
+ +system-config-httpd-1.3.3.ebuild:
+ Apache configuration tool
+
diff --git a/app-admin/system-config-httpd/files/1.3.3-gentooify.patch b/app-admin/system-config-httpd/files/1.3.3-gentooify.patch
new file mode 100644
index 000000000000..8e0e2eb89e9e
--- /dev/null
+++ b/app-admin/system-config-httpd/files/1.3.3-gentooify.patch
@@ -0,0 +1,79 @@
+diff -urN system-config-httpd-1.3.3.orig/src/ApacheBase.py system-config-httpd-1.3.3/src/ApacheBase.py
+--- system-config-httpd-1.3.3.orig/src/ApacheBase.py 2006-09-04 11:57:25.000000000 -0700
++++ system-config-httpd-1.3.3/src/ApacheBase.py 2006-09-04 12:01:10.000000000 -0700
+@@ -4349,7 +4349,7 @@
+
+ # Compute md5sum of currently installed httpd.conf
+ try:
+- rmd5 = hexstr (md5 (open ('/etc/httpd/conf/httpd.conf', 'r').read ()).digest())
++ rmd5 = hexstr (md5 (open ('/etc/apache2/httpd.conf', 'r').read ()).digest())
+ except:
+ rmd5 = ''
+
+@@ -4361,14 +4361,14 @@
+ if omd5 != rmd5:
+ if force:
+ try:
+- os.remove ('/etc/httpd/conf/httpd.conf.bak')
++ os.remove ('/etc/apache2/httpd.conf.bak')
+ except:
+ pass
+ try:
+- os.rename ('/etc/httpd/conf/httpd.conf', '/etc/httpd/conf/httpd.conf.bak')
++ os.rename ('/etc/apache2/httpd.conf', '/etc/apache2/httpd.conf.bak')
+ except:
+ pass
+- open ('/etc/httpd/conf/httpd.conf', 'w').write (result)
++ open ('/etc/apache2/httpd.conf', 'w').write (result)
+ open ('/usr/share/system-config-httpd/httpd.conf.md5', 'w').write (nmd5)
+ local_box.write (ctx)
+ return 0
+@@ -4377,7 +4377,7 @@
+ else:
+ return -2
+ else:
+- open ('/etc/httpd/conf/httpd.conf', 'w').write (result)
++ open ('/etc/apache2/httpd.conf', 'w').write (result)
+ open ('/usr/share/system-config-httpd/httpd.conf.md5', 'w').write (nmd5)
+ local_box.write (ctx)
+ return 0
+diff -urN system-config-httpd-1.3.3.orig/src/httpd.conf.xsl system-config-httpd-1.3.3/src/httpd.conf.xsl
+--- system-config-httpd-1.3.3.orig/src/httpd.conf.xsl 2006-09-04 11:57:25.000000000 -0700
++++ system-config-httpd-1.3.3/src/httpd.conf.xsl 2006-09-04 12:00:25.000000000 -0700
+@@ -29,8 +29,8 @@
+ # of the server's control files begin with "/" (or "drive:/" for Win32), the
+ # server will use that explicit path. If the filenames do *not* begin
+ # with "/", the value of ServerRoot is prepended -- so "logs/foo.log"
+-# with ServerRoot set to "/etc/httpd" will be interpreted by the
+-# server as "/etc/httpd/logs/foo.log".
++# with ServerRoot set to "/etc/apache2" will be interpreted by the
++# server as "/etc/apache2/logs/foo.log".
+ #
+
+ ### Section 1: Global Environment
+@@ -203,9 +203,14 @@
+ LoadModule cgi_module modules/mod_cgi.so
+
+ #
+-# Load config files from the config directory "/etc/httpd/conf.d".
++# Load config files from the config directory "/etc/apache2/modules.d".
+ #
+-Include conf.d/*.conf
++Include modules.d/*.conf
++
++#
++# Load config files from the config directory "/etc/apache2/vhosts.d".
++#
++Include vhosts.d/*.conf
+
+ #
+ # ExtendedStatus controls whether Apache will generate "full" status
+@@ -865,7 +870,7 @@
+ # To enable the cache as well, edit and uncomment the following lines:
+ # (no cacheing without CacheRoot)
+ #
+-#CacheRoot "/etc/httpd/proxy"
++#CacheRoot "/etc/apache2/proxy"
+ #CacheSize 5
+ #CacheGcInterval 4
+ #CacheMaxExpire 24
diff --git a/app-admin/system-config-httpd/files/digest-system-config-httpd-1.3.3 b/app-admin/system-config-httpd/files/digest-system-config-httpd-1.3.3
new file mode 100644
index 000000000000..ec82282320f6
--- /dev/null
+++ b/app-admin/system-config-httpd/files/digest-system-config-httpd-1.3.3
@@ -0,0 +1,3 @@
+MD5 3cfcd670ba650ed5781e03d0f7ba130c system-config-httpd-1.3.3-1.1.1.src.rpm 833094
+RMD160 2a96e737d3b1b8ef9128ca149edd46fb60ae3b30 system-config-httpd-1.3.3-1.1.1.src.rpm 833094
+SHA256 e52343a1290fd39b0b55fd58ab6961c998104e3423de72e7b2574eb84907d942 system-config-httpd-1.3.3-1.1.1.src.rpm 833094
diff --git a/app-admin/system-config-httpd/metadata.xml b/app-admin/system-config-httpd/metadata.xml
new file mode 100644
index 000000000000..cd89a979878d
--- /dev/null
+++ b/app-admin/system-config-httpd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>dberkholz@gentoo.org</email>
+<name>Donnie Berkholz</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild b/app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild
new file mode 100644
index 000000000000..7ca9bfc2bdaa
--- /dev/null
+++ b/app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild,v 1.1 2006/09/05 21:25:15 dberkholz Exp $
+
+inherit eutils rpm
+
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1.1.1"
+
+DESCRIPTION="Apache configuration tool"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="dev-libs/alchemist
+ =dev-python/pygtk-2*
+ dev-lang/python
+ =dev-python/gnome-python-2*
+ >=net-www/apache-2.0.52-r3
+ sys-apps/usermode
+ dev-libs/libxslt"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool"
+
+pkg_setup() {
+ if ! built_with_use dev-libs/libxslt python; then
+ local msg="Build dev-libs/libxslt with USE=python"
+ eerror "$msg"
+ die "$msg"
+ fi
+}
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gentooify.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ make_desktop_entry /usr/bin/${PN}
+
+ fperms 644 /etc/pam.d/${PN}
+}
diff --git a/app-admin/system-config-lvm/Manifest b/app-admin/system-config-lvm/Manifest
new file mode 100644
index 000000000000..03397952803a
--- /dev/null
+++ b/app-admin/system-config-lvm/Manifest
@@ -0,0 +1,20 @@
+AUX 1.0.18-use-portable-pam.patch 679 RMD160 3de1444198fce2cf9f031f0645f1ee628e858130 SHA1 ed104998cd949439a39be27c0fdfc0db51b277bf SHA256 fd6593975fa70ed455302f7e43539bce2e8e0854a427574d99ae578709ca7107
+MD5 cebfda9a5bd4bb68d494d4e9f676b831 files/1.0.18-use-portable-pam.patch 679
+RMD160 3de1444198fce2cf9f031f0645f1ee628e858130 files/1.0.18-use-portable-pam.patch 679
+SHA256 fd6593975fa70ed455302f7e43539bce2e8e0854a427574d99ae578709ca7107 files/1.0.18-use-portable-pam.patch 679
+DIST system-config-lvm-1.0.18-1.2.FC6.src.rpm 1022939 RMD160 85d1539f7a0d0949aed6c5d54e98eaa598bd1193 SHA1 f4e6556ef0f2395f8718a45eacff326e96189dc6 SHA256 90b6b5ad181cdb53f48660ad6351e537ccdcac5f981a1b4be1a42ba13a5f4eb9
+EBUILD system-config-lvm-1.0.18.ebuild 1136 RMD160 3405f5a806cb4a1685402f51d8bbd6c656929b55 SHA1 052163f3a01f82486e2c0ad51e3cf4322851382b SHA256 7ab429e2be14a9fa328b34b4a043a87eff668938f96eb72833b363ef25964184
+MD5 771f8a6f78c466420a149c3e723e88d5 system-config-lvm-1.0.18.ebuild 1136
+RMD160 3405f5a806cb4a1685402f51d8bbd6c656929b55 system-config-lvm-1.0.18.ebuild 1136
+SHA256 7ab429e2be14a9fa328b34b4a043a87eff668938f96eb72833b363ef25964184 system-config-lvm-1.0.18.ebuild 1136
+MISC ChangeLog 474 RMD160 d7aeac456aaca719744e100a48a57527932b6332 SHA1 eafdc287e460098c3388b983fb0131c4c399ce26 SHA256 7e1fc9f0ad98781a7a040f70e2927f6d549d3ce3e1ee9bd03ab46651a2238bde
+MD5 a03f8e5cc41a3ae8302995b08e3ae4a2 ChangeLog 474
+RMD160 d7aeac456aaca719744e100a48a57527932b6332 ChangeLog 474
+SHA256 7e1fc9f0ad98781a7a040f70e2927f6d549d3ce3e1ee9bd03ab46651a2238bde ChangeLog 474
+MISC metadata.xml 252 RMD160 212f61f15769b523e0fa55ed5d872d85536b4043 SHA1 5f9d6137a829b96482aacd60baf98160b49dc514 SHA256 b3aaf1e941b12ded57dea3530d59b8db42716f5e805efb6338101c135beac506
+MD5 4f7fe0eacb3ba0ef618e04831e4a7517 metadata.xml 252
+RMD160 212f61f15769b523e0fa55ed5d872d85536b4043 metadata.xml 252
+SHA256 b3aaf1e941b12ded57dea3530d59b8db42716f5e805efb6338101c135beac506 metadata.xml 252
+MD5 64ef4333d06898e0749930a01397f5bb files/digest-system-config-lvm-1.0.18 304
+RMD160 d2ac7842f184407004eb816e5bc6a44361d588ca files/digest-system-config-lvm-1.0.18 304
+SHA256 eb238b8c475303f7e29f87a5d36fc72a36e12930f8b9b2451437abf9718ed938 files/digest-system-config-lvm-1.0.18 304
diff --git a/app-admin/system-config-nfs/Manifest b/app-admin/system-config-nfs/Manifest
new file mode 100644
index 000000000000..d423a1c0bf08
--- /dev/null
+++ b/app-admin/system-config-nfs/Manifest
@@ -0,0 +1,20 @@
+AUX 1.3.19-gentooify.patch 1430 RMD160 5a78adf559ba36f628e5e8fe8d9f988b211c5aba SHA1 cc0d8df512a6606f891b34bed2bcad0b1373de2a SHA256 ed43812b0faf06e3df0897635e3772f535498ae5afa2de40b59a852d5be71e9d
+MD5 fff294097948d78b0e8bda4cb0740b91 files/1.3.19-gentooify.patch 1430
+RMD160 5a78adf559ba36f628e5e8fe8d9f988b211c5aba files/1.3.19-gentooify.patch 1430
+SHA256 ed43812b0faf06e3df0897635e3772f535498ae5afa2de40b59a852d5be71e9d files/1.3.19-gentooify.patch 1430
+DIST system-config-nfs-1.3.19-1.1.src.rpm 133923 RMD160 1de98db3631a7ff89f82ecb8c09d401f4f418eeb SHA1 0f5975c4806a161bfd118c4cb6c2c19afbbde460 SHA256 380c9acff9c0b1410a606842ee8e2ccde78d4af1c9c0d58d4684d67b11dc82e2
+EBUILD system-config-nfs-1.3.19.ebuild 1075 RMD160 49eb3704b42add6805d575aea935c219088a5ab2 SHA1 32d3178106828c160c5dd8cf32291f0296f843bb SHA256 c8c50fe345874142ad3d1b2482b7cdb6746ed762e213863616954a6ed6460ff5
+MD5 29b14bd123d5ea011ed1a8953260ffc6 system-config-nfs-1.3.19.ebuild 1075
+RMD160 49eb3704b42add6805d575aea935c219088a5ab2 system-config-nfs-1.3.19.ebuild 1075
+SHA256 c8c50fe345874142ad3d1b2482b7cdb6746ed762e213863616954a6ed6460ff5 system-config-nfs-1.3.19.ebuild 1075
+MISC ChangeLog 443 RMD160 257b4ef4ff0cae7c9c99309ab95d16728a81e4fd SHA1 6467db4d2e2b4178a097cd87eeed8c0d966c43b8 SHA256 ae94704588d14d5431703a004e49458492bcde440535091c297d104e37f25bc4
+MD5 6588b1c635200edaa464f6552e6a8900 ChangeLog 443
+RMD160 257b4ef4ff0cae7c9c99309ab95d16728a81e4fd ChangeLog 443
+SHA256 ae94704588d14d5431703a004e49458492bcde440535091c297d104e37f25bc4 ChangeLog 443
+MISC metadata.xml 252 RMD160 212f61f15769b523e0fa55ed5d872d85536b4043 SHA1 5f9d6137a829b96482aacd60baf98160b49dc514 SHA256 b3aaf1e941b12ded57dea3530d59b8db42716f5e805efb6338101c135beac506
+MD5 4f7fe0eacb3ba0ef618e04831e4a7517 metadata.xml 252
+RMD160 212f61f15769b523e0fa55ed5d872d85536b4043 metadata.xml 252
+SHA256 b3aaf1e941b12ded57dea3530d59b8db42716f5e805efb6338101c135beac506 metadata.xml 252
+MD5 2d13cb3e6b25a09bc96a98fe7ca98c98 files/digest-system-config-nfs-1.3.19 289
+RMD160 c050d594780814467aae4bb662220ba5241772ff files/digest-system-config-nfs-1.3.19 289
+SHA256 907ca3f5869ba703de7ddfa2fc2741fac9d644b87ec09aaca4bae43f986b092c files/digest-system-config-nfs-1.3.19 289