summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-11-01 06:55:04 +0000
committerDonny Davies <woodchip@gentoo.org>2001-11-01 06:55:04 +0000
commitd958367e0f264744afbb0474bfdb5fefe191e6be (patch)
treeb71c94efeaed0051d1d1061b704514b2ef349052 /app-arch
parentNo longer needed. (diff)
downloadhistorical-d958367e0f264744afbb0474bfdb5fefe191e6be.tar.gz
historical-d958367e0f264744afbb0474bfdb5fefe191e6be.tar.bz2
historical-d958367e0f264744afbb0474bfdb5fefe191e6be.zip
umm, fixed several errors: header was broken, A was being unnecessarily defined, DEPEND was empty!, try -> || die, spaces to tabs. not to be picky, but this ebuild was in really bad form..
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/cabextract/cabextract-0.5.ebuild20
1 files changed, 6 insertions, 14 deletions
diff --git a/app-arch/cabextract/cabextract-0.5.ebuild b/app-arch/cabextract/cabextract-0.5.ebuild
index 13e84bcebf49..e0aa116f9361 100644
--- a/app-arch/cabextract/cabextract-0.5.ebuild
+++ b/app-arch/cabextract/cabextract-0.5.ebuild
@@ -1,32 +1,24 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Joshua Pollak <pardsbane@offthehill.org>
-# /home/cvsroot/gentoo-x86/sys-apps/less/less-358-r2.ebuild,v 1.1 2001/02/07 15:51:27 achim Exp
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/cabextract-0.5.ebuild,v 1.2 2001/11/01 06:55:04 woodchip Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
-DESCRIPTION="Extracts files from Microsoft .cab files."
-SRC_URI="http://www.kyz.uklinux.net/downloads/${A}"
+DESCRIPTION="Extracts files from Microsoft .cab files"
+SRC_URI="http://www.kyz.uklinux.net/downloads/${P}.tar.gz"
HOMEPAGE="http://www.kyz.uklinux.net/cabextract.php3"
-DEPEND=""
+DEPEND="virtual/glibc"
src_compile() {
- try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
- try pmake
-
+ ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man || die
+ emake || die
}
src_install() {
dobin cabextract
-
doman cabextract.1
-
dodoc COPYING NEWS README TODO AUTHORS
}
-
-
-
-