summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-15 08:21:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-15 08:21:22 +0000
commit52ecfff891c9f2246ee562ef9131cffd93908005 (patch)
tree9a7f0b3e1febc5fa17ec0b494d8d383ee52d743e /app-benchmarks/tiobench
parentinitial commit (bug 32499) (diff)
downloadhistorical-52ecfff891c9f2246ee562ef9131cffd93908005.tar.gz
historical-52ecfff891c9f2246ee562ef9131cffd93908005.tar.bz2
historical-52ecfff891c9f2246ee562ef9131cffd93908005.zip
initial commit (bug 32499)
Diffstat (limited to 'app-benchmarks/tiobench')
-rw-r--r--app-benchmarks/tiobench/Manifest3
-rw-r--r--app-benchmarks/tiobench/files/digest-tiobench-0.3.31
-rw-r--r--app-benchmarks/tiobench/tiobench-0.3.3.ebuild36
3 files changed, 39 insertions, 1 deletions
diff --git a/app-benchmarks/tiobench/Manifest b/app-benchmarks/tiobench/Manifest
index abdec0112a0d..8a72c27d9d1f 100644
--- a/app-benchmarks/tiobench/Manifest
+++ b/app-benchmarks/tiobench/Manifest
@@ -1,2 +1,3 @@
-MD5 bba500c34eb45a472427c1c1a1728e91 tiobench-0.3.3.ebuild 818
+MD5 86935cd14cb8133010edb5dc61f26075 tiobench-0.3.3.ebuild 929
+MD5 99468eb7a341d3b2e526082ca9a728b0 ChangeLog 430
MD5 b0e08c271d30b5da41b55be795a8773e files/digest-tiobench-0.3.3 65
diff --git a/app-benchmarks/tiobench/files/digest-tiobench-0.3.3 b/app-benchmarks/tiobench/files/digest-tiobench-0.3.3
new file mode 100644
index 000000000000..20ba79163de5
--- /dev/null
+++ b/app-benchmarks/tiobench/files/digest-tiobench-0.3.3
@@ -0,0 +1 @@
+MD5 bf485bf820e693c79e6bd2a38702a128 tiobench-0.3.3.tar.gz 28282
diff --git a/app-benchmarks/tiobench/tiobench-0.3.3.ebuild b/app-benchmarks/tiobench/tiobench-0.3.3.ebuild
new file mode 100644
index 000000000000..e9ed62b58b57
--- /dev/null
+++ b/app-benchmarks/tiobench/tiobench-0.3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/tiobench/tiobench-0.3.3.ebuild,v 1.1 2003/11/15 08:21:20 mr_bones_ Exp $
+
+DESCRIPTION="Portable, robust, fully-threaded I/O benchmark program"
+HOMEPAGE="http://tiobench.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/glibc
+ dev-lang/perl"
+DEPEND=">=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e 's:/usr/local/bin:/usr/sbin:' tiobench.pl || \
+ die "sed tiobench.pl failed"
+ sed -i \
+ -e "/^CFLAGS/ s:=.*:= ${CFLAGS}:" Makefile || \
+ die "sed Makefile failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dosbin tiotest tiobench.pl tiosum.pl || die "dosbin failed"
+ dodoc BUGS ChangeLog README TODO || die "dodoc failed"
+}