summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-11-06 11:30:45 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-11-06 11:30:45 +0000
commite7c39ecf9cb0a29d6e2a0ba3196cfd94b426f4c0 (patch)
tree758066c56b2c6b6b4bf1cdcbbec0bc995a2f31ca /app-benchmarks
parentstable x86, bug #153892 (diff)
downloadhistorical-e7c39ecf9cb0a29d6e2a0ba3196cfd94b426f4c0.tar.gz
historical-e7c39ecf9cb0a29d6e2a0ba3196cfd94b426f4c0.tar.bz2
historical-e7c39ecf9cb0a29d6e2a0ba3196cfd94b426f4c0.zip
version bump/version cleanout
Package-Manager: portage-2.1.2_rc1-r2
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/iozone/ChangeLog8
-rw-r--r--app-benchmarks/iozone/files/digest-iozone-3.2673
-rw-r--r--app-benchmarks/iozone/iozone-3.267.ebuild79
3 files changed, 89 insertions, 1 deletions
diff --git a/app-benchmarks/iozone/ChangeLog b/app-benchmarks/iozone/ChangeLog
index 6e5934fd82c7..826e662df876 100644
--- a/app-benchmarks/iozone/ChangeLog
+++ b/app-benchmarks/iozone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-benchmarks/iozone
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/ChangeLog,v 1.29 2006/07/11 14:32:43 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/ChangeLog,v 1.30 2006/11/06 11:30:45 dragonheart Exp $
+
+*iozone-3.267 (06 Nov 2006)
+
+ 06 Nov 2006; Daniel Black <dragonheart@gentoo.org> -iozone-3.247.ebuild,
+ -iozone-3.248.ebuild, -iozone-3.254.ebuild, +iozone-3.267.ebuild:
+ version bump/version cleanout
*iozone-3.263 (11 Jul 2006)
diff --git a/app-benchmarks/iozone/files/digest-iozone-3.267 b/app-benchmarks/iozone/files/digest-iozone-3.267
new file mode 100644
index 000000000000..cfdabccd9d44
--- /dev/null
+++ b/app-benchmarks/iozone/files/digest-iozone-3.267
@@ -0,0 +1,3 @@
+MD5 14e3dabaec0cb3f8d50d9478dcea33a6 iozone3_267.tar 1505280
+RMD160 375991f30846a115360dcd2db9f446414a7cbb78 iozone3_267.tar 1505280
+SHA256 55299ffb3411250e16d9b5da71c6041ed8cf8e56f87189870ad1f905ab6594c3 iozone3_267.tar 1505280
diff --git a/app-benchmarks/iozone/iozone-3.267.ebuild b/app-benchmarks/iozone/iozone-3.267.ebuild
new file mode 100644
index 000000000000..e9e133c23836
--- /dev/null
+++ b/app-benchmarks/iozone/iozone-3.267.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/iozone-3.267.ebuild,v 1.1 2006/11/06 11:30:45 dragonheart Exp $
+
+# TODO
+# -> linux-arm (32bit) <-
+# -> linux-AMD64 (64bit) <-
+# -> linux-ia64 (64bit) <-
+# -> linux-powerpc (32bit) <-
+# -> linux-powerpc64 (64bit) <-
+# -> linux-S390 (32bit) <-
+# -> linux-S390X (64bit) <-
+#
+# -> freebsd (32bit) <-
+# -> macosx (32bit) <-
+# -> netbsd (32bit) <-
+# -> openbsd (32bit) <-
+# -> openbsd-threads (32bit) <-
+#
+# ~ia64 ~s390 alpha(?) x86-fbsd
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Filesystem benchmarking program"
+HOMEPAGE="http://www.iozone.org/"
+SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-devel/gcc
+ >=sys-apps/sed-4
+ virtual/libc"
+RDEPEND="virtual/libc"
+
+S=${WORKDIR}/${PN}${PV/./_}
+
+src_compile() {
+ cd src/current
+
+ # Options FIX
+ sed -i -e "s:CC =.*:CC =$(tc-getCC):g" \
+ -e "s:-O3:${CFLAGS}:g" makefile
+
+ case ${ARCH} in
+ x86|alpha) PLATFORM="linux";;
+ arm) PLATFORM="linux-arm";;
+ ppc) PLATFORM="linux-powerpc";;
+ ppc64) PLATFORM="linux-powerpc64";;
+ amd64) PLATFORM="linux-AMD64";;
+ ia64) PLATFORM="linux-ia64";;
+ s390) PLATFORM="linux-S390";;
+ x86-fbsd) PLATFORM="freebsd";;
+ *) PLATFORM="linux-${ARCH}";;
+ esac
+
+ emake ${PLATFORM} || die "Compile failed"
+}
+
+src_install() {
+ dosbin src/current/iozone
+ dodoc docs/I*
+ dodoc docs/Run_rules.doc
+ dodoc src/current/Changes.txt
+ doman docs/iozone.1
+
+ insinto /usr/share/doc/${PF}
+ cd src/current
+ doins Generate_Graphs Gnuplot.txt gengnuplot.sh gnu3d.dem
+
+ prepall
+}
+
+src_test() {
+ cd ${T}
+ ${S}/src/current/iozone testfile || die "self test failed"
+}