summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2007-02-04 02:35:24 +0000
committerLars Weiler <pylon@gentoo.org>2007-02-04 02:35:24 +0000
commit51afa7e9d5efbe3689722e424e6c39c4f3a717b4 (patch)
treed7f5e29e30e737904b054a799dd41239e4e3507f /app-cdr/isomaster
parentFix pre-stripped files and get CC through tc-getCC. Bug #152253. (diff)
downloadhistorical-51afa7e9d5efbe3689722e424e6c39c4f3a717b4.tar.gz
historical-51afa7e9d5efbe3689722e424e6c39c4f3a717b4.tar.bz2
historical-51afa7e9d5efbe3689722e424e6c39c4f3a717b4.zip
Version bump; bug #157697; thanks to Wojciech Myrda for the ebuild.
Package-Manager: portage-2.1.2-r5
Diffstat (limited to 'app-cdr/isomaster')
-rw-r--r--app-cdr/isomaster/ChangeLog9
-rw-r--r--app-cdr/isomaster/files/digest-isomaster-0.73
-rw-r--r--app-cdr/isomaster/isomaster-0.7.ebuild34
3 files changed, 44 insertions, 2 deletions
diff --git a/app-cdr/isomaster/ChangeLog b/app-cdr/isomaster/ChangeLog
index 8fc47cbd772b..f286aa6ac790 100644
--- a/app-cdr/isomaster/ChangeLog
+++ b/app-cdr/isomaster/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-cdr/isomaster
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/isomaster/ChangeLog,v 1.1 2006/12/03 05:55:55 pylon Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/isomaster/ChangeLog,v 1.2 2007/02/04 02:35:24 pylon Exp $
+
+*isomaster-0.7 (04 Feb 2007)
+
+ 04 Feb 2007; Lars Weiler <pylon@gentoo.org> +isomaster-0.7.ebuild:
+ Version bump; bug #157697; thanks to Wojciech Myrda for the ebuild.
*isomaster-0.5 (03 Dec 2006)
diff --git a/app-cdr/isomaster/files/digest-isomaster-0.7 b/app-cdr/isomaster/files/digest-isomaster-0.7
new file mode 100644
index 000000000000..b12be6eab8fd
--- /dev/null
+++ b/app-cdr/isomaster/files/digest-isomaster-0.7
@@ -0,0 +1,3 @@
+MD5 ecc0a033211bb61c18a0bdde5612f2c9 isomaster-0.7.tar.bz2 161558
+RMD160 693f19986a96b73de265655e0bb1743192239746 isomaster-0.7.tar.bz2 161558
+SHA256 f72472173be1c69ce74249a956fe7cad80ce0563a97dd0cbc1fa098a24c851d7 isomaster-0.7.tar.bz2 161558
diff --git a/app-cdr/isomaster/isomaster-0.7.ebuild b/app-cdr/isomaster/isomaster-0.7.ebuild
new file mode 100644
index 000000000000..17d45d2c4b8b
--- /dev/null
+++ b/app-cdr/isomaster/isomaster-0.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+inherit eutils
+
+DESCRIPTION="GTK2 (bootable) CD ISO Image editor."
+HOMEPAGE="http://littlesvr.ca/isomaster/"
+SRC_URI="http://littlesvr.ca/isomaster/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.0"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ # make flags useful
+ sed -i -e "s:-Wall:${CFLAGS}:" Makefile || die "sed failed"
+ sed -i -e "s:-Wall:${CFLAGS}:" */Makefile || die "sed failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install || die "Install failed"
+ dodoc *.TXT bk/TODO.TXT
+
+ doicon icons/${PN}.png
+ make_desktop_entry ${PN} "Isomaster" ${PN}.png "Application;AudioVideo;"
+}
+