summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-06-24 12:25:13 +0000
committerDane Smith <c1pher@gentoo.org>2011-06-24 12:25:13 +0000
commit496635c7fe13b480edea7b4d1bfdbe8ac1597b10 (patch)
tree0a9a44555a5158b199ab3a4b4820708c0665441a /app-crypt/WiRouterKeyRec/WiRouterKeyRec-1.0.7.ebuild
parentalpha/ia64/s390/sh/sparc stable wrt #370523 (diff)
downloadhistorical-496635c7fe13b480edea7b4d1bfdbe8ac1597b10.tar.gz
historical-496635c7fe13b480edea7b4d1bfdbe8ac1597b10.tar.bz2
historical-496635c7fe13b480edea7b4d1bfdbe8ac1597b10.zip
Version bump. Thanks Agostino.
Package-Manager: portage-2.2.0_alpha41/cvs/Linux x86_64
Diffstat (limited to 'app-crypt/WiRouterKeyRec/WiRouterKeyRec-1.0.7.ebuild')
-rw-r--r--app-crypt/WiRouterKeyRec/WiRouterKeyRec-1.0.7.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-crypt/WiRouterKeyRec/WiRouterKeyRec-1.0.7.ebuild b/app-crypt/WiRouterKeyRec/WiRouterKeyRec-1.0.7.ebuild
new file mode 100644
index 000000000000..98ad632092ae
--- /dev/null
+++ b/app-crypt/WiRouterKeyRec/WiRouterKeyRec-1.0.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/WiRouterKeyRec/WiRouterKeyRec-1.0.7.ebuild,v 1.1 2011/06/24 12:25:13 c1pher Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+MY_PN="WiRouter_KeyRec"
+MY_P="${MY_PN}_${PV}"
+
+DESCRIPTION="Recovery tool for wpa passphrase"
+HOMEPAGE="http://www.salvatorefresta.net"
+SRC_URI="http://tools.salvatorefresta.net/${MY_P}.zip -> ${P}.zip"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare () {
+ sed -i 's/$(CFLAGS)\ -o\ $(EXEC)/$(CFLAGS)\ $(LDFLAGS)\ -o\ $(EXEC)/' Makefile || die
+}
+
+src_compile () {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install () {
+ newbin wirouterkeyrec ${PN}
+ insinto /etc/${PN}
+ doins "config/agpf_config.lst"
+}