summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-08-16 11:51:19 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-08-16 11:51:19 +0000
commit94cc9a1b0fdd718f9802a3ea5d897b1b43784b22 (patch)
treefe260f90d43dd0e2073b6d81201af50cac04d930 /app-crypt/cryptplug
parentCleaning up a little, getting ready for moving stuff out of FILESDIR (diff)
downloadhistorical-94cc9a1b0fdd718f9802a3ea5d897b1b43784b22.tar.gz
historical-94cc9a1b0fdd718f9802a3ea5d897b1b43784b22.tar.bz2
historical-94cc9a1b0fdd718f9802a3ea5d897b1b43784b22.zip
modified gpgme-0.3.14-r1 to this needed to change too
Diffstat (limited to 'app-crypt/cryptplug')
-rw-r--r--app-crypt/cryptplug/ChangeLog7
-rw-r--r--app-crypt/cryptplug/cryptplug-0.3.16-r1.ebuild8
-rw-r--r--app-crypt/cryptplug/files/gpgme3.patch27
3 files changed, 9 insertions, 33 deletions
diff --git a/app-crypt/cryptplug/ChangeLog b/app-crypt/cryptplug/ChangeLog
index e212e4d29137..2b1181d06700 100644
--- a/app-crypt/cryptplug/ChangeLog
+++ b/app-crypt/cryptplug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/cryptplug
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/cryptplug/ChangeLog,v 1.16 2004/08/08 12:58:31 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/cryptplug/ChangeLog,v 1.17 2004/08/16 11:48:33 dragonheart Exp $
+
+ 16 Aug 2004; Daniel Black <dragonheart@gentoo.org> -files/gpgme3.patch,
+ cryptplug-0.3.16-r1.ebuild:
+ Have modified gpgme-0.3.14-r1 a bit to make it easier. As a result this needed
+ to changed
08 Aug 2004; Guy Martin <gmsoft@gentoo.org> cryptplug-0.3.16.ebuild:
Stable on hppa.
diff --git a/app-crypt/cryptplug/cryptplug-0.3.16-r1.ebuild b/app-crypt/cryptplug/cryptplug-0.3.16-r1.ebuild
index 76ad688f4e41..355821a9c0d2 100644
--- a/app-crypt/cryptplug/cryptplug-0.3.16-r1.ebuild
+++ b/app-crypt/cryptplug/cryptplug-0.3.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/cryptplug/cryptplug-0.3.16-r1.ebuild,v 1.1 2004/08/08 03:19:52 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/cryptplug/cryptplug-0.3.16-r1.ebuild,v 1.2 2004/08/16 11:48:33 dragonheart Exp $
inherit eutils
@@ -18,19 +18,17 @@ RDEPEND="=app-crypt/gpgme-0.3.14-r1
DEPEND="${RDEPEND}
sys-apps/gawk
- sys-apps/grep
- sys-devel/autoconf"
+ sys-apps/grep"
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/cryptplug-0.3.16-64bit.dif
epatch ${FILESDIR}/cryptplug-0.3.16-initialize-fix.diff
- epatch ${FILESDIR}/gpgme3.patch
}
src_compile() {
- autoconf || die "autoconfigure failed"
+ export GPGME_CONFIG=${ROOT}/usr/bin/gpgme3-config
econf || "configure failed"
emake || "make failed"
}
diff --git a/app-crypt/cryptplug/files/gpgme3.patch b/app-crypt/cryptplug/files/gpgme3.patch
deleted file mode 100644
index 563f433d601f..000000000000
--- a/app-crypt/cryptplug/files/gpgme3.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -ru cryptplug-0.3.16.prepatch/configure.ac cryptplug-0.3.16/configure.ac
---- cryptplug-0.3.16.prepatch/configure.ac 2003-05-13 20:47:26.000000000 +0930
-+++ cryptplug-0.3.16/configure.ac 2004-08-07 17:21:33.828494216 +0930
-@@ -81,9 +81,9 @@
- [gpgme_config_prefix=$withval], [gpgme_config_prefix=])
- if test "$cryptplug_gpgme" != "no"; then
- if test x$gpgme_config_prefix != x ; then
-- GPGME_CONFIG="$gpgme_config_prefix/bin/gpgme-config"
-+ GPGME_CONFIG="$gpgme_config_prefix/bin/gpgme3-config"
- fi
-- AC_PATH_PROG(GPGME_CONFIG, gpgme-config, no)
-+ AC_PATH_PROG(GPGME_CONFIG, gpgme3-config, no)
- if test "$GPGME_CONFIG" = "no"; then
- GPGME_CFLAGS=
- GPGME_LIBS=
-diff -ru cryptplug-0.3.16.prepatch/gpgme/gpgmeplug.c cryptplug-0.3.16/gpgme/gpgmeplug.c
---- cryptplug-0.3.16.prepatch/gpgme/gpgmeplug.c 2004-08-07 17:20:32.650794640 +0930
-+++ cryptplug-0.3.16/gpgme/gpgmeplug.c 2004-08-07 17:21:33.886485400 +0930
-@@ -57,7 +57,7 @@
- #define BUG_URL "http:://www.gnupg.org/aegypten/"
- #endif
-
--#include "gpgme.h"
-+#include "gpgme3.h"
- #ifndef GPGMEPLUG_PROTOCOL
- #define GPGMEPLUG_PROTOCOL GPGME_PROTOCOL_OpenPGP
- #endif