summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-10-18 10:38:19 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-10-18 10:38:19 +0000
commit8b1f99cba86df3c104b1588656efc0249dde2bca (patch)
treef23b8c46056349bcb19c0c8558b8a9ac3b0e6737 /app-crypt/gnupg
parentVersion bump (diff)
downloadhistorical-8b1f99cba86df3c104b1588656efc0249dde2bca.tar.gz
historical-8b1f99cba86df3c104b1588656efc0249dde2bca.tar.bz2
historical-8b1f99cba86df3c104b1588656efc0249dde2bca.zip
Version bump.
Diffstat (limited to 'app-crypt/gnupg')
-rw-r--r--app-crypt/gnupg/ChangeLog7
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.2.01
-rw-r--r--app-crypt/gnupg/gnupg-1.2.0.ebuild59
3 files changed, 66 insertions, 1 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index 5dc7d3afcdcd..ca329c8f782f 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.6 2002/08/14 15:11:30 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.7 2002/10/18 10:38:19 aliz Exp $
+
+*gnupg-1.2.0 (18 Oct 2002)
+
+ 18 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> gnupg-1.2.0.ebuild :
+ Version bump, found by Daniel Seyffer <gentoo-bugs@seyffer.de> in #8778.
*gnupg-1.0.7 (1 Feb 2002)
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.2.0 b/app-crypt/gnupg/files/digest-gnupg-1.2.0
new file mode 100644
index 000000000000..f96a9f9fcbcb
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.2.0
@@ -0,0 +1 @@
+MD5 b22b10dacfeb5c2b0bc4ce9def2d1120 gnupg-1.2.0.tar.bz2 1849154
diff --git a/app-crypt/gnupg/gnupg-1.2.0.ebuild b/app-crypt/gnupg/gnupg-1.2.0.ebuild
new file mode 100644
index 000000000000..6b0f4319bad8
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.0.ebuild,v 1.1 2002/10/18 10:38:19 aliz Exp $
+
+IUSE="nls"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/gnupg/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND=">=sys-libs/zlib-1.1.3"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ # Bug #6387, --enable-m-guard causes bus error on sparcs
+ if [ "${ARCH}" != "sparc" -a "${ARCH}" != "sparc64" ]; then
+ myconf="${myconf} --enable-m-guard"
+ fi
+ econf \
+ --enable-static-rnd=linux \
+ --host="${CHOST}" \
+ ${myconf} || die
+
+ emake || make || die
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS
+ dodoc README TODO VERSION
+ docinto doc
+ cd doc
+ dodoc FAQ HACKING DETAILS ChangeLog
+ docinto sgml
+ dodoc gpg.sgml gpgv.sgml
+ dohtml faq.html
+ docinto txt
+ dodoc faq.raw
+ chmod +s "${D}/usr/bin/gpg"
+}
+
+pkg_postinst() {
+ einfo "gpg is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+ echo " "
+ einfo "Note: this version is not backwards compatible with gnupg-1.0.6."
+ einfo " To update your keyrings run: gpg --rebuild-keydb-caches"
+ einfo " To backup your keyrings run: gpg --export-ownertrust"
+ einfo " and copy the keyrings out of your ~/.gnupg directory."
+}