summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-01-01 13:06:51 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-01-01 13:06:51 +0000
commit801d28dfa84c2d1450c26508872e6eb6003efc10 (patch)
treec1cbf1b98095f2d414ec9b6764530dddc9d32515 /app-crypt/rainbowcrack
parentAdded ~ppc64 to KEYWORDS (diff)
downloadhistorical-801d28dfa84c2d1450c26508872e6eb6003efc10.tar.gz
historical-801d28dfa84c2d1450c26508872e6eb6003efc10.tar.bz2
historical-801d28dfa84c2d1450c26508872e6eb6003efc10.zip
initial submission as per bug #75278
Diffstat (limited to 'app-crypt/rainbowcrack')
-rw-r--r--app-crypt/rainbowcrack/ChangeLog10
-rw-r--r--app-crypt/rainbowcrack/Manifest15
-rw-r--r--app-crypt/rainbowcrack/metadata.xml18
-rw-r--r--app-crypt/rainbowcrack/rainbowcrack-1.2.ebuild56
4 files changed, 99 insertions, 0 deletions
diff --git a/app-crypt/rainbowcrack/ChangeLog b/app-crypt/rainbowcrack/ChangeLog
new file mode 100644
index 000000000000..bd3143942ae9
--- /dev/null
+++ b/app-crypt/rainbowcrack/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-crypt/rainbowcrack
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/rainbowcrack/ChangeLog,v 1.1 2005/01/01 13:06:51 dragonheart Exp $
+
+*rainbowcrack-1.2 (01 Jan 2005)
+
+ 01 Jan 2005; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
+ +rainbowcrack-1.2.ebuild:
+ initial submission as per bug #75278. Ebuild thanks to halitosis@phreaker.net
+
diff --git a/app-crypt/rainbowcrack/Manifest b/app-crypt/rainbowcrack/Manifest
new file mode 100644
index 000000000000..456ce22202b3
--- /dev/null
+++ b/app-crypt/rainbowcrack/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 53577b6d925ed125c976c0daef988edf rainbowcrack-1.2.ebuild 1555
+MD5 b501021113660333d344a4fa18808e5c metadata.xml 988
+MD5 7cb742ad432ad21ab2fc947b13149901 ChangeLog 432
+MD5 d13ce783ad640b04752c5f0bce77d0ee files/rainbowcrack-1.2-makefile.patch 1134
+MD5 a24acbb0c808a455a647bb18ba9dc99b files/digest-rainbowcrack-1.2 150
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFB1qFLmdTrptrqvGERAilAAKCJGINCzHZsb1Ykme3fY6lPuFGrLQCbB3Ur
+GH8IGS4jM7mGG3VZoSswCMk=
+=CKzU
+-----END PGP SIGNATURE-----
diff --git a/app-crypt/rainbowcrack/metadata.xml b/app-crypt/rainbowcrack/metadata.xml
new file mode 100644
index 000000000000..07d893086a67
--- /dev/null
+++ b/app-crypt/rainbowcrack/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+<maintainer>
+ <email>dragonheart@gentoo.org</email>
+ <name>Daniel Black</name>
+</maintainer>
+<longdescription>
+RainbowCrack is a general propose implementation of Philippe Oechslin's faster time-memory trade-off technique.
+ In short, the RainbowCrack tool is a password cracker. A traditional brute force cracker try all possible
+plaintexts one by one in cracking time. It is time consuming to break complex password in this way. The idea of
+time-memory trade-off is to do all cracking time computation in advance and store the result in files so called
+"rainbow table". It does take a long time to precompute the tables. But once the one time precomputation is
+finished, a time-memory trade-off cracker can be hundreds of times faster than a brute force cracker, with the
+help of precomputed tables.
+</longdescription>
+</pkgmetadata>
diff --git a/app-crypt/rainbowcrack/rainbowcrack-1.2.ebuild b/app-crypt/rainbowcrack/rainbowcrack-1.2.ebuild
new file mode 100644
index 000000000000..0bea5b7d01a6
--- /dev/null
+++ b/app-crypt/rainbowcrack/rainbowcrack-1.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/rainbowcrack/rainbowcrack-1.2.ebuild,v 1.1 2005/01/01 13:06:51 dragonheart Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Hash cracker that precomputes plaintext - ciphertext pairs in advance"
+HOMEPAGE="http://www.antsight.com/zsl/rainbowcrack/"
+
+SRC_URI="http://www.antsight.com/zsl/rainbowcrack/${P}-src.zip
+ http://www.antsight.com/zsl/rainbowcrack/${P}-src-algorithmpatch.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl"
+
+MY_P=${P}-src
+S=${WORKDIR}/${MY_P}/src
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ mv ${P}-src-algorithmpatch/Hash* ${S}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-makefile.patch || die "patch failed"
+}
+
+src_compile() {
+ emake -f makefile.linux CXX=$(tc-getCXX) || die "make failed"
+}
+
+src_test() {
+ einfo "generating rainbow tables (password maps)"
+ ./rtgen sha1 loweralpha 7 7 0 1000 160 test
+ einfo "sorting tables"
+ ./rtsort *.rt
+ einfo "attempting crack of 7 character random sha1 lowercase passwords"
+ ./rcrack ./*.rt -l random_sha1_loweralpha#1-7.hash
+ einfo "I haven't rigged this so it finds anything yet. Submissions welcome bugs.gentoo.org"
+}
+
+src_install() {
+ dobin rtgen rtdump rtsort rcrack
+ insinto /usr/share/${PN}
+ doins charset.txt
+
+ dodoc *.plain *.hash
+
+ newdoc ${WORKDIR}/${P}-src-algorithmpatch/readme.txt algorithm_readme.txt
+
+ cd ${WORKDIR}/${MY_P}
+ dodoc readme.txt readme_src.txt disclaimer.txt
+ dohtml -r doc/
+}