summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2005-01-02 13:16:03 +0000
committerJohn Mylchreest <johnm@gentoo.org>2005-01-02 13:16:03 +0000
commit0e68fff24ea39231ed4999ca6fb99216a672c957 (patch)
tree99922518a313792e199264918cc7af8a24ba70cd /app-crypt
parentadding app-crypt/gpg-agent threads use description (diff)
downloadhistorical-0e68fff24ea39231ed4999ca6fb99216a672c957.tar.gz
historical-0e68fff24ea39231ed4999ca6fb99216a672c957.tar.bz2
historical-0e68fff24ea39231ed4999ca6fb99216a672c957.zip
fixing up libksba dep which was missing. Adding threads fix (libpth). Now compiles properly on all systems?
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gpg-agent/ChangeLog6
-rw-r--r--app-crypt/gpg-agent/Manifest10
-rw-r--r--app-crypt/gpg-agent/gpg-agent-1.9.14.ebuild12
3 files changed, 18 insertions, 10 deletions
diff --git a/app-crypt/gpg-agent/ChangeLog b/app-crypt/gpg-agent/ChangeLog
index 2c42b7d7085f..0e4cae584c9b 100644
--- a/app-crypt/gpg-agent/ChangeLog
+++ b/app-crypt/gpg-agent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/gpg-agent
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-agent/ChangeLog,v 1.1 2005/01/02 07:05:34 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-agent/ChangeLog,v 1.2 2005/01/02 13:16:03 johnm Exp $
+
+ 02 Jan 2005; John Mylchreest <johnm@gentoo.org> gpg-agent-1.9.14.ebuild:
+ fixing up libksba dep which was missing. Adding threads fix (libpth). Now
+ compiles properly on all systems?
*gpg-agent-1.9.14 (02 Jan 2005)
diff --git a/app-crypt/gpg-agent/Manifest b/app-crypt/gpg-agent/Manifest
index 794c045b888c..0d508be7d5ba 100644
--- a/app-crypt/gpg-agent/Manifest
+++ b/app-crypt/gpg-agent/Manifest
@@ -1,14 +1,14 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 dc609d814cc99e3194285fc3ef907098 gpg-agent-1.9.14.ebuild 2015
-MD5 cc29ca12082ee7e053b860db86333e60 ChangeLog 447
+MD5 617c925c97eed9124c65571f38b4dc10 gpg-agent-1.9.14.ebuild 2132
+MD5 5aeb364ab8429ca6c126371d40598981 ChangeLog 629
MD5 b1a4c3f100342f9335a6974737f5e5ec metadata.xml 872
MD5 337c9671ff169f922ba7d007a3ceaae6 files/digest-gpg-agent-1.9.14 66
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFB151EmdTrptrqvGERAlKaAJ9dkX7IqZMp+12XyFxFnzwjxW/RNgCfSvm7
-DNWM16CQFC/GW0DZWfC/3+s=
-=xeHL
+iD8DBQFB1/RXKiUX0BdHiZkRAgNIAKDLfmI4a3FgBxlZRlTQYJh98uLsfACdEmk9
+YO2DfPdLAF6CflyxhuZsR1c=
+=XvA4
-----END PGP SIGNATURE-----
diff --git a/app-crypt/gpg-agent/gpg-agent-1.9.14.ebuild b/app-crypt/gpg-agent/gpg-agent-1.9.14.ebuild
index 7286572a60ce..70933f5c17c7 100644
--- a/app-crypt/gpg-agent/gpg-agent-1.9.14.ebuild
+++ b/app-crypt/gpg-agent/gpg-agent-1.9.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-agent/gpg-agent-1.9.14.ebuild,v 1.1 2005/01/02 07:05:34 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-agent/gpg-agent-1.9.14.ebuild,v 1.2 2005/01/02 13:16:03 johnm Exp $
inherit eutils flag-o-matic
@@ -14,10 +14,11 @@ SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/${GPG_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
# ~arm ~ia64 ~mips ~s390 ~sparce missing until libassuan gets the keywords
+# ~alpha missing for dev-libs/libksba-0.9.7
-IUSE="nls caps"
+IUSE="nls caps threads"
RDEPEND="<app-crypt/gnupg-1.9
nls? ( sys-devel/gettext )
@@ -25,7 +26,9 @@ RDEPEND="<app-crypt/gnupg-1.9
>=dev-libs/libassuan-0.6.9
caps? ( sys-libs/libcap )
>=dev-libs/libgpg-error-0.7
- >=dev-libs/libgcrypt-1.1.94"
+ >=dev-libs/libgcrypt-1.1.94
+ >=dev-libs/libksba-0.9.7
+ threads? ( dev-libs/pth )"
DEPEND="${RDEPEND}
dev-lang/perl
@@ -43,6 +46,7 @@ src_compile() {
--libexecdir=/usr/lib \
--enable-agent-only \
`use_with caps capabilities` \
+ `use_enable threads` \
|| die
emake || die