summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-10-03 22:29:31 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-10-03 22:29:31 +0000
commit13928bb8f0cf9723264509b8a6a276b3cca7d966 (patch)
tree871c9418af85de76c8ec880a8b3c16c90eb03535 /app-crypt
parentAdd myself as maintainer. (diff)
downloadhistorical-13928bb8f0cf9723264509b8a6a276b3cca7d966.tar.gz
historical-13928bb8f0cf9723264509b8a6a276b3cca7d966.tar.bz2
historical-13928bb8f0cf9723264509b8a6a276b3cca7d966.zip
Fix compilation failure w/ openssl-0.9.8i by commenting out some ifdeffed code. Bug 239449.
Package-Manager: portage-2.2_rc11/cvs/Linux 2.6.27-rc8 x86_64
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/qca-ossl/Manifest3
-rw-r--r--app-crypt/qca-ossl/files/qca-ossl-openssl-0.9.8i.patch29
-rw-r--r--app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild7
3 files changed, 36 insertions, 3 deletions
diff --git a/app-crypt/qca-ossl/Manifest b/app-crypt/qca-ossl/Manifest
index e4c063437adb..07f02a2c3278 100644
--- a/app-crypt/qca-ossl/Manifest
+++ b/app-crypt/qca-ossl/Manifest
@@ -1,4 +1,5 @@
+AUX qca-ossl-openssl-0.9.8i.patch 774 RMD160 711598d6c52f03abe234058867ecbe66206d42b8 SHA1 2cad3a7c536ab20b94d988ed7265ea002e0e08b9 SHA256 1fff9870c295a5634e203f836ad6c201fed8eb8fc10ab4c0643a2ec464422e4f
DIST qca-ossl-2.0.0-beta3.tar.bz2 49188 RMD160 c979c3c3427eb45e8866e28746f83966e8bcf3c2 SHA1 dd925e8732ff76f24f9f90f4094abaf2f0ac27bf SHA256 08e09ff586b184d5fb53b88f0b48eed0a7bf0a5f210a9f97a76cf4cd5446c67b
-EBUILD qca-ossl-2.0.0_beta3.ebuild 1492 RMD160 91d072203f999c6ca0a67a25ae323fe1012f7991 SHA1 3967f71505a8fc276cd5ee7e59a50acf69ef1661 SHA256 cf35f4879f34ffb4651ce076dd220e6841eefaef45859fe239ee6f905bb0039e
+EBUILD qca-ossl-2.0.0_beta3.ebuild 1603 RMD160 097a1b78febb722ab3b6547f1b351a56805b4c78 SHA1 08f31075e97258c9b2f3fc518dc13dd9f1df2a1e SHA256 b25fc23f8c7a707fbb532ee922b5d52b6194d31fc9b116d8484b169221b944f3
MISC ChangeLog 2725 RMD160 09470f0ba4c31c5b2a1be52199c05366225ccdb4 SHA1 93c1668dc8379ef5a51a0e5c975793c713f24259 SHA256 1f0e1f29aa94cf7f676acfb684d4b3fc68b5b95814fd57769c7ab6e5b3388405
MISC metadata.xml 192 RMD160 745ecce4d913885d0c5794b96fafd63a29a6e19e SHA1 fe4c3a2accae45b2ade98c5b45a3bd4533aac681 SHA256 2f70cf009da734f5a0166d90a267b186b6a4148cec4778a7f27ca8ef38709096
diff --git a/app-crypt/qca-ossl/files/qca-ossl-openssl-0.9.8i.patch b/app-crypt/qca-ossl/files/qca-ossl-openssl-0.9.8i.patch
new file mode 100644
index 000000000000..deceb34b59e3
--- /dev/null
+++ b/app-crypt/qca-ossl/files/qca-ossl-openssl-0.9.8i.patch
@@ -0,0 +1,29 @@
+http://websvn.kde.org/trunk/kdesupport/qca/plugins/qca-ossl/qca-ossl.cpp?r1=848615&r2=864423&view=patch
+
+--- qca-ossl/qca-ossl.cpp 2008/08/18 09:08:51 848615
++++ qca-ossl/qca-ossl.cpp 2008/09/24 19:22:26 864423
+@@ -6616,9 +6616,11 @@
+ #ifdef SHA512_DIGEST_LENGTH
+ list += "sha512";
+ #endif
++/*
+ #ifdef OBJ_whirlpool
+ list += "whirlpool";
+ #endif
++*/
+ return list;
+ }
+
+@@ -6863,10 +6865,12 @@
+ else if ( type == "sha512" )
+ return new opensslHashContext( EVP_sha512(), this, type);
+ #endif
++/*
+ #ifdef OBJ_whirlpool
+ else if ( type == "whirlpool" )
+ return new opensslHashContext( EVP_whirlpool(), this, type);
+ #endif
++*/
+ else if ( type == "pbkdf1(sha1)" )
+ return new opensslPbkdf1Context( EVP_sha1(), this, type );
+ else if ( type == "pbkdf1(md2)" )
diff --git a/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild b/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild
index 6675b8ebd93b..61e6a0464e6a 100644
--- a/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild
+++ b/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild,v 1.13 2008/09/20 10:05:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-ossl/qca-ossl-2.0.0_beta3.ebuild,v 1.14 2008/10/03 22:29:30 loki_val Exp $
-inherit eutils qt4
+inherit base eutils qt4
MY_P="${P/_/-}"
QCA_VER="${PV%.*}"
@@ -22,6 +22,8 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}/${PN}-openssl-0.9.8i.patch" )
+
pkg_setup() {
if use debug && ! built_with_use ">=app-crypt/qca-${QCA_VER}" debug; then
echo
@@ -45,6 +47,7 @@ src_compile() {
|| die "configure failed"
eqmake4 ${PN}.pro
+ sed -i -e '/strip/d' Makefile || die "sed failed"
emake || die "emake failed"
}