summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-09-19 19:19:50 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-09-19 19:19:50 +0000
commit50526fbfd8c5c16357cd840de82a9239ca181613 (patch)
tree3cdb95c40cef6fdccfb89f67338768fb6a3995c0 /app-crypt
parentNo need to set RDEPEND=DEPEND (diff)
downloadhistorical-50526fbfd8c5c16357cd840de82a9239ca181613.tar.gz
historical-50526fbfd8c5c16357cd840de82a9239ca181613.tar.bz2
historical-50526fbfd8c5c16357cd840de82a9239ca181613.zip
bug 106536
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gpg-agent/ChangeLog9
-rw-r--r--app-crypt/gpg-agent/files/digest-gpg-agent-1.9.161
-rw-r--r--app-crypt/gpg-agent/files/digest-gpg-agent-1.9.191
-rw-r--r--app-crypt/gpg-agent/gpg-agent-1.9.19.ebuild (renamed from app-crypt/gpg-agent/gpg-agent-1.9.16.ebuild)34
4 files changed, 24 insertions, 21 deletions
diff --git a/app-crypt/gpg-agent/ChangeLog b/app-crypt/gpg-agent/ChangeLog
index 00d5c1ea5c39..e6a1f89e8176 100644
--- a/app-crypt/gpg-agent/ChangeLog
+++ b/app-crypt/gpg-agent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/gpg-agent
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-agent/ChangeLog,v 1.12 2005/09/16 20:33:04 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-agent/ChangeLog,v 1.13 2005/09/19 19:19:50 vanquirius Exp $
+
+*gpg-agent-1.9.19 (19 Sep 2005)
+
+ 19 Sep 2005; Marcelo Goes <vanquirius@gentoo.org>
+ -gpg-agent-1.9.16.ebuild, +gpg-agent-1.9.19.ebuild:
+ Version bump for bug 106536. Thanks to Paolo Pedroni <paolo dot pedroni at
+ iol dot it>.
16 Sep 2005; Ciaran McCreesh <ciaranm@gentoo.org> ChangeLog:
Converted to UTF-8, fixed encoding screwups
diff --git a/app-crypt/gpg-agent/files/digest-gpg-agent-1.9.16 b/app-crypt/gpg-agent/files/digest-gpg-agent-1.9.16
deleted file mode 100644
index f4bdad3e3554..000000000000
--- a/app-crypt/gpg-agent/files/digest-gpg-agent-1.9.16
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1282755dce9cf4a84e904ca0191017a3 gnupg-1.9.16.tar.bz2 1707356
diff --git a/app-crypt/gpg-agent/files/digest-gpg-agent-1.9.19 b/app-crypt/gpg-agent/files/digest-gpg-agent-1.9.19
new file mode 100644
index 000000000000..2be41931ad90
--- /dev/null
+++ b/app-crypt/gpg-agent/files/digest-gpg-agent-1.9.19
@@ -0,0 +1 @@
+MD5 8084256a61aa90e0173d436bf1e6f82b gnupg-1.9.19.tar.bz2 1760576
diff --git a/app-crypt/gpg-agent/gpg-agent-1.9.16.ebuild b/app-crypt/gpg-agent/gpg-agent-1.9.19.ebuild
index 6b68ce3bc2fc..b2455c4f3800 100644
--- a/app-crypt/gpg-agent/gpg-agent-1.9.16.ebuild
+++ b/app-crypt/gpg-agent/gpg-agent-1.9.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-agent/gpg-agent-1.9.16.ebuild,v 1.6 2005/08/06 05:34:19 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-agent/gpg-agent-1.9.19.ebuild,v 1.1 2005/09/19 19:19:50 vanquirius Exp $
inherit eutils flag-o-matic
@@ -16,36 +16,34 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="caps nls smartcard threads"
+IUSE="caps nls smartcard"
RDEPEND="app-crypt/gnupg
nls? ( sys-devel/gettext )
- >=dev-libs/libassuan-0.6.9
+ >=dev-libs/libassuan-0.6.10
caps? ( sys-libs/libcap )
>=dev-libs/libgpg-error-1.0
>=dev-libs/libgcrypt-1.1.94
- >=dev-libs/libksba-0.9.7
+ >=dev-libs/libksba-0.9.12
smartcard? ( >=dev-libs/opensc-0.8.0 )
- threads? ( >=dev-libs/pth-1.3.7 )"
+ >=dev-libs/pth-1.3.7"
DEPEND="${RDEPEND}
dev-lang/perl"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # We install +s only if USE=-caps
- use caps && return 0
- sed -i \
- -e '/^gpg_agent_LDADD/s:=:=-Wl,-z,now:' \
- agent/Makefile.in || die "sed -z now"
-}
-
src_compile() {
+ # We install +s only if USE=-caps and not OS X
+
+ if ! use ppc-macos && ! use caps
+ then
+ append-ldflags '-Wl,-z,now'
+ fi
econf \
--enable-agent-only \
- $(use_with caps capabilities) \
- $(use_enable threads) \
+ --disable-scdaemon \
+ --disable-gpgsm \
+ --enable-symcryptrun \
$(use_enable nls) \
+ $(use_with caps capabilities) \
|| die
emake || die
}
@@ -57,8 +55,6 @@ src_test() {
src_install() {
make DESTDIR="${D}" install || die
- # keep the documentation in /usr/share/doc/...
- rm -f "${D}"/usr/share/gnupg/FAQ "${D}"/usr/share/gnupg/faq.html
dodoc README
if ! use caps ; then