summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-07-24 19:52:05 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-07-24 19:52:05 +0000
commitdabb71cc55a8ac931d8f6b8adda9d8220806b3ce (patch)
treeb3d8ccfabd14151636e8caf07ab357354ff0f793 /app-dicts/dictd-wn/dictd-wn-2.0.ebuild
parentfixed SRC_URI to use mirror://gnu (#55523) (diff)
downloadhistorical-dabb71cc55a8ac931d8f6b8adda9d8220806b3ce.tar.gz
historical-dabb71cc55a8ac931d8f6b8adda9d8220806b3ce.tar.bz2
historical-dabb71cc55a8ac931d8f6b8adda9d8220806b3ce.zip
version bump #54439
Diffstat (limited to 'app-dicts/dictd-wn/dictd-wn-2.0.ebuild')
-rw-r--r--app-dicts/dictd-wn/dictd-wn-2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-dicts/dictd-wn/dictd-wn-2.0.ebuild b/app-dicts/dictd-wn/dictd-wn-2.0.ebuild
new file mode 100644
index 000000000000..838144d5ecb2
--- /dev/null
+++ b/app-dicts/dictd-wn/dictd-wn-2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/dictd-wn/dictd-wn-2.0.ebuild,v 1.1 2004/07/24 19:52:05 liquidx Exp $
+
+MY_P=${P/td/t}
+DESCRIPTION="WordNet for dict"
+HOMEPAGE="http://www.dict.org/"
+SRC_URI="ftp://ftp.dict.org/pub/dict/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+
+DEPEND=">=app-text/dictd-1.5.5"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # don't use econf, configure script is broken
+ ./configure || die "configure failed"
+ emake || die "compile failed"
+ emake db || die "compile database failed"
+}
+
+src_install() {
+ cd ${S}
+ insinto /usr/lib/dict
+ doins wn.dict.dz wn.index || die
+}