summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-01-23 13:04:14 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-01-23 13:04:14 +0000
commit1fd4d403bb7bcdcc76c1894f0680be8a818480b8 (patch)
treef157c90bd61537e5d2a1f40bc2c2b9bd7b0470fd /app-dicts
parentUnmask mozilla-thunderbird-bin-3.0 (diff)
downloadhistorical-1fd4d403bb7bcdcc76c1894f0680be8a818480b8.tar.gz
historical-1fd4d403bb7bcdcc76c1894f0680be8a818480b8.tar.bz2
historical-1fd4d403bb7bcdcc76c1894f0680be8a818480b8.zip
Initial ebuild of goldendict. Bug #264631
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/goldendict/ChangeLog11
-rw-r--r--app-dicts/goldendict/Manifest5
-rw-r--r--app-dicts/goldendict/files/goldendict-0.9.0-gcc4.4.patch11
-rw-r--r--app-dicts/goldendict/goldendict-0.9.0.ebuild64
-rw-r--r--app-dicts/goldendict/metadata.xml6
5 files changed, 97 insertions, 0 deletions
diff --git a/app-dicts/goldendict/ChangeLog b/app-dicts/goldendict/ChangeLog
new file mode 100644
index 000000000000..1160004badaf
--- /dev/null
+++ b/app-dicts/goldendict/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-dicts/goldendict
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/goldendict/ChangeLog,v 1.1 2010/01/23 13:04:13 hwoarang Exp $
+
+*goldendict-0.9.0 (23 Jan 2010)
+
+ 23 Jan 2010; Markos Chandras <hwoarang@gentoo.org>
+ +goldendict-0.9.0.ebuild, +files/goldendict-0.9.0-gcc4.4.patch,
+ +metadata.xml:
+ Initial ebuild of goldendict. Bug #264631
+
diff --git a/app-dicts/goldendict/Manifest b/app-dicts/goldendict/Manifest
new file mode 100644
index 000000000000..429c5d424da7
--- /dev/null
+++ b/app-dicts/goldendict/Manifest
@@ -0,0 +1,5 @@
+AUX goldendict-0.9.0-gcc4.4.patch 380 RMD160 ad0d42441279dd3b13ecdf5903d5fc991cf8ca31 SHA1 42c735a450640614e84f3b10a906b2fc4a3ecc3a SHA256 e7dd204ab580bbe473d782299d7d24f35bcedaaca4034c6540761b6d10d31c72
+DIST goldendict-0.9.0-src-x11.tar.bz2 450332 RMD160 9c8467ace98f8b44b87853d610c895d368702037 SHA1 adb119b612c9b75d8114744257673892fd9625c9 SHA256 30bf5e4ac6abf56067ee8d8750c545726509bcea591825de88ba44071769c946
+EBUILD goldendict-0.9.0.ebuild 1575 RMD160 43b49f974e67f8b5287e88fe5a55b385d6a21d57 SHA1 1319efaf1e32bd72952353b301e32cbf50411538 SHA256 aa0b361b901c73001b948bf9e8dc7753097b1e230ea61fefcb7870d92514d104
+MISC ChangeLog 429 RMD160 c5d8bbe3a2b168e14113ccc35fd4ee39c8900600 SHA1 6c956e1c22d14c3774e014e66a0cf5657e0875c9 SHA256 8b64e53a670db3884481d5ae723079bf8865a192b76babb95258fea100cf1068
+MISC metadata.xml 157 RMD160 ac97f8cc970b649f4d061f6e4441eaf6144524e3 SHA1 415c2e405c673551de51cf6623305f9dbcc70b23 SHA256 94b6a379608ee8b74b175f0dfe5b2312658faf5eca74bba0787fc02c3d6859d6
diff --git a/app-dicts/goldendict/files/goldendict-0.9.0-gcc4.4.patch b/app-dicts/goldendict/files/goldendict-0.9.0-gcc4.4.patch
new file mode 100644
index 000000000000..80d4551389de
--- /dev/null
+++ b/app-dicts/goldendict/files/goldendict-0.9.0-gcc4.4.patch
@@ -0,0 +1,11 @@
+diff -Nuar goldendict-0.9.0-src.orig/chunkedstorage.hh goldendict-0.9.0-src/chunkedstorage.hh
+--- goldendict-0.9.0-src.orig/chunkedstorage.hh 2009-09-24 20:20:56.000000000 +0600
++++ goldendict-0.9.0-src/chunkedstorage.hh 2009-09-24 20:22:22.000000000 +0600
+@@ -8,6 +8,7 @@
+ #include "file.hh"
+
+ #include <vector>
++#include <stdint.h>
+
+ #ifdef _MSC_VER
+ #include <stdint_msvc.h>
diff --git a/app-dicts/goldendict/goldendict-0.9.0.ebuild b/app-dicts/goldendict/goldendict-0.9.0.ebuild
new file mode 100644
index 000000000000..a25ddf0a67b2
--- /dev/null
+++ b/app-dicts/goldendict/goldendict-0.9.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/goldendict/goldendict-0.9.0.ebuild,v 1.1 2010/01/23 13:04:13 hwoarang Exp $
+
+EAPI="2"
+LANGS="ru"
+inherit qt4-r2 eutils
+
+DESCRIPTION="Feature-rich dictionary lookup program"
+HOMEPAGE="http://goldendict.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}-src-x11.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}/${P}-src"
+
+RDEPEND=">=app-text/hunspell-1.2
+ dev-libs/libzip
+ media-libs/libogg
+ media-libs/libvorbis
+ x11-libs/libXtst
+ >=x11-libs/qt-webkit-4.5:4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc4.4.patch"
+ # duplicates stuff into a directory we don't use
+ sed -i \
+ -e s/INSTALLS\ \+=\ desktops2//g \
+ -e s/INSTALLS\ \+=\ icons2//g \
+ "${S}"/goldendict.pro || die 'sed failed'
+}
+
+src_configure() {
+ PREFIX=/usr eqmake4
+}
+
+src_compile() {
+ if use linguas_ru ; then
+ einfo 'Preparing translations...'
+ lrelease ${PN}.pro || die 'lrelease failed'
+ fi
+ emake || die 'emake failed'
+}
+
+src_install() {
+ qt4-r2_src_install
+ for X in ${LINGUAS} ; do
+ for Z in ${LANGS}; do
+ if [[ ${X} == ${Z} ]]; then
+ insinto /usr/share/apps/${PN}/locale
+ doins locale/ru.qm || die 'doins failed'
+ fi
+ done
+ done
+}
+
+pkg_postinst() {
+ elog 'The portage tree contains various stardict and dictd dictionaries, which'
+ elog 'GoldenDict can use. Also, check http://goldendict.berlios.de/dictionaries.php'
+ elog 'for more options. The myspell packages can also be useful.'
+}
diff --git a/app-dicts/goldendict/metadata.xml b/app-dicts/goldendict/metadata.xml
new file mode 100644
index 000000000000..c4db62280a40
--- /dev/null
+++ b/app-dicts/goldendict/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+</pkgmetadata>
+