summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2009-03-09 11:25:05 +0000
committerAkinori Hattori <hattya@gentoo.org>2009-03-09 11:25:05 +0000
commit5fbebf3c1a1dcff2e4e29f42b67edfe12ca462d3 (patch)
treee1592a8a8ae596cb16c313240a43ce0ee483f8d7 /app-editors/easyedit/easyedit-1.4.7.ebuild
parentVersion bump (diff)
downloadhistorical-5fbebf3c1a1dcff2e4e29f42b67edfe12ca462d3.tar.gz
historical-5fbebf3c1a1dcff2e4e29f42b67edfe12ca462d3.tar.bz2
historical-5fbebf3c1a1dcff2e4e29f42b67edfe12ca462d3.zip
set default target to curses.
Package-Manager: portage-2.1.6.7/cvs/Linux i686
Diffstat (limited to 'app-editors/easyedit/easyedit-1.4.7.ebuild')
-rw-r--r--app-editors/easyedit/easyedit-1.4.7.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/app-editors/easyedit/easyedit-1.4.7.ebuild b/app-editors/easyedit/easyedit-1.4.7.ebuild
index a9bbae6683e4..8bdb92965068 100644
--- a/app-editors/easyedit/easyedit-1.4.7.ebuild
+++ b/app-editors/easyedit/easyedit-1.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/easyedit/easyedit-1.4.7.ebuild,v 1.1 2009/03/01 16:44:20 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/easyedit/easyedit-1.4.7.ebuild,v 1.2 2009/03/09 11:25:05 hattya Exp $
inherit toolchain-funcs
@@ -18,20 +18,30 @@ DEPEND=">=sys-libs/ncurses-5.0"
RDEPEND="${DEPEND}"
src_unpack() {
+
unpack ${A}
cd "${S}"
- sed -i -e "s/\tcc /\t\\\\\$(CC) /" -e "/other_cflag/s/ *-s//" create.make
- emake localmake
- sed -i -e 's/-DNCURSES//' make.local
+ sed -i \
+ -e "s/\tcc /\t\\\\\$(CC) /" \
+ -e "/other_cflag/s/ *-s//" \
+ create.make
+
}
src_compile() {
- emake -f make.local CC="$(tc-getCC)" curses || die
+
+ emake localmake
+ sed -i -e '/^all/s/ee/curses/' make.local
+
+ emake -f make.local CC="$(tc-getCC)" || die
+
}
src_install() {
+
dobin ee
doman ee.1
dodoc README.ee Changes ee.i18n.guide ee.msg
+
}