summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 23:26:38 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 23:26:38 +0000
commit6fa2a853c9ff4cc42cb6f17651ed9206b668390d (patch)
tree701d219416e6ef918bbf0c0e853a971622a38f09 /app-editors/elvis
parentadded ~ppc to KEYWORDS (diff)
downloadhistorical-6fa2a853c9ff4cc42cb6f17651ed9206b668390d.tar.gz
historical-6fa2a853c9ff4cc42cb6f17651ed9206b668390d.tar.bz2
historical-6fa2a853c9ff4cc42cb6f17651ed9206b668390d.zip
Changed src_install () to src_install()
Diffstat (limited to 'app-editors/elvis')
-rw-r--r--app-editors/elvis/elvis-2.1.4-r1.ebuild41
-rw-r--r--app-editors/elvis/elvis-2.1.4.ebuild41
2 files changed, 38 insertions, 44 deletions
diff --git a/app-editors/elvis/elvis-2.1.4-r1.ebuild b/app-editors/elvis/elvis-2.1.4-r1.ebuild
index c16f5e97b628..7392d46438b4 100644
--- a/app-editors/elvis/elvis-2.1.4-r1.ebuild
+++ b/app-editors/elvis/elvis-2.1.4-r1.ebuild
@@ -1,49 +1,46 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4-r1.ebuild,v 1.9 2002/10/05 05:39:05 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4-r1.ebuild,v 1.10 2002/11/30 23:24:30 vapier Exp $
-IUSE="X"
-
-S=${WORKDIR}/elvis-2.1_4
+MY_P="${PN}-2.1_4"
+S=${WORKDIR}/${MY_P}
DESCRIPTION="A vi/ex clone"
-SRC_URI="ftp://ftp.cs.pdx.edu/pub/${PN}/${PN}-2.1_4.tar.gz"
+SRC_URI="ftp://ftp.cs.pdx.edu/pub/${PN}/${MY_P}.tar.gz"
HOMEPAGE="ftp://ftp.cs.pdx.edu/pub/elvis/"
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="x86 ppc sparc sparc64"
+IUSE="X"
+
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2
X? ( virtual/x11 )"
RDEPEND=""
-SLOT="0"
-LICENSE="Artistic"
-KEYWORDS="x86 ppc sparc sparc64"
-
src_compile() {
-
local myconf
- if [ "`use X`" ]; then
- myconf="--with-x"
- else
- myconf="--without-x"
- fi
+ use X \
+ && myconf="--with-x" \
+ || myconf="--without-x"
./configure --bindir=${D}/usr/bin --datadir=${D}/usr/share/elvis ${myconf} || die
cp Makefile Makefile.orig
sed -e "s:gcc -O2:gcc ${CFLAGS}:" Makefile.orig > Makefile
cp config.h config.h.orig
sed -e "s:${D}/usr/share/elvis:/usr/share/elvis:" config.h.orig > config.h
make || die
-
}
-src_install () {
-
+src_install() {
cp instman.sh instman.sh.orig
- cat instman.sh.orig | sed -e "s:/usr/man:${D}/usr/share/man:g" > instman.sh
+ sed -e "s:/usr/man:${D}/usr/share/man:g" instman.sh.orig > instman.sh
+
cp insticon.sh insticon.sh.orig
- cat insticon.sh.orig | sed -e "s:^xinc=.*$:xinc=${D}/usr/include:" \
- | sed -e "s:^xlib=.*$:xlib=${D}/usr/lib:" > insticon.sh
+ sed -e "s:^xinc=.*$:xinc=${D}/usr/include:" \
+ -e "s:^xlib=.*$:xlib=${D}/usr/lib:" \
+ insticon.sh.orig > insticon.sh
+
dodir /usr/bin
dodir /usr/share/man/man1
make install || die
-
}
diff --git a/app-editors/elvis/elvis-2.1.4.ebuild b/app-editors/elvis/elvis-2.1.4.ebuild
index a406c98a053b..df1c98ecf6c9 100644
--- a/app-editors/elvis/elvis-2.1.4.ebuild
+++ b/app-editors/elvis/elvis-2.1.4.ebuild
@@ -1,47 +1,44 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4.ebuild,v 1.8 2002/10/05 05:39:05 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4.ebuild,v 1.9 2002/11/30 23:26:38 vapier Exp $
-IUSE="X"
-
-S=${WORKDIR}/elvis-2.1_4
+MY_P="${PN}-2.1_4"
+S=${WORKDIR}/${MY_P}
DESCRIPTION="A vi/ex clone"
-SRC_URI="ftp://ftp.cs.pdx.edu/pub/${PN}/${PN}-2.1_4.tar.gz"
+SRC_URI="ftp://ftp.cs.pdx.edu/pub/${PN}/${MY_P}.tar.gz"
HOMEPAGE="ftp://ftp.cs.pdx.edu/pub/elvis/"
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="x86 ppc sparc sparc64"
+IUSE="X"
+
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2
X? ( virtual/x11 )"
RDEPEND=""
-SLOT="0"
-LICENSE="Artistic"
-KEYWORDS="x86 ppc sparc sparc64"
-
src_compile() {
-
local myconf
- if [ "`use X`" ]; then
- mconf="--with-x"
- else
- mconf="--without-x"
- fi
+ use X \
+ && myconf="--with-x" \
+ || myconf="--without-x"
./configure --bindir=${D}/usr/bin --datadir=${D}/usr/share/elvis ${myconf} || die
cp Makefile Makefile.orig
cat Makefile.orig | sed -e "s:gcc -O2:gcc ${CFLAGS}:" > Makefile
make || die
-
}
-src_install () {
-
+src_install() {
cp instman.sh instman.sh.orig
- cat instman.sh.orig | sed -e "s:/usr/man:${D}/usr/share/man:g" > instman.sh
+ sed -e "s:/usr/man:${D}/usr/share/man:g" instman.sh.orig > instman.sh
+
cp insticon.sh insticon.sh.orig
- cat insticon.sh.orig | sed -e "s:^xinc=.*$:xinc=${D}/usr/include:" \
- | sed -e "s:^xlib=.*$:xlib=${D}/usr/lib:" > insticon.sh
+ sed -e "s:^xinc=.*$:xinc=${D}/usr/include:" \
+ -e "s:^xlib=.*$:xlib=${D}/usr/lib:" \
+ insticon.sh.orig > insticon.sh
+
dodir /usr/bin
dodir /usr/share/man/man1
make install || die
-
}