summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-03-03 19:03:38 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-03-03 19:03:38 +0000
commita140f941c2f811bccde3986f4b37afcb399410f7 (patch)
tree2f1af897e5ecbc499f91f75663700e5636bf0310 /app-editors/jedit
parentVersion bump to 2.01a04. (diff)
downloadhistorical-a140f941c2f811bccde3986f4b37afcb399410f7.tar.gz
historical-a140f941c2f811bccde3986f4b37afcb399410f7.tar.bz2
historical-a140f941c2f811bccde3986f4b37afcb399410f7.zip
Version bumped. Closes #16753.
Diffstat (limited to 'app-editors/jedit')
-rw-r--r--app-editors/jedit/ChangeLog8
-rw-r--r--app-editors/jedit/files/digest-jedit-4.11
-rw-r--r--app-editors/jedit/jedit-4.1.ebuild68
3 files changed, 76 insertions, 1 deletions
diff --git a/app-editors/jedit/ChangeLog b/app-editors/jedit/ChangeLog
index a10322d8d59a..ada673c370e3 100644
--- a/app-editors/jedit/ChangeLog
+++ b/app-editors/jedit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/jedit
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.15 2003/02/12 03:47:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.16 2003/03/03 19:03:38 mholzer Exp $
+
+*jedit-4.1 (03 Mar 2003)
+
+ 03 Mar 2003; Martin Holzer <mholzer@gentoo.org> jedit-4.1.ebuild
+ files/digest-jedit-4.1 ChangeLog :
+ Version bumped. Closes #16753.
*jedit-4.1_pre7 (27 Dec 2002)
diff --git a/app-editors/jedit/files/digest-jedit-4.1 b/app-editors/jedit/files/digest-jedit-4.1
new file mode 100644
index 000000000000..a7e7ba5f875d
--- /dev/null
+++ b/app-editors/jedit/files/digest-jedit-4.1
@@ -0,0 +1 @@
+MD5 93242245baffa3fba02eaa68ec56fea8 jedit41source.tar.gz 1334562
diff --git a/app-editors/jedit/jedit-4.1.ebuild b/app-editors/jedit/jedit-4.1.ebuild
new file mode 100644
index 000000000000..212e65222752
--- /dev/null
+++ b/app-editors/jedit/jedit-4.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.1.ebuild,v 1.1 2003/03/03 19:03:38 mholzer Exp $
+
+MY_PV="41"
+
+DESCRIPTION="Programmer's editor written in Java"
+HOMEPAGE="http://www.jedit.org"
+SRC_URI="mirror://sourceforge/jedit/jedit${MY_PV}source.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE="jikes"
+
+RDEPEND=">=virtual/jdk-1.3"
+DEPEND="${RDEPEND}
+ >=dev-java/ant-1.4.1
+ jikes? ( >=dev-java/jikes-1.17 )"
+
+S="${WORKDIR}/jEdit"
+
+src_compile() {
+ local antflags
+
+ antflags=""
+ if [ `use jikes` ] ; then
+ einfo "Please ignore the following compiler warnings."
+ einfo "Jikes is just too pedantic..."
+ antflags="${antflags} -Dbuild.compiler=jikes"
+ fi
+
+ ant ${antflags} || die "compile problem"
+}
+
+src_install () {
+ dodir /usr/share/jedit
+ dodir /usr/bin
+
+ cp -R jedit.jar jars doc macros modes properties startup ${D}/usr/share/jedit
+ cd ${D}/usr/share/jedit
+ chmod -R u+rw,ug-s,go+u,go-w \
+ jedit.jar jars doc macros modes properties startup
+
+ cat >${D}/usr/share/jedit/jedit.sh <<-EOF
+ #!/bin/bash
+
+ java -jar /usr/share/jedit/jedit.jar $@
+ EOF
+ chmod 755 ${D}/usr/share/jedit/jedit.sh
+
+ ln -s ../share/jedit/jedit.sh ${D}/usr/bin/jedit
+}
+
+pkg_postinst() {
+ touch /usr/share/jedit/jars/.keep
+
+ einfo "The system directory for jEdit plugins is"
+ einfo "/usr/share/jedit/jars"
+}
+
+pkg_postrm() {
+ einfo "jEdit plugins installed into /usr/share/jedit/jars"
+ einfo "(after installation of jEdit itself) haven't been"
+ einfo "removed. To get rid of jEdit completely, you may"
+ einfo "want to run"
+ einfo ""
+ einfo "\trm -r /usr/share/jedit"
+}