summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2002-12-12 15:30:09 +0000
committerHannes Mehnert <hannes@gentoo.org>2002-12-12 15:30:09 +0000
commit5cf002067349a86e1528370304e9b71a0897a002 (patch)
tree8855eb35a4c56f292c8fcaea5b198db1241bda56 /app-editors/kile
parentNew version (diff)
downloadhistorical-5cf002067349a86e1528370304e9b71a0897a002.tar.gz
historical-5cf002067349a86e1528370304e9b71a0897a002.tar.bz2
historical-5cf002067349a86e1528370304e9b71a0897a002.zip
kile-1.31 works without patch with qt which has enabled stl
Diffstat (limited to 'app-editors/kile')
-rw-r--r--app-editors/kile/files/kile-1.31-qt-no-stl.diff60
-rw-r--r--app-editors/kile/kile-1.31.ebuild5
2 files changed, 1 insertions, 64 deletions
diff --git a/app-editors/kile/files/kile-1.31-qt-no-stl.diff b/app-editors/kile/files/kile-1.31-qt-no-stl.diff
deleted file mode 100644
index d05dbe3c8a5c..000000000000
--- a/app-editors/kile/files/kile-1.31-qt-no-stl.diff
+++ /dev/null
@@ -1,60 +0,0 @@
-diff -ur kile/gfe/fileFilter.cpp kile/gfe/fileFilter.cpp
---- kile/gfe/fileFilter.cpp 2002-10-05 16:13:28.000000000 +0300
-+++ kile/gfe/fileFilter.cpp 2002-11-30 13:50:56.000000000 +0200
-@@ -8,6 +8,8 @@
- *********************************************************************/
- using namespace std;
-
-+#define QT_NO_STL
-+
- #include "fileFilter.h"
- #include <qstring.h>
- #include <qfiledlg.h>
-diff -ur kile/gfe/multiFile.cpp kile/gfe/multiFile.cpp
---- kile/gfe/multiFile.cpp 2002-10-05 16:13:51.000000000 +0300
-+++ kile/gfe/multiFile.cpp 2002-11-30 13:50:56.000000000 +0200
-@@ -22,6 +22,8 @@
-
- ------------------------------------------------------------------------*/
-
-+#define QT_NO_STL
-+
- #include "multiFile.h"
- #include <iostream.h>
- #include <klocale.h>
-diff -ur kile/gfe/qplotdialog.cpp kile/gfe/qplotdialog.cpp
---- kile/gfe/qplotdialog.cpp 2002-10-05 16:13:59.000000000 +0300
-+++ kile/gfe/qplotdialog.cpp 2002-11-30 13:50:57.000000000 +0200
-@@ -17,6 +17,8 @@
- * *
- ***************************************************************************/
-
-+#define QT_NO_STL
-+
- #include "qplotdialog.h"
- #include <qlabel.h>
- #include <qmenubar.h>
-diff -ur kile/gfe/qplotmaker.cpp kile/gfe/qplotmaker.cpp
---- kile/gfe/qplotmaker.cpp 2002-10-05 16:14:00.000000000 +0300
-+++ kile/gfe/qplotmaker.cpp 2002-11-30 13:50:57.000000000 +0200
-@@ -17,6 +17,8 @@
- * *
- ***************************************************************************/
-
-+#define QT_NO_STL
-+
- #ifdef HAVE_CONFIG_H
- #include <config.h>
- #endif
-diff -ur kile/gfe/rawGnu.cpp kile/gfe/rawGnu.cpp
---- kile/gfe/rawGnu.cpp 2002-10-05 16:14:02.000000000 +0300
-+++ kile/gfe/rawGnu.cpp 2002-11-30 13:50:58.000000000 +0200
-@@ -23,6 +23,8 @@
-
- *********************************************************************/
-
-+#define QT_NO_STL
-+
- #include "rawGnu.h"
-
- rawGnu::rawGnu
diff --git a/app-editors/kile/kile-1.31.ebuild b/app-editors/kile/kile-1.31.ebuild
index fd9af06d6d89..aef0304545c1 100644
--- a/app-editors/kile/kile-1.31.ebuild
+++ b/app-editors/kile/kile-1.31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-1.31.ebuild,v 1.1 2002/12/12 08:37:37 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-1.31.ebuild,v 1.2 2002/12/12 15:30:09 hannes Exp $
inherit kde-base
need-kde 3
@@ -15,6 +15,3 @@ RDEPEND="${RDEPEND} app-text/tetex"
KEYWORDS="~x86"
LICENSE="GPL-2"
-
-#fix #11173
-PATCHES="$FILESDIR/$P-qt-no-stl.diff"