summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-31 22:12:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-31 22:12:04 +0000
commit4559f7b9013ddd83e1078f81640d3fd153a05e4a (patch)
treef0f56511f8ca4be13b2cea17ed70dc40bbedba2a /app-editors/mp
parentversion bump, first gpg-signed package ;) (diff)
downloadhistorical-4559f7b9013ddd83e1078f81640d3fd153a05e4a.tar.gz
historical-4559f7b9013ddd83e1078f81640d3fd153a05e4a.tar.bz2
historical-4559f7b9013ddd83e1078f81640d3fd153a05e4a.zip
dont install uselss COPYING file and fix other stuff while i'm at it
Diffstat (limited to 'app-editors/mp')
-rw-r--r--app-editors/mp/mp-3.1.9.ebuild20
-rw-r--r--app-editors/mp/mp-3.2.10.ebuild33
-rw-r--r--app-editors/mp/mp-3.2.7.ebuild21
-rw-r--r--app-editors/mp/mp-3.2.8.ebuild33
4 files changed, 56 insertions, 51 deletions
diff --git a/app-editors/mp/mp-3.1.9.ebuild b/app-editors/mp/mp-3.1.9.ebuild
index 3ff2b0f6ced1..e38845a0ead7 100644
--- a/app-editors/mp/mp-3.1.9.ebuild
+++ b/app-editors/mp/mp-3.1.9.ebuild
@@ -1,28 +1,28 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.1.9.ebuild,v 1.10 2004/03/13 22:30:28 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.1.9.ebuild,v 1.11 2004/05/31 22:12:03 vapier Exp $
-DESCRIPTION="mp, the definitive text editor"
-SRC_URI="http://triptico.dhis.org/download/${P}.tar.gz"
+DESCRIPTION="the definitive text editor"
HOMEPAGE="http://www.triptico.com/software/mp.html"
+SRC_URI="http://triptico.dhis.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
+IUSE=""
DEPEND="virtual/glibc
sys-libs/ncurses"
-
RDEPEND="${DEPEND}
dev-lang/perl"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc "
-
src_compile() {
emake || die
}
-src_install () {
+src_install() {
dodir /usr/bin
make install PREFIX=${D}/usr || die
- dodoc AUTHORS ChangeLog COPYING README
+ dodoc AUTHORS ChangeLog README
dohtml README.html doc/mp_api.html
}
diff --git a/app-editors/mp/mp-3.2.10.ebuild b/app-editors/mp/mp-3.2.10.ebuild
index ddcd95891300..83c0e4839727 100644
--- a/app-editors/mp/mp-3.2.10.ebuild
+++ b/app-editors/mp/mp-3.2.10.ebuild
@@ -1,34 +1,37 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.10.ebuild,v 1.2 2004/03/13 22:30:28 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.10.ebuild,v 1.3 2004/05/31 22:12:03 vapier Exp $
-DESCRIPTION="mp, the definitive text editor"
-SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
+DESCRIPTION="the definitive text editor"
HOMEPAGE="http://www.triptico.com/software/mp.html"
+SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="ncurses gtk"
DEPEND="virtual/glibc
ncurses? ( sys-libs/ncurses )
- gtk? ( =x11-libs/gtk+-1.2* )"
-
+ gtk? ( =x11-libs/gtk+-1.2* )
+ !gtk? ( sys-libs/ncurses )"
RDEPEND="${DEPEND}
dev-lang/perl"
-IUSE="ncurses gtk"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc"
src_compile() {
- if [ -n "`use ncurses`" ] && [ -n "`use gtk`" ]; then emake || die;
- elif [ -n "`use ncurses`" ]; then emake mp || die;
- elif [ -n "`use gtk`" ]; then emake gmp || die;
- else die "You need ncurses and/or gtk in your USE variables";
+ if use ncurses && use gtk ; then
+ emake || die
+ elif use ncurses || ! use gtk ; then
+ emake mp || die
+ elif use gtk ; then
+ emake gmp || die
fi
}
-src_install () {
+src_install() {
dodir /usr/bin
make install PREFIX=${D}/usr || die "install failed"
- dodoc AUTHORS Changelog COPYING README
+ dodoc AUTHORS Changelog README
dohtml README.html doc/mp_api.html
insinto /usr/share/pixmaps/
diff --git a/app-editors/mp/mp-3.2.7.ebuild b/app-editors/mp/mp-3.2.7.ebuild
index 471f68461cd8..1d31227050fd 100644
--- a/app-editors/mp/mp-3.2.7.ebuild
+++ b/app-editors/mp/mp-3.2.7.ebuild
@@ -1,29 +1,28 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.7.ebuild,v 1.6 2004/03/13 22:30:28 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.7.ebuild,v 1.7 2004/05/31 22:12:03 vapier Exp $
-DESCRIPTION="mp, the definitive text editor"
-SRC_URI="http://triptico.dhis.org/download/${P}.tar.gz"
+DESCRIPTION="the definitive text editor"
HOMEPAGE="http://www.triptico.com/software/mp.html"
+SRC_URI="http://triptico.dhis.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE=""
DEPEND="virtual/glibc
sys-libs/ncurses"
-
RDEPEND="${DEPEND}
dev-lang/perl"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 sparc"
-
src_compile() {
emake || die
}
-src_install () {
+src_install() {
dodir /usr/bin
make install PREFIX=${D}/usr || die
- dodoc AUTHORS ChangeLog COPYING README
+ dodoc AUTHORS ChangeLog README
dohtml README.html doc/mp_api.html
}
-
diff --git a/app-editors/mp/mp-3.2.8.ebuild b/app-editors/mp/mp-3.2.8.ebuild
index abb966d6e6b8..b8a53367c622 100644
--- a/app-editors/mp/mp-3.2.8.ebuild
+++ b/app-editors/mp/mp-3.2.8.ebuild
@@ -1,33 +1,36 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.8.ebuild,v 1.4 2004/05/28 21:31:04 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.8.ebuild,v 1.5 2004/05/31 22:12:03 vapier Exp $
-DESCRIPTION="mp, the definitive text editor"
-SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
+DESCRIPTION="the definitive text editor"
HOMEPAGE="http://www.triptico.com/software/mp.html"
+SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64"
+IUSE="ncurses gtk"
DEPEND="virtual/glibc
ncurses? ( sys-libs/ncurses )
- gtk? ( =x11-libs/gtk+-1.2* )"
-
+ gtk? ( =x11-libs/gtk+-1.2* )
+ !gtk? ( sys-libs/ncurses )"
RDEPEND="${DEPEND}
dev-lang/perl"
-IUSE="ncurses gtk"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc ~amd64"
src_compile() {
- if [ -n "`use ncurses`" ] && [ -n "`use gtk`" ]; then emake || die;
- elif [ -n "`use ncurses`" ]; then emake mp || die;
- elif [ -n "`use gtk`" ]; then emake gmp || die;
- else die "You need ncurses and/or gtk in your USE variables";
+ if use ncurses && use gtk ; then
+ emake || die
+ elif use ncurses || ! use gtk ; then
+ emake mp || die
+ elif use gtk ; then
+ emake gmp || die
fi
}
-src_install () {
+src_install() {
dodir /usr/bin
make install PREFIX=${D}/usr || die "install failed"
- dodoc AUTHORS Changelog COPYING README
+ dodoc AUTHORS Changelog README
dohtml README.html doc/mp_api.html
}