summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-04-25 15:14:07 +0000
committerJon Portnoy <avenj@gentoo.org>2003-04-25 15:14:07 +0000
commit26d80ef75a1878eab87da48517cc6954882effc4 (patch)
treee2b7aebc70f16c2a85b53869071565b614fc0f95 /app-editors/nano
parentVersion bump, latest nano (diff)
downloadhistorical-26d80ef75a1878eab87da48517cc6954882effc4.tar.gz
historical-26d80ef75a1878eab87da48517cc6954882effc4.tar.bz2
historical-26d80ef75a1878eab87da48517cc6954882effc4.zip
Version bump, latest nano
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/Manifest4
-rw-r--r--app-editors/nano/files/digest-nano-1.2.11
-rw-r--r--app-editors/nano/nano-1.2.1.ebuild47
3 files changed, 50 insertions, 2 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index dd2acbe42dec..c6f3535553a7 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,7 +1,7 @@
-MD5 531a84966f567f5b770623bfd102bb7e ChangeLog 3500
+MD5 3a3538a5630a75b9e4b2bb142a622112 ChangeLog 3609
MD5 0513fe40bbc21ccd9a7c45b652b05ca1 nano-1.0.9-r2.ebuild 953
MD5 049a64cda4b779584b3cdb9b50222b93 nano-1.2.0.ebuild 1126
-MD5 36904ccf660b6a59e9481e2830c0d5bc nano-1.2.1.ebuild 1027
+MD5 f95c01bf3a8298d1b92443fd80d2890f nano-1.2.1.ebuild 1123
MD5 2a5aa3b75ad255cc493411d5a2f43240 files/digest-nano-1.0.9-r2 62
MD5 d82a94a172903fce22d2585733f21bb5 files/digest-nano-1.2.0 62
MD5 2bfbe3942bd67cfddb8f612d87b2e469 files/digest-nano-1.2.1 62
diff --git a/app-editors/nano/files/digest-nano-1.2.1 b/app-editors/nano/files/digest-nano-1.2.1
new file mode 100644
index 000000000000..50c41afc11bb
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-1.2.1
@@ -0,0 +1 @@
+MD5 188d24b9cc4c1041ac58d6b6f7941eb4 nano-1.2.1.tar.gz 911163
diff --git a/app-editors/nano/nano-1.2.1.ebuild b/app-editors/nano/nano-1.2.1.ebuild
new file mode 100644
index 000000000000..8ac63532bd60
--- /dev/null
+++ b/app-editors/nano/nano-1.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.2.1.ebuild,v 1.1 2003/04/25 15:13:53 avenj Exp $
+
+MY_P="${PN}-${PV/_}"
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+SRC_URI="http://www.nano-editor.org/dist/v1.2/${MY_P}.tar.gz"
+HOMEPAGE="http://www.nano-editor.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+IUSE="nls build slang spell"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/editor"
+
+src_compile() {
+ use build && myconf="${myconf} --disable-wrapping-as-root"
+
+ econf \
+ --bindir=/bin \
+ --enable-color \
+ --enable-multibuffer \
+ --enable-nanorc \
+ `use_enable spell` \
+ `use_enable nls` \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ use build \
+ && rm -rf ${D}/usr/share \
+ || dodoc ChangeLog README nanorc.sample AUTHORS BUGS NEWS TODO \
+ && dohtml *.html
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}