summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2002-06-26 17:32:50 +0000
committerMark Guertin <gerk@gentoo.org>2002-06-26 17:32:50 +0000
commit9e670fa948cd0a56fefb0813b30a083586a2e9f0 (patch)
treeaefa3ec1efbe921fe9c47935ad6ad424f54fec13 /app-editors/xemacs
parentUpdated to most recent version. (diff)
downloadhistorical-9e670fa948cd0a56fefb0813b30a083586a2e9f0.tar.gz
historical-9e670fa948cd0a56fefb0813b30a083586a2e9f0.tar.bz2
historical-9e670fa948cd0a56fefb0813b30a083586a2e9f0.zip
added ppc patch to close bug 4067
Diffstat (limited to 'app-editors/xemacs')
-rw-r--r--app-editors/xemacs/files/xemacs-21.4.8-ppc.diff23
-rw-r--r--app-editors/xemacs/xemacs-21.4.8-r1.ebuild7
2 files changed, 29 insertions, 1 deletions
diff --git a/app-editors/xemacs/files/xemacs-21.4.8-ppc.diff b/app-editors/xemacs/files/xemacs-21.4.8-ppc.diff
new file mode 100644
index 000000000000..5ec39a2a9adf
--- /dev/null
+++ b/app-editors/xemacs/files/xemacs-21.4.8-ppc.diff
@@ -0,0 +1,23 @@
+--- configure.in.orig Sun Jun 23 13:25:00 2002
++++ configure.in Sun Jun 23 13:25:20 2002
+@@ -2538,7 +2538,7 @@
+ AC_MSG_CHECKING(for \"-z nocombreloc\" linker flag)
+ case "`ld --help 2>&1`" in
+ *-z\ nocombreloc* ) AC_MSG_RESULT(yes)
+- XE_PREPEND(-z nocombreloc, ld_switch_site) ;;
++ XE_PREPEND(-Wl,-z,nocombreloc, ld_switch_site) ;;
+ *) AC_MSG_RESULT(no) ;;
+ esac
+ fi
+--- configure.orig Sun Jun 23 13:25:04 2002
++++ configure Sun Jun 23 13:25:56 2002
+@@ -5010,7 +5010,7 @@
+ echo "configure:5011: checking for \"-z nocombreloc\" linker flag" >&5
+ case "`ld --help 2>&1`" in
+ *-z\ nocombreloc* ) echo "$ac_t""yes" 1>&6
+- ld_switch_site="-z nocombreloc $ld_switch_site" && if test "$extra_verbose" = "yes"; then echo " Prepending \"-z nocombreloc\" to \$ld_switch_site"; fi ;;
++ ld_switch_site="-Wl,-z,nocombreloc $ld_switch_site" && if test "$extra_verbose" = "yes"; then echo " Prepending \"-Wl,-z,nocombreloc\" to \$ld_switch_site"; fi ;;
+ *) echo "$ac_t""no" 1>&6 ;;
+ esac
+ fi
+
diff --git a/app-editors/xemacs/xemacs-21.4.8-r1.ebuild b/app-editors/xemacs/xemacs-21.4.8-r1.ebuild
index 1bb4dfc4723a..1edde982cdc8 100644
--- a/app-editors/xemacs/xemacs-21.4.8-r1.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.8-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Matthew Kennedy <mkennedy@gentoo.org>
# Author: Geert Bevin <gbevin@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.8-r1.ebuild,v 1.1 2002/05/31 23:42:05 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.8-r1.ebuild,v 1.2 2002/06/26 17:32:50 gerk Exp $
# this is just TEMPORARY until we can get to the core of the problem
SANDBOX_DISABLED="1"
@@ -54,6 +54,11 @@ src_unpack() {
unpack ${P}.tar.gz
cd ${S}
patch -p0 <${FILESDIR}/emodules.info-21.4.8-gentoo.patch
+
+ if [ ${ARCH} = "ppc" ] ; then
+ patch -p0 < ${FILESDIR}/${P}-ppc.diff
+ fi
+
}
src_compile() {