summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-18 19:07:51 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-18 19:07:51 +0000
commit9f5e2f01567e2c426e5bad711d6b5436de517284 (patch)
treec989d64d3d034ee04e19fed937ef1f33b1f095b0 /app-editors
parentVersion bump to 0.7.0. Closes #60757. (diff)
downloadhistorical-9f5e2f01567e2c426e5bad711d6b5436de517284.tar.gz
historical-9f5e2f01567e2c426e5bad711d6b5436de517284.tar.bz2
historical-9f5e2f01567e2c426e5bad711d6b5436de517284.zip
add patch from upstream to fix nanorc tabbing
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/Manifest9
-rw-r--r--app-editors/nano/files/1.3.4-nanobrack.patch15
-rw-r--r--app-editors/nano/nano-1.3.4.ebuild3
3 files changed, 22 insertions, 5 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index 6f67486a8f11..714f8c67bcf5 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -6,7 +6,7 @@ MD5 b297797b490f7c6ca8d5f40f2d6347cc metadata.xml 1015
MD5 285b5a2576ec35dc904ed4130a09d9d4 nano-1.2.4.ebuild 1397
MD5 f84b986a9c5d94eca042432d72532575 nano-1.3.2-r1.ebuild 1632
MD5 833d96e7eabcf3ccab5e902aad581692 nano-1.3.3-r1.ebuild 1719
-MD5 a1d1a0c91be093a52f72d8a0aa676e87 nano-1.3.4.ebuild 1535
+MD5 1a23a78d77f30bb45cef3857c3683fa3 nano-1.3.4.ebuild 1577
MD5 f4ea39140349611e991db4706e69e393 files/1.3-nanopermsfix.patch 556
MD5 0726e5da362828bb5b1a73e5bd944849 files/1.3.2-nomac.patch 553
MD5 740ee1dff171c4230019d04c3fcac1d3 files/1.3.2-wsconvert.patch 6900
@@ -23,10 +23,11 @@ MD5 9ecacdb9e41a6ddb3200113238ca4b2b files/nanorc-sh 646
MD5 52fb99e2245a74eef08cdd6a00b5cf97 files/1.3.3-debug-printf-fix.patch 508
MD5 95e2a2065a0c2ff580dcf645fba2de1e files/digest-nano-1.3.4 62
MD5 4cf6c77ed7c28d94c8de44d8318176c3 files/1.3.4-nomac.patch 511
+MD5 c3684059e73752ce1f114e768ecbaa2b files/1.3.4-nanobrack.patch 557
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFBItaEHTu7gpaalycRAhvwAJ4kpZ4EhHAhGTSqqVICFLs1m5xVLgCgsfTM
-nfKsUYV+UARx2axHHf9hrm0=
-=OcgQ
+iD8DBQFBI6knHTu7gpaalycRAgCsAKC6qCPs8k48ndAx1uwM9OA+1BwvmACeKx6C
+GW+FAUgN9ehuVzSy+1cjpeg=
+=T7IL
-----END PGP SIGNATURE-----
diff --git a/app-editors/nano/files/1.3.4-nanobrack.patch b/app-editors/nano/files/1.3.4-nanobrack.patch
new file mode 100644
index 000000000000..606f0580bc04
--- /dev/null
+++ b/app-editors/nano/files/1.3.4-nanobrack.patch
@@ -0,0 +1,15 @@
+diff -ur nano-1.3.4/src/rcfile.c nano-1.3.4-fixed/src/rcfile.c
+--- nano-1.3.4/src/rcfile.c 2004-08-18 05:31:26.000000000 +0200
++++ nano-1.3.4-fixed/src/rcfile.c 2004-08-18 18:01:24.000000000 +0200
+@@ -611,9 +611,10 @@
+ else
+ #endif
+ if (strcasecmp(rcopts[i].name, "tabsize") == 0) {
+- if (!parse_num(option, &tabsize) || tabsize <= 0)
++ if (!parse_num(option, &tabsize) || tabsize <= 0) {
+ rcfile_error(N_("Requested tab size %s invalid"), option);
+ tabsize = -1;
++ }
+ }
+ } else
+ SET(rcopts[i].flag);
diff --git a/app-editors/nano/nano-1.3.4.ebuild b/app-editors/nano/nano-1.3.4.ebuild
index 20ce001d2815..a59776987978 100644
--- a/app-editors/nano/nano-1.3.4.ebuild
+++ b/app-editors/nano/nano-1.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.4.ebuild,v 1.1 2004/08/18 04:09:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.4.ebuild,v 1.2 2004/08/18 19:07:51 vapier Exp $
inherit eutils
@@ -24,6 +24,7 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/${PV}-nanobrack.patch
use nomac && epatch ${FILESDIR}/${PV}-nomac.patch
}