summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Maitin-Shepard <jbms@gentoo.org>2004-01-18 17:47:46 +0000
committerJeremy Maitin-Shepard <jbms@gentoo.org>2004-01-18 17:47:46 +0000
commite4a38a4cbc8fba40f432c2ab6bc30e326b9ad3f6 (patch)
tree22740c5848010597aa375eaebc3ada500c2f0c4f /app-emacs/haskell-mode/haskell-mode-1.44-r1.ebuild
parentRemoved certain customizations from the site file. (diff)
downloadhistorical-e4a38a4cbc8fba40f432c2ab6bc30e326b9ad3f6.tar.gz
historical-e4a38a4cbc8fba40f432c2ab6bc30e326b9ad3f6.tar.bz2
historical-e4a38a4cbc8fba40f432c2ab6bc30e326b9ad3f6.zip
Revision bump.
Diffstat (limited to 'app-emacs/haskell-mode/haskell-mode-1.44-r1.ebuild')
-rw-r--r--app-emacs/haskell-mode/haskell-mode-1.44-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/haskell-mode/haskell-mode-1.44-r1.ebuild b/app-emacs/haskell-mode/haskell-mode-1.44-r1.ebuild
new file mode 100644
index 000000000000..643a6e9f5cb7
--- /dev/null
+++ b/app-emacs/haskell-mode/haskell-mode-1.44-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-1.44-r1.ebuild,v 1.1 2004/01/18 17:47:39 jbms Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
+HOMEPAGE="http://www.haskell.org/haskell-mode/"
+SRC_URI="http://www.haskell.org/haskell-mode/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${P}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ dohtml *.html *.hs
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+ einfo "See /usr/share/doc/${P}/html/installation-guide.html"
+}