summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commitce2fa6f6c4951c11ef10627b81603f112c0b62a8 (patch)
tree3f697c6e444c56ff856d2d5e5300c606d2462d12 /app-emacs/junkbust
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadhistorical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.gz
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.bz2
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/junkbust')
-rw-r--r--app-emacs/junkbust/ChangeLog11
-rw-r--r--app-emacs/junkbust/files/50junkbust-gentoo.el8
-rw-r--r--app-emacs/junkbust/files/digest-junkbust-0.81
-rw-r--r--app-emacs/junkbust/junkbust-0.8.ebuild40
4 files changed, 60 insertions, 0 deletions
diff --git a/app-emacs/junkbust/ChangeLog b/app-emacs/junkbust/ChangeLog
new file mode 100644
index 000000000000..d392fe7767dc
--- /dev/null
+++ b/app-emacs/junkbust/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/junkbust
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/junkbust/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*junkbust-0.8 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ junkbust-0.8.ebuild, files/50junkbust-gentoo.el,
+ files/digest-junkbust-0.8 :
+
+ Initial import.
diff --git a/app-emacs/junkbust/files/50junkbust-gentoo.el b/app-emacs/junkbust/files/50junkbust-gentoo.el
new file mode 100644
index 000000000000..6275c65e6576
--- /dev/null
+++ b/app-emacs/junkbust/files/50junkbust-gentoo.el
@@ -0,0 +1,8 @@
+
+;;; junkbust site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'junkbust)
+(global-set-key [f6] 'junkbust-block-url-edit-rule)
+(global-set-key [S-f6] 'junkbust-block-url-edit-url)
+(global-set-key [C-f6] 'junkbust-blocklist-file-visit)
diff --git a/app-emacs/junkbust/files/digest-junkbust-0.8 b/app-emacs/junkbust/files/digest-junkbust-0.8
new file mode 100644
index 000000000000..155d3e820cbf
--- /dev/null
+++ b/app-emacs/junkbust/files/digest-junkbust-0.8
@@ -0,0 +1 @@
+MD5 88252c3fd81ac696e7c4e1d69f0d4427 junkbust-0.8.tar.bz2 10071
diff --git a/app-emacs/junkbust/junkbust-0.8.ebuild b/app-emacs/junkbust/junkbust-0.8.ebuild
new file mode 100644
index 000000000000..ff426394ef9b
--- /dev/null
+++ b/app-emacs/junkbust/junkbust-0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/junkbust/junkbust-0.8.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="An Emacs add-on for maintaining a personal configuration of the Junkbuster filtering HTTP proxy"
+HOMEPAGE="http://www.neilvandyke.org/junkbust-emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+RDEPEND="${DEPEND}
+ net-www/junkbuster"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50junkbust-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/junkbust.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}