summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commitce2fa6f6c4951c11ef10627b81603f112c0b62a8 (patch)
tree3f697c6e444c56ff856d2d5e5300c606d2462d12 /app-emacs/vm/vm-7.07-r1.ebuild
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadhistorical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.gz
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.bz2
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/vm/vm-7.07-r1.ebuild')
-rw-r--r--app-emacs/vm/vm-7.07-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-emacs/vm/vm-7.07-r1.ebuild b/app-emacs/vm/vm-7.07-r1.ebuild
new file mode 100644
index 000000000000..26950a961c48
--- /dev/null
+++ b/app-emacs/vm/vm-7.07-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/vm-7.07-r1.ebuild,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="An emacs major mode for reading and writing e-mail with support for GPG and MIME."
+SRC_URI="ftp://ftp.uni-mainz.de/pub/software/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.wonderworks.com/vm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ virtual/emacs"
+
+S=${WORKDIR}/${P}
+
+SITEFILE=50vm-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 <${FILESDIR}/vm-direntry-fix-gentoo.patch || die
+}
+
+src_compile() {
+ make prefix=${D}/usr \
+ INFODIR=${D}/usr/share/info \
+ LISPDIR=${D}/${SITELISP}/vm \
+ PIXMAPDIR=${D}/${SITELISP}/etc/${PN} \
+ all
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ INFODIR=${D}/usr/share/info \
+ LISPDIR=${D}/${SITELISP}/vm \
+ PIXMAPDIR=${D}/${SITELISP}/etc/${PN} \
+ install || die
+ elisp-install ${PN} *.el
+ elisp-site-file-install ${FILESDIR}/50vm-gentoo.el
+ dodoc COPYING README
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}