summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-09-12 01:35:58 +0000
committerMamoru Komachi <usata@gentoo.org>2003-09-12 01:35:58 +0000
commit57f35ea67db61800b78ebc19a433b2063689bd84 (patch)
treee3db62b8869ffdb4d2c3012cf94d793fa5f79b0e /app-emacs/yatex
parentnew ebuild (diff)
downloadhistorical-57f35ea67db61800b78ebc19a433b2063689bd84.tar.gz
historical-57f35ea67db61800b78ebc19a433b2063689bd84.tar.bz2
historical-57f35ea67db61800b78ebc19a433b2063689bd84.zip
new ebuild
Diffstat (limited to 'app-emacs/yatex')
-rw-r--r--app-emacs/yatex/Manifest4
-rw-r--r--app-emacs/yatex/metadata.xml17
-rw-r--r--app-emacs/yatex/yatex-1.71.ebuild55
3 files changed, 75 insertions, 1 deletions
diff --git a/app-emacs/yatex/Manifest b/app-emacs/yatex/Manifest
index 7a47df424e31..4671c83002e4 100644
--- a/app-emacs/yatex/Manifest
+++ b/app-emacs/yatex/Manifest
@@ -1,4 +1,6 @@
-MD5 4040346bfbcf290d03e60d8b1648cc5e yatex-1.71.ebuild 1140
+MD5 28a8b4dcfef35fc7d6e9896514498cbe yatex-1.71.ebuild 1140
+MD5 73b8438632d3ec40a9f16e142f48b43a metadata.xml 646
+MD5 f8cbf24513f0e3152fef975527411071 ChangeLog 411
MD5 25efbe9871a1b36669916928339fa1d8 files/50yatex-gentoo.el 532
MD5 920ec551a0bac37b6e5b1142af2df6d0 files/yatex-1.71-gentoo.diff 2634
MD5 cea9c48d2281fc63126df7a0dbb1c43b files/digest-yatex-1.71 61
diff --git a/app-emacs/yatex/metadata.xml b/app-emacs/yatex/metadata.xml
new file mode 100644
index 000000000000..f747d206430d
--- /dev/null
+++ b/app-emacs/yatex/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+<herd>emacs</herd>
+<maintainer>
+ <email>usata@gentoo.org</email>
+ <name>Mamoru KOMACHI</name>
+</maintainer>
+<longdescription>
+YaTeX is an intelligent, acquisitive and integrated package which
+reduces your efforts of composing LaTeX source on Emacs. And yahtml is
+the honest and bright YaTeX-compatible major-mode package for writing
+HTML. If you have noticed the power of YaTeX, you can drive yahtml
+over the HTML files quickly and steadily. And vice versa, of course.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emacs/yatex/yatex-1.71.ebuild b/app-emacs/yatex/yatex-1.71.ebuild
new file mode 100644
index 000000000000..61d4293701a0
--- /dev/null
+++ b/app-emacs/yatex/yatex-1.71.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yatex/yatex-1.71.ebuild,v 1.1 2003/09/12 01:35:54 usata Exp $
+
+inherit elisp
+
+IUSE="cjk"
+
+DESCRIPTION="YaTeX: Yet Another TeX mode for Emacs"
+HOMEPAGE="http://www.yatex.org/"
+SRC_URI="http://www.yatex.org/${P/-/}.tar.gz"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/emacs
+ cjk? app-i18n/nkf"
+RDEPEND="virtual/emacs"
+
+S=${WORKDIR}/${P/-/}
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+
+ emacs -q -batch -l ./yatexlib.el -e batch-byte-compile *.el || die
+ cd docs
+ mv yatexe yatex.info
+ mv yahtmle yahtml.info
+ if [ -n "`use cjk`" ] ; then
+ nkf -e yatexj > yatex-ja.info
+ nkf -e yahtmlj > yahtml-ja.info
+ fi
+}
+
+src_install() {
+
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/50yatex-gentoo.el
+
+ dodoc help/YATEXHLP.eng docs/*.eng
+ if [ -n "`use cjk`" ] ; then
+ dodoc 00readme install help/YATEXHLP.jp
+ dodoc docs/{htmlqa,qanda} docs/*.doc
+ fi
+ for i in docs/*.info; do
+ doinfo ${i}
+ done
+}