summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-14 09:04:36 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-14 09:04:36 +0000
commitd5e15a89a3ecb1407064c9736a9850f612905754 (patch)
tree4a7699d88e013b6ee6f0f4edaf88f08be18ecc70 /app-emulation/cedega
parentKEYWORD update (diff)
downloadhistorical-d5e15a89a3ecb1407064c9736a9850f612905754.tar.gz
historical-d5e15a89a3ecb1407064c9736a9850f612905754.tar.bz2
historical-d5e15a89a3ecb1407064c9736a9850f612905754.zip
ver bump #59989
Diffstat (limited to 'app-emulation/cedega')
-rw-r--r--app-emulation/cedega/ChangeLog7
-rw-r--r--app-emulation/cedega/Manifest14
-rw-r--r--app-emulation/cedega/cedega-4.0.1.ebuild56
-rw-r--r--app-emulation/cedega/files/digest-cedega-4.0.11
4 files changed, 76 insertions, 2 deletions
diff --git a/app-emulation/cedega/ChangeLog b/app-emulation/cedega/ChangeLog
index f4c7e7706dad..c764fcf88ff7 100644
--- a/app-emulation/cedega/ChangeLog
+++ b/app-emulation/cedega/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/cedega
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.4 2004/07/26 12:55:46 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.5 2004/08/14 09:04:36 vapier Exp $
+
+*cedega-4.0.1 (14 Aug 2004)
+
+ 14 Aug 2004; Mike Frysinger <vapier@gentoo.org> +cedega-4.0.1.ebuild:
+ Version bump #59989 by John5788.
26 Jul 2004; Danny van Dyk <kugelfang@gentoo.org> cedega-4.0.ebuild:
Marked ~amd64.
diff --git a/app-emulation/cedega/Manifest b/app-emulation/cedega/Manifest
index 831bd4da033a..0b61f0bd02c2 100644
--- a/app-emulation/cedega/Manifest
+++ b/app-emulation/cedega/Manifest
@@ -1,4 +1,16 @@
-MD5 c9d9be4b7e707026164b50d47af19ed6 ChangeLog 505
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 d5de2e15a3770dc3a9b91bba46acb141 ChangeLog 639
MD5 004baf5ffeb9ec3444feabac0e68eb1f cedega-4.0.ebuild 1962
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
+MD5 b5fa26dbd207c3907d88160c3bba2457 cedega-4.0.1.ebuild 1962
MD5 7eccc393a8bb2164b799f66650fc2b54 files/digest-cedega-4.0 67
+MD5 c32df3be597bc84f86c228b63bec407d files/digest-cedega-4.0.1 69
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.8 (GNU/Linux)
+
+iD8DBQFBHdYRHTu7gpaalycRAl1gAJ9mvUsXjFVA8O7csf2fDt3fb/ROCwCgvfu+
+wgJ2JVjuviY/+vx7ouToCpE=
+=38+0
+-----END PGP SIGNATURE-----
diff --git a/app-emulation/cedega/cedega-4.0.1.ebuild b/app-emulation/cedega/cedega-4.0.1.ebuild
new file mode 100644
index 000000000000..38568123d86e
--- /dev/null
+++ b/app-emulation/cedega/cedega-4.0.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-4.0.1.ebuild,v 1.1 2004/08/14 09:04:36 vapier Exp $
+
+MY_P="cedega_${PV}-1.i386"
+DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="~x86 ~amd64"
+IUSE="cups opengl"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ !app-emulation/winex
+ !app-emulation/winex-transgaming"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Cedega archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo ""
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install() {
+ mv ${WORKDIR}/usr ${D}
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/cedega to start cedega as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the cedega wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/cedega:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to"
+ einfo "/etc/modules.autoload.d/<your kernel version>"
+}
diff --git a/app-emulation/cedega/files/digest-cedega-4.0.1 b/app-emulation/cedega/files/digest-cedega-4.0.1
new file mode 100644
index 000000000000..9feb103b57d2
--- /dev/null
+++ b/app-emulation/cedega/files/digest-cedega-4.0.1
@@ -0,0 +1 @@
+MD5 30b245977dfa50e7d1adadd9ad4822d2 cedega_4.0.1-1.i386.tgz 7384181