summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-10-20 07:24:08 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-10-20 07:24:08 +0000
commit242b9aa3b9eababe12be0f5d50903d931101199c (patch)
tree02154826d784e6bc1048df8d2da6736f4c4b454a /app-emulation/dynamips/files
parentWrite better reason for removal. (diff)
downloadhistorical-242b9aa3b9eababe12be0f5d50903d931101199c.tar.gz
historical-242b9aa3b9eababe12be0f5d50903d931101199c.tar.bz2
historical-242b9aa3b9eababe12be0f5d50903d931101199c.zip
Version bump, drop old
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0x1F357D42
Diffstat (limited to 'app-emulation/dynamips/files')
-rw-r--r--app-emulation/dynamips/files/dynamips-0.2.10-makefile.patch52
-rw-r--r--app-emulation/dynamips/files/dynamips-0.2.8_rc3-makefile.patch83
2 files changed, 52 insertions, 83 deletions
diff --git a/app-emulation/dynamips/files/dynamips-0.2.10-makefile.patch b/app-emulation/dynamips/files/dynamips-0.2.10-makefile.patch
new file mode 100644
index 000000000000..89f22c2b6244
--- /dev/null
+++ b/app-emulation/dynamips/files/dynamips-0.2.10-makefile.patch
@@ -0,0 +1,52 @@
+--- stable/Makefile.orig 2013-10-20 11:17:50.242929187 +0400
++++ stable/Makefile 2013-10-20 11:19:19.395936956 +0400
+@@ -3,12 +3,7 @@
+
+ # Replace x86 by amd64 for a build on x86_64.
+ # Use "nojit" for architectures that are not x86 or x86_64.
+-DYNAMIPS_ARCH?=x86
+-#DYNAMIPS_ARCH?=amd64
+-
+-ifeq ($(DYNAMIPS_ARCH),ppc32)
+-DYNAMIPS_ARCH=x86
+-endif
++DYNAMIPS_ARCH?=nojit
+
+ # Get include files from the current directory and from the common directory
+ INCLUDE+=-I. -I../common
+@@ -47,7 +42,7 @@
+ PPC32_ARCH_INC_FILE=\"ppc32_$(DYNAMIPS_ARCH)_trans.h\"
+ OSNAME=unknown
+
+-CFLAGS+= $(INCLUDE) -Wall -O2 -fomit-frame-pointer \
++CFLAGS+= $(INCLUDE) -Wall \
+ -DJIT_ARCH=\"$(DYNAMIPS_ARCH)\" -DJIT_CPU=CPU_$(DYNAMIPS_ARCH) \
+ -DMIPS64_ARCH_INC_FILE=$(MIPS64_ARCH_INC_FILE) \
+ -DPPC32_ARCH_INC_FILE=$(PPC32_ARCH_INC_FILE) \
+@@ -72,7 +67,7 @@
+ # PCAP_LIB=-lpcap
+ OSNAME=Linux
+ CFLAGS+=-I/usr/include -I. $(PTHREAD_CFLAGS)
+- LIBS=-L/usr/lib -L. -ldl -lrt -luuid -lelf $(PTHREAD_LIBS)
++ LIBS=$(LDFLAGS) -L/usr/lib -L. -ldl -lrt -luuid -lelf $(PTHREAD_LIBS)
+ DESTDIR=/usr
+ else
+ ifeq ($(shell uname -s), Darwin)
+@@ -274,7 +269,7 @@
+
+ asmdefs$(BIN_EXT): asmdefs.c mips64.h
+ @echo "Linking $@"
+- @$(CC) -Wall $(CFLAGS) -o $@ asmdefs.c
++ @$(CC) -Wall $(CFLAGS) $(LDFLAGS) -o $@ asmdefs.c
+
+ asmdefs.h: asmdefs$(BIN_EXT)
+ @echo "Building assembly definitions header file"
+@@ -282,7 +277,7 @@
+
+ nvram_export$(BIN_EXT): nvram_export.o fs_nvram.o
+ @echo "Linking $@"
+- @$(CC) -Wall $(CFLAGS) $(INCLUDE) -o $@ nvram_export.o fs_nvram.o
++ @$(CC) -Wall $(CFLAGS) $(LDFLAGS) $(INCLUDE) -o $@ nvram_export.o fs_nvram.o
+
+ install: $(PROG) nvram_export$(BIN_EXT)
+ @echo "Installing"
diff --git a/app-emulation/dynamips/files/dynamips-0.2.8_rc3-makefile.patch b/app-emulation/dynamips/files/dynamips-0.2.8_rc3-makefile.patch
deleted file mode 100644
index ad74cfa25007..000000000000
--- a/app-emulation/dynamips/files/dynamips-0.2.8_rc3-makefile.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-diff -uNr dynamips-0.2.8-RC3-community.ORIG//Makefile dynamips-0.2.8-RC3-community/Makefile
---- dynamips-0.2.8-RC3-community.ORIG//Makefile 2011-05-17 10:12:54.777002689 +0100
-+++ dynamips-0.2.8-RC3-community/Makefile 2011-05-17 10:13:22.408002704 +0100
-@@ -5,7 +5,7 @@
- # - Use "amd64" for a build on x86_64 (64-bits)
- # - Use "ppc32" for a build on powerpc (32-bits)
- # - Use "nojit" for unsupported architectures.
--export DYNAMIPS_ARCH?=x86
-+export DYNAMIPS_ARCH?=nojit
-
- # Do you want to use lib (for 32 bit compiling) or lib64
- export DYNAMIPS_LIB?=lib
-diff -uNr dynamips-0.2.8-RC3-community.ORIG//stable/Makefile dynamips-0.2.8-RC3-community/stable/Makefile
---- dynamips-0.2.8-RC3-community.ORIG//stable/Makefile 2011-05-17 10:12:54.776002689 +0100
-+++ dynamips-0.2.8-RC3-community/stable/Makefile 2011-05-17 10:15:53.143002781 +0100
-@@ -3,13 +3,9 @@
-
- # Replace x86 by amd64 for a build on x86_64.
- # Use "nojit" for architectures that are not x86 or x86_64.
--DYNAMIPS_ARCH?=x86
-+DYNAMIPS_ARCH?=nojit
- #DYNAMIPS_ARCH?=amd64
-
--ifeq ($(DYNAMIPS_ARCH),ppc32)
--DYNAMIPS_ARCH=x86
--endif
--
- # Do you want to use lib (for 32 bit compiling) or lib64
- DYNAMIPS_LIB?=lib
-
-@@ -51,7 +47,7 @@
- PPC32_ARCH_INC_FILE=\"ppc32_$(DYNAMIPS_ARCH)_trans.h\"
- OSNAME=unknown
-
--CFLAGS+= $(INCLUDE) -Wall -O3 -fomit-frame-pointer \
-+CFLAGS+= $(INCLUDE) -Wall -Wno-strict-aliasing \
- -DJIT_ARCH=\"$(DYNAMIPS_ARCH)\" -DJIT_CPU=CPU_$(DYNAMIPS_ARCH) \
- -DMIPS64_ARCH_INC_FILE=$(MIPS64_ARCH_INC_FILE) \
- -DPPC32_ARCH_INC_FILE=$(PPC32_ARCH_INC_FILE) \
-@@ -247,19 +243,19 @@
- $(PROG): mips64_microcode_dump.inc ppc32_microcode_dump.inc \
- $(LEX_C) $(C_OBJS) $(A_OBJS)
- @echo "Linking $@"
-- @$(CC) $(CFLAGS) -o $@ $(C_OBJS) $(A_OBJS) $(LIBS)
-+ @$(CC) -Wall $(LDFLAGS) $(CFLAGS) -o $@ $(C_OBJS) $(A_OBJS) $(LIBS)
-
- udp_send$(BIN_EXT): udp_send.c net.c crc.c
- @echo "Linking $@"
-- @$(CC) -Wall $(CFLAGS) -o $@ udp_send.c net.c crc.c $(LIBS)
-+ @$(CC) -Wall $(LDFLAGS) $(CFLAGS) -o $@ udp_send.c net.c crc.c $(LIBS)
-
- udp_recv$(BIN_EXT): udp_recv.c net.c crc.c
- @echo "Linking $@"
-- @$(CC) -Wall $(CFLAGS) -o $@ udp_recv.c net.c crc.c $(LIBS)
-+ @$(CC) -Wall $(LDFLAGS) $(CFLAGS) -o $@ udp_recv.c net.c crc.c $(LIBS)
-
- rom2c$(BIN_EXT): rom2c.c
- @echo "Linking $@"
-- @$(CC) -Wall $(CFLAGS) -o $@ $< $(LIBS)
-+ @$(CC) -Wall $(LDFLAGS) $(CFLAGS) -o $@ $< $(LIBS)
-
- mips64_microcode_dump.inc: rom2c$(BIN_EXT) mips64_microcode
- @./rom2c mips64_microcode mips64_microcode_dump.inc 0xbfc00000
-@@ -269,15 +265,17 @@
-
- asmdefs$(BIN_EXT): asmdefs.c mips64.h
- @echo "Linking $@"
-- @$(CC) -Wall $(CFLAGS) -o $@ asmdefs.c
-+ @$(CC) -Wall $(LDFLAGS) $(CFLAGS) -o $@ asmdefs.c
-
- asmdefs.h: asmdefs$(BIN_EXT)
- @echo "Building assembly definitions header file"
- @./asmdefs
-
-+dev_rom.o: mips64_microcode_dump.inc ppc32_microcode_dump.inc
-+
- nvram_export$(BIN_EXT): nvram_export.c
- @echo "Linking $@"
-- @$(CC) -Wall $(CFLAGS) $(INCLUDE) -o $@ $<
-+ @$(CC) $(LDFLAGS) -Wall $(CFLAGS) $(INCLUDE) -o $@ ../common/nvram_export.c
-
- install: $(PROG) nvram_export
- @echo "Installing"