summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-09-09 14:04:23 +0000
committerMichael Januszewski <spock@gentoo.org>2004-09-09 14:04:23 +0000
commit79b9d82927876cca999205584916d554ec3819c2 (patch)
tree765eb692a0c3d8c36c9fdeb8aeaa21852b8d9225 /app-emulation/uade
parentAdded beepmp USE flag for app-emulation/uade. (diff)
downloadhistorical-79b9d82927876cca999205584916d554ec3819c2.tar.gz
historical-79b9d82927876cca999205584916d554ec3819c2.tar.bz2
historical-79b9d82927876cca999205584916d554ec3819c2.zip
Added support for the Beep Media Player (beepmp USE flag). Closes bug #62463.
Diffstat (limited to 'app-emulation/uade')
-rw-r--r--app-emulation/uade/ChangeLog8
-rw-r--r--app-emulation/uade/Manifest17
-rw-r--r--app-emulation/uade/files/digest-uade-0.91-r11
-rw-r--r--app-emulation/uade/files/uade-0.91-bmp-fix.patch29
-rw-r--r--app-emulation/uade/uade-0.91-r1.ebuild62
5 files changed, 114 insertions, 3 deletions
diff --git a/app-emulation/uade/ChangeLog b/app-emulation/uade/ChangeLog
index 7a742a9cde0e..35fdd34d9aaf 100644
--- a/app-emulation/uade/ChangeLog
+++ b/app-emulation/uade/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/uade
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.14 2004/09/01 06:26:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.15 2004/09/09 14:04:23 spock Exp $
+
+*uade-0.91-r1 (09 Sep 2004)
+
+ 09 Sep 2004; Michal Januszewski <spock@gentoo.org>
+ +files/uade-0.91-bmp-fix.patch, +uade-0.91-r1.ebuild:
+ Added support for the Beep Media Player (beepmp USE flag). Closes bug #62463.
31 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org> uade-0.91.ebuild:
tidy a bit
diff --git a/app-emulation/uade/Manifest b/app-emulation/uade/Manifest
index f8795e5569fc..f53237c556dc 100644
--- a/app-emulation/uade/Manifest
+++ b/app-emulation/uade/Manifest
@@ -1,6 +1,19 @@
-MD5 62ba3d04ae1794c48a73c13bba1cb43b ChangeLog 1864
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 2290dc4035301212d0df7b5b348b7a50 uade-0.91.ebuild 1540
+MD5 ae6376aa5e84e1e09c1419e25aac648e uade-0.91-r1.ebuild 1693
MD5 5e0e693bfb3862a705778fa4518184c1 uade-0.81.ebuild 1594
+MD5 7533c6c892c3f7a61aa79930c2e03217 ChangeLog 2079
MD5 a715d9de7a6423e88a804a562c2220a9 metadata.xml 219
-MD5 2290dc4035301212d0df7b5b348b7a50 uade-0.91.ebuild 1540
+MD5 9e378de0863e2aaa880f4351dc743cb3 files/uade-0.91-bmp-fix.patch 1111
MD5 4df754504fa84b727b0d21eccfcbf1c5 files/digest-uade-0.81 63
MD5 1f90b1c9ed54563fc4371e3976a2b4bb files/digest-uade-0.91 63
+MD5 1f90b1c9ed54563fc4371e3976a2b4bb files/digest-uade-0.91-r1 63
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBQGL0chej4aZK9/cRAlcaAJ9JHbDJ950S0LZaC+Xt7pNElWfxLQCcDTS1
+5p1cQvesAF6S1tqrPaGpxjI=
+=Wtw0
+-----END PGP SIGNATURE-----
diff --git a/app-emulation/uade/files/digest-uade-0.91-r1 b/app-emulation/uade/files/digest-uade-0.91-r1
new file mode 100644
index 000000000000..0489ad326287
--- /dev/null
+++ b/app-emulation/uade/files/digest-uade-0.91-r1
@@ -0,0 +1 @@
+MD5 3b7fa0899e3456e0d37c50048685881e uade-0.91.tar.bz2 2117195
diff --git a/app-emulation/uade/files/uade-0.91-bmp-fix.patch b/app-emulation/uade/files/uade-0.91-bmp-fix.patch
new file mode 100644
index 000000000000..97d3f98adc60
--- /dev/null
+++ b/app-emulation/uade/files/uade-0.91-bmp-fix.patch
@@ -0,0 +1,29 @@
+diff -Naur uade-0.91-orig/plugindir/beepmp/uade.c uade-0.91/plugindir/beepmp/uade.c
+--- uade-0.91-orig/plugindir/beepmp/uade.c 2004-07-27 16:22:37.000000000 +0200
++++ uade-0.91/plugindir/beepmp/uade.c 2004-09-09 15:37:24.609571008 +0200
+@@ -305,9 +305,12 @@
+ /* xmms calls this function to check song */
+ static int is_our_file(char *filename) {
+ int ours;
++ const char *prefix = "file://";
+ if(!uade_is_operational) {
+ return FALSE;
+ }
++ if (strncasecmp(filename, prefix, strlen(prefix)) == 0)
++ filename += strlen(prefix);
+ ours = check_my_file(filename, 0, 0);
+ if (ours) {
+ FILE *f = fopen(filename, "rb");
+diff -Naur uade-0.91-orig/src/uade.c uade-0.91/src/uade.c
+--- uade-0.91-orig/src/uade.c 2004-07-27 16:22:37.000000000 +0200
++++ uade-0.91/src/uade.c 2004-09-09 15:38:58.252335144 +0200
+@@ -443,6 +443,9 @@
+ {
+ int bytesread, status;
+ FILE *file;
++ const char *prefix = "file://";
++ if (strncasecmp(name, prefix, strlen(prefix)) == 0)
++ name += strlen(prefix);
+ file = fopen(name, "rb");
+ if (!file) {
+ fprintf(stderr,"uade: couldn't load %s %s\n", expl, name);
diff --git a/app-emulation/uade/uade-0.91-r1.ebuild b/app-emulation/uade/uade-0.91-r1.ebuild
new file mode 100644
index 000000000000..5ba1213a5a7b
--- /dev/null
+++ b/app-emulation/uade/uade-0.91-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-0.91-r1.ebuild,v 1.1 2004/09/09 14:04:23 spock Exp $
+
+inherit eutils
+
+DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation and cloned m68k-assembler Eagleplayer API"
+HOMEPAGE="http://uade.ton.tut.fi/"
+SRC_URI="http://uade.ton.tut.fi/uade/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="xmms sdl alsa oss perl beepmp"
+
+RDEPEND="virtual/libc
+ xmms? ( >=media-sound/xmms-1.2.2
+ x11-libs/gtk+ )
+ sdl? ( media-libs/libsdl )
+ alsa? ( >=media-libs/alsa-lib-1.0.5 )
+ beepmp? ( >=media-sound/beep-media-player-0.7_rc1 )"
+
+DEPEND="${RDEPEND}
+ xmms? ( sys-devel/libtool )"
+
+src_unpack () {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-bmp-fix.patch
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --package-prefix="${D}" \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_with oss) \
+ $(use_with sdl) \
+ $(use_with alsa) \
+ $(use_with xmms) \
+ $(use_with beepmp bmp) \
+ || die "configure failed"
+ emake || die 'emake failed'
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die 'make install failed'
+ dodoc BUGS ChangeLog.txt FIXED ANTIPLANS README PLANS TESTING docs/CREDITS
+
+ find "${D}/usr/share/doc/${PF}/" \
+ \( -name '*.readme' -o \
+ -name '*.txt' -o \
+ -name 'INSTALL*' -o \
+ -name 'README*' -o \
+ -name 'Change*' \) -exec gzip -9 \{\} \;
+ dohtml -r "${D}/usr/share/doc/${PF}/"
+ rm -f "${D}/usr/share/doc/${PF}/"{COPYING,INSTALL.*.gz}
+ rm -f "${D}/usr/share/doc/${PF}/uade-docs/"{*.html,*.png,*.1}
+
+ if ! use perl; then
+ rm -f "${D}/usr/bin/pwrap.pl"
+ fi
+}